You are not logged in.

#1 2017-05-14 12:27:29

flungo
Member
Registered: 2016-01-08
Posts: 2

i2c_hid_get_input: incomplete report

Occasionally when I power on my laptop (ASUS UX310UA) I get the following message spamming the console:

i2c_hid i2c-ELAN1200:00: i2c_hid_get_input: incomplete report 16/16466

The boot does not complete and requires a hard reset (and occasionally with the disconnection of the power supply before powering back on) before it will be able to boot into Linux. I am wondering where I should start in investigating this? Is this a kernel or hardware fault? What can be done to mitigate this?

This only seems to occur after a shutdown when external power is connected. I have never had this error when the power lead is not connected and as mentioned I occasionally have had to unplug the power lead while powered down in order to stop this message. I have not seen this problem on the rare times that I boot into Windows so if its a hardware error, it is either just ignoring the error or the driver deals with the error better.

Since this only happens when turning on the computer, it does not affect usability beyond being a bit of an inconvenience when I turn it on, but obviously, if there is something that can be done I would like to fix it. My suspicion is that when connected to external power the trackpad is not unpowered correctly and so does not shut down, then causing a problem when the machine turns back on and wants to initialise the device.

Photograph of message: https://i.imgur.com/4GGYY9m.jpg

Last edited by flungo (2017-05-14 16:37:49)

Offline

#2 2017-05-14 16:11:57

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,628
Website

Re: i2c_hid_get_input: incomplete report

Read the Code of Conduct and only post thumbnails http://wiki.archlinux.org/index.php/Cod … s_and_code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2018-05-19 21:09:55

ElmrFud
Member
Registered: 2018-05-19
Posts: 1

Re: i2c_hid_get_input: incomplete report

I have this same issue on an ASUS FX503 laptop.  Despite the jpeg being posted, is there any fix for this?  Searches have suggested that it's the touchpad.

Offline

#4 2018-05-20 03:01:07

circleface
Member
Registered: 2012-05-26
Posts: 639

Re: i2c_hid_get_input: incomplete report

Please do not necrobump old threads.  If you are still having the same problem, please start a new thread and include error logs and such so that someone can help you.

Offline

#5 2018-05-20 03:16:31

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,923

Re: i2c_hid_get_input: incomplete report

ElmrFud, circleface is correct,   Please feel free to open a new thread on the topic and link back to this one if you feel it is still appropriate.  This way you will own the new thread.

Closing this old thread.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB