You are not logged in.

#1 2017-05-19 20:32:10

arbacle
Member
Registered: 2015-11-16
Posts: 22

[Solved] SDDM start issues (black screen)

I'm doing a reinstall of my system (because of an SSD upgrade) and I'm having issues setting up SDDM. I have a dual graphics card laptop with Intel and AMD.

On my previous install I did this:

pacman -S xorg-server
pacman -S xorg-xinit
pacman -S xf86-video-intel
pacman -S xf86-video-ati
pacman -S sddm
sddm --example-config > /etc/sddm.conf
systemctl enable sddm
cp /etc/X11/xinit/xinitrc ~/.xinitrc
nano .xinitrc # (comment bottom and add "exec startkde")

I replicated things, but now I'm getting a black screen after the disk check (when sddm is supposed to start). I can login to tty2 and disable sddm.service. When it's disabled I can login at tty1 and use "startx" to start my Plasma session (everything in it is working as expected).

Here's the sddm part from the log:

May 19 22:32:39 hostname sddm[349]: Running display setup script  "/usr/share/sddm/scripts/Xsetup"
May 19 22:32:39 hostname sddm[349]: Display server started.
May 19 22:32:39 hostname sddm[349]: Socket server starting...
May 19 22:32:39 hostname sddm[349]: Socket server started.
May 19 22:32:39 hostname sddm[349]: Greeter starting...
May 19 22:32:39 hostname sddm[349]: Adding cookie to "/var/run/sddm/{4404d264-2ca7-4aad-bd49-e8a053f90b2a}"
May 19 22:32:39 hostname sddm-helper[404]: [PAM] Starting...
May 19 22:32:39 hostname sddm-helper[404]: [PAM] Authenticating...
May 19 22:32:39 hostname sddm-helper[404]: [PAM] returning.
May 19 22:32:39 hostname sddm-helper[404]: pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0)
May 19 22:32:39 hostname systemd[1]: Created slice User Slice of sddm.
May 19 22:32:39 hostname systemd[1]: Starting User Manager for UID 996...
May 19 22:32:39 hostname systemd-logind[342]: New session c1 of user sddm.
May 19 22:32:39 hostname systemd[1]: Started Session c1 of user sddm.
May 19 22:32:39 hostname systemd[406]: pam_unix(systemd-user:session): session opened for user sddm by (uid=0)
May 19 22:32:39 hostname systemd[406]: Reached target Paths.
May 19 22:32:39 hostname systemd[406]: Starting D-Bus User Message Bus Socket.
May 19 22:32:39 hostname systemd[406]: Listening on Sound System.
May 19 22:32:39 hostname systemd[406]: Reached target Timers.
May 19 22:32:39 hostname systemd[406]: Listening on D-Bus User Message Bus Socket.
May 19 22:32:39 hostname systemd[406]: Reached target Sockets.
May 19 22:32:39 hostname systemd[406]: Reached target Basic System.
May 19 22:32:39 hostname systemd[406]: Reached target Default.
May 19 22:32:39 hostname systemd[406]: Startup finished in 17ms.
May 19 22:32:39 hostname systemd[1]: Started User Manager for UID 996.
May 19 22:32:39 hostname sddm[349]: Greeter session started successfully
May 19 22:32:39 hostname sddm-greeter[411]: Reading from "/usr/share/xsessions/plasma.desktop"
May 19 22:32:39 hostname sddm-greeter[411]: inotify_add_watch("/usr/share/wayland-sessions") failed: "No such file or directory"
May 19 22:32:39 hostname sddm-greeter[411]: Connected to the daemon.
May 19 22:32:39 hostname sddm[349]: Message received from greeter: Connect
May 19 22:32:39 hostname sddm-greeter[411]: Loading qrc:/theme/Main.qml...
May 19 22:32:40 hostname sddm-greeter[411]: Adding view for ":0.0" QRect(0,0 1366x768)
May 19 22:32:40 hostname systemd[406]: Started D-Bus User Message Bus.
May 19 22:32:40 hostname sddm-greeter[411]: QXcbConnection: XCB error: 148 (Unknown), sequence: 177, resource id: 0, major code: 140 (Unknown), minor code: 20
May 19 22:32:40 hostname sddm-greeter[411]: Message received from daemon: Capabilities
May 19 22:32:40 hostname sddm-greeter[411]: Message received from daemon: HostName

I'm out of ideas how to fix this, so if somebody can help, I'll be thankful.

Last edited by arbacle (2017-05-23 19:13:42)

Offline

#2 2017-05-19 21:48:34

luceph
Member
From: Ontario, Canada
Registered: 2017-05-06
Posts: 27

Re: [Solved] SDDM start issues (black screen)

Could you post your

cat /etc/sddm.conf

Last edited by luceph (2017-05-19 21:48:58)

Offline

#3 2017-05-19 22:28:40

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [Solved] SDDM start issues (black screen)

Here it is:

[Autologin]
Relogin=false
Session=
User=

[General]
HaltCommand=/usr/bin/systemctl poweroff
Numlock=on
RebootCommand=/usr/bin/systemctl reboot

[Theme]
Current=breeze
CursorTheme=breeze_cursors
FacesDir=/usr/share/sddm/faces
ThemeDir=/usr/share/sddm/themes

[Users]
DefaultPath=/bin:/usr/bin:/usr/local/bin
HideShells=
HideUsers=
MaximumUid=60000
MinimumUid=1000
RememberLastSession=true
RememberLastUser=true

[WaylandDisplay]
SessionCommand=/usr/share/sddm/scripts/wayland-session
SessionDir=/usr/share/wayland-sessions

[XDisplay]
DisplayCommand=/usr/share/sddm/scripts/Xsetup
DisplayStopCommand=/usr/share/sddm/scripts/Xstop
MinimumVT=1
ServerArguments=-nolisten tcp
ServerPath=/usr/bin/X
SessionCommand=/usr/share/sddm/scripts/Xsession
SessionDir=/usr/share/xsessions
XauthPath=/usr/bin/xauth
XephyrPath=/usr/bin/Xephyr

The files in my /usr/share/sddm/scripts/ directory are identical with the ones on my old HDD, so the issue is not there.

Offline

#4 2017-05-20 07:58:40

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [Solved] SDDM start issues (black screen)

Okay, new post, because I did some poking around and have new info.

When I enable sddm.service and start sddm, on a fresh boot I get the issue. But if I do "systemctl stop sddm" and then "systemctl start sddm", the greeter starts up and everything is as normal.

So the most interesting part is that on boot the screen freezes at the output of fsck. If I go to tty2 (without logging in) and then go back to tty1 the screen is now black. If I just enter my password the system is starting. Also (just tried) - if I enter my password on the "stuck" output of fsck, I'm again logged in. So the greeter is there, but I can't see it for some reason - the screen is not refreshing from the console output to the greeter.

I've tried a different theme, also deleted sddm's cache - no dice.

Offline

#5 2017-05-20 13:39:43

luceph
Member
From: Ontario, Canada
Registered: 2017-05-06
Posts: 27

Re: [Solved] SDDM start issues (black screen)

Append

plasma.desktop

to

Session = 

.

Offline

#6 2017-05-20 19:48:34

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [Solved] SDDM start issues (black screen)

Unfortunately this doesn't solve the issue. I'm starting to think that there's a more deep problem than SDDM (somewhere in X?), because of the issue mentioned in my last post.

After the fsck output the screen blinks (through black) and freezes on the text output. When I type my password on this "screen", I get logged in and the session starts as expected. So the screen is not refreshing to show the greeter.

Offline

#7 2017-05-20 20:26:41

seth
Member
Registered: 2012-09-03
Posts: 31,885

Re: [Solved] SDDM start issues (black screen)

is your hostname actually "hostname"? Are you using networkmanager?

Offline

#8 2017-05-21 11:00:16

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [Solved] SDDM start issues (black screen)

No, my hostname is different smile

[arbacle@hostname ~]$ pacman -Q networkmanager
networkmanager 1.8.0-1

Offline

#9 2017-05-21 14:32:56

seth
Member
Registered: 2012-09-03
Posts: 31,885

Re: [Solved] SDDM start issues (black screen)

Please don't do that or at least clearly indicate the redaction (in this case, an invalid hostname + networkmanager is a splendid recipe to make any X11 client abort if the X11 server was started before NM altered hostname and /etc/hosts) - in general there's no need to stash your hostname (unless it's the name of your wifes best friend, of course ;-)

Please post your xorg log and the output of glxinfo. Would you get a "no signal" OSD if there wasn't any?

Offline

#10 2017-05-22 20:21:41

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [Solved] SDDM start issues (black screen)

Hm, sorry about that didn't know about it, will keep it in mind. On the matter of keeping my hostname private, I guess I'm using a bit too thick tinfoil for my hat smile

The logs:
Xorg - https://pastebin.com/Z1GEbPvX
glxinfo - https://pastebin.com/7w6Fgkjh

I'm seeing errors about missing stuff from the Xorg config - aren't we past that point? I thought that nowadays things are happening automagically with Xorg.

Offline

#11 2017-05-22 20:59:17

seth
Member
Registered: 2012-09-03
Posts: 31,885

Re: [Solved] SDDM start issues (black screen)

amd/intel prime setup - try https://bbs.archlinux.org/viewtopic.php … 4#p1471264

edit: though it's madness, the company is still called "amd", not "mad" ;-)

Last edited by seth (2017-05-23 19:37:09)

Offline

#12 2017-05-23 19:13:27

arbacle
Member
Registered: 2015-11-16
Posts: 22

Re: [Solved] SDDM start issues (black screen)

Wooo! That solves the problem (3 seconds works for my setup).

The delay is a bit disappointing (moots the point of the SSD), but at least I have a greeter.

@seth, thank you very much for the help!

Offline

#13 2020-08-26 07:34:54

FirstAirBender
Member
Registered: 2019-09-13
Posts: 14

Re: [Solved] SDDM start issues (black screen)

I have an Nvidia graphics card, so what solved the problem for me was to follow the guide here: https://wiki.archlinux.org/index.php/NV … timus#SDDM

Offline

#14 2020-08-26 07:46:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,029

Re: [Solved] SDDM start issues (black screen)

Offline

Board footer

Powered by FluxBB