You are not logged in.

#1 2017-05-23 19:56:12

matyilona200
Member
Registered: 2012-06-21
Posts: 77

ACPI errors on boot after update to kernel 4.11.2-1

I updated the linux package to 4.11.2.-1 from 4.10.13-1 (havent updated for a while, been very busy lately), rebooted, but archlinux never started.
It drops down to a tty, where my keyeboard doesn't work (keyboard hook is at the end of my modules list). I get theese
errors.
If I remove the resume kernel parameter the results are similar, the lvm devices are not found.
The initramfs image has a 2 in its name, so the Korora install can use the one without a number, apart from that "2" my mkinitcpio configs are untouched.
I have a lenovo G585 laptop.
I'm dualbooting an old Korora install (4.6.something kernel), which starts, so it's probably not a hardware issue.

I have my bachelors thesis due in less then a week, so I don't have a lot of time to investigate it right now.
I'll try downgrading the kernel (linux, linux-headers, acpi_cal) and if that works not touch anything till the thesis is handed in.

Edit: downgrading acpi_call as the latest version was dependent on the latest linux, sounds realted any way

Last edited by matyilona200 (2017-05-23 20:01:01)

Offline

#2 2017-05-23 22:07:39

matyilona200
Member
Registered: 2012-06-21
Posts: 77

Re: ACPI errors on boot after update to kernel 4.11.2-1

Downgrading seems to have fixed the issue.

Offline

#3 2017-05-24 17:34:03

raindev
Member
From: Europe
Registered: 2016-07-27
Posts: 8
Website

Re: ACPI errors on boot after update to kernel 4.11.2-1

I also got ACPI errors after upgrading to 4.11.2-1-ARCH from 4.9.28-1-lts. Mine are different though and the system continues to boot successfully:

May 24 18:56:07 machine kernel: ACPI Error: Needed type [Reference], found [Integer] ffff88045c4f12d0 (20170119/exresop-103)
May 24 18:56:07 machine kernel: ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/dswexec-461)
May 24 18:56:07 machine kernel: ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff88045e8e73c0), AE_AML_OPERAND_TYPE (20170119/psparse-543)

Offline

#4 2017-05-24 19:35:35

seth
Member
Registered: 2012-09-03
Posts: 33,538

Re: ACPI errors on boot after update to kernel 4.11.2-1

This rather looks like an lvm issue - why do you think it's related to ACPI?
Does it work with "acpi=off"?

Online

#5 2017-05-25 06:41:32

Henkieq
Member
Registered: 2017-05-25
Posts: 2

Re: ACPI errors on boot after update to kernel 4.11.2-1

Same issue here after upgrading Linux from 4.10.13-1 to 4.11.2-1 and linux-firmware from 20170309.695f2d6-1 to 20170422.ade8332-1 on a Thinkpad X250:

[    0.510671] ACPI: Added _OSI(Module Device)
[    0.510673] ACPI: Added _OSI(Processor Device)
[    0.510675] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.510677] ACPI: Added _OSI(Processor Aggregator Device)
[    0.510696] ACPI : EC: EC started
[    0.510697] ACPI : EC: interrupt blocked
[    0.513366] ACPI: \: Used as first EC
[    0.513370] ACPI: \: GPE=0x25, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.513373] ACPI: \: Used as boot ECDT EC to handle transactions
[    0.522379] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.533951] ACPI Error: Needed type [Reference], found [Integer] ffff88022391c480 (20170119/exresop-103)
[    0.533972] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/dswexec-461)
[    0.533988] ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff8802250e6fc8), AE_AML_OPERAND_TYPE (20170119/psparse-543)
[    0.534714] ACPI: Dynamic OEM Table Load:
[    0.534739] ACPI: SSDT 0xFFFF880223F2D800 0005AA (v01 PmRef  ApIst    00003000 INTL 20120711)
[    0.535815] ACPI: Dynamic OEM Table Load:
[    0.535834] ACPI: SSDT 0xFFFF8802238D7600 000119 (v02 PmRef  ApCst    00003000 INTL 20120711)
[    0.538183] ACPI : EC: EC stopped

Last edited by Henkieq (2017-05-25 06:43:53)

Offline

#6 2017-05-25 14:01:42

Serioga
Member
Registered: 2017-05-25
Posts: 4

Re: ACPI errors on boot after update to kernel 4.11.2-1

Same here...
4.11.2-1-ARCH/Thinkpad T540p

archlnx kernel: ACPI Error: Needed type [Reference], found [Integer] ffff880234105750 (20170119/exresop-103)
archlnx kernel: ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/dswexec-461)
archlnx kernel: ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff8802358dca00), AE_AML_OPERAND_TYPE (20170119/psparse-543)

Offline

#7 2017-05-25 22:58:58

a1rolo
Member
Registered: 2016-01-27
Posts: 7

Re: ACPI errors on boot after update to kernel 4.11.2-1

Same here, Laptop lenovo Thinkpad T450

ACPI Error: Needed type [Reference], found [Integer] ffff8802241db5e8 (20170119/exresop-103)
ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/dswexec-461)
ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff8802254e6ca8), AE_AML_OPERAND_TYPE (20170119/psparse-543)

Offline

#8 2017-05-25 23:03:53

loqs
Member
Registered: 2014-03-06
Posts: 15,493

Re: ACPI errors on boot after update to kernel 4.11.2-1

@matyilona200 you might want to remove ACPI errors from the thread title and add fails to boot.
@raindev @Henkieq @Serioga @a1rolo unless your systems fails to boot under 4.11.2-1 this would seem to be a different issue.

Offline

#9 2017-07-18 04:34:41

TJM
Member
Registered: 2016-09-18
Posts: 104

Re: ACPI errors on boot after update to kernel 4.11.2-1

Same issue on ThinkPad T440. I am 100% sure that I am just using ext4 without LVM.

[    0.506940] ACPI Error: Needed type [Reference], found [Integer] ffff88013a8e5ca8 (20170119/exresop-103)
[    0.506962] ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/dswexec-461)
[    0.506978] ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff88013a8db988), AE_AML_OPERAND_TYPE (20170119/psparse-543)

Offline

#10 2017-07-18 06:37:07

seth
Member
Registered: 2012-09-03
Posts: 33,538

Re: ACPI errors on boot after update to kernel 4.11.2-1

See comment #8 - does the system still boot?

Online

#11 2017-07-23 15:23:42

gilcu3
Member
Registered: 2011-04-12
Posts: 10

Re: ACPI errors on boot after update to kernel 4.11.2-1

seth wrote:

See comment #8 - does the system still boot?

I'm having the same acpi error as others here, and yes the system boots, but I don't know if that means something (acpi related) wont work or not. We would appreciate clarifications on what it could be smile. I have observed it happens with linux-zen 4.11.8-1 and not with linux 4.11.9-1.

Offline

#12 2017-07-23 15:38:10

seth
Member
Registered: 2012-09-03
Posts: 33,538

Re: ACPI errors on boot after update to kernel 4.11.2-1

Then you're off-topic ;-)
The ACPI errors spill into the boot messages since some kernel versions - they've been there before, you just didn't see them.
There're various threads about this on this forum.

What they mean is, that board vendors implement ACPI by fiddling around until it works with their currently installed windows version. Crap situation, but the warning per se is nothing to worry about. It may however explain ACPI disfunctionality (S3/S4, rebooting, special keys on notebooks, .....)

Online

#13 2017-07-23 15:47:31

gilcu3
Member
Registered: 2011-04-12
Posts: 10

Re: ACPI errors on boot after update to kernel 4.11.2-1

I had seen apci errors before (AE_NOT_FOUND for example), but exactly this one, it's the first time I see it. So, for now no big worries about it, thanks

Offline

Board footer

Powered by FluxBB