You are not logged in.

#1 2017-06-07 03:05:57

libra_kevin
Member
Registered: 2016-09-29
Posts: 3

Perl 5.26 breaks some dependencies

I'm trying to update the packages today, but seeing the following error:

[taot:fastai-courses][master]$ sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: gnome-vfs-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: gnomecanvas-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gnome2-wnck: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-goo-canvas: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gtk2-imageview: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gtk2-unique: installing perl (5.26.0-1) breaks dependency 'perl<5.25'

Thanks!

Offline

#2 2017-06-07 03:41:49

mcmillan
Member
Registered: 2006-04-06
Posts: 727

Re: Perl 5.26 breaks some dependencies

All are AUR packages, so you need to remove them before updating, then  need to fix PKGBUILDS and rebuild with the new version of perl.

Offline

#3 2017-06-07 03:45:08

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,318
Website

Re: Perl 5.26 breaks some dependencies

Not a Pacman issue, moving to AUR Issues...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#4 2017-06-07 13:33:36

dr34m
Member
Registered: 2016-07-28
Posts: 47

Re: Perl 5.26 breaks some dependencies

try this to search for broken perl packages:

https://github.com/BlackArch/blackarch/ … ackages.sh

edit: update version:

https://github.com/scottgreenup/desktop … ackages.sh

Last edited by dr34m (2017-06-07 13:39:00)

Offline

#5 2017-06-07 13:53:12

mcstayinskool
Member
Registered: 2015-05-18
Posts: 9

Re: Perl 5.26 breaks some dependencies

Running into the same issue. I never installed those packages directly, so they must have come as a dependency to some other AUR package. Wish I knew which one...

I'm investigating solutions, I will post to this thread if I find something that works for me.

Offline

#6 2017-06-07 14:41:28

Scorpick
Member
Registered: 2016-02-16
Posts: 20

Re: Perl 5.26 breaks some dependencies

Offline

#7 2017-06-07 18:17:59

sfabius
Member
Registered: 2007-07-07
Posts: 130

Re: Perl 5.26 breaks some dependencies

I get this for perl-goo-canvas and perl-gtk2-imageview:

$ yaourt -Su
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: perl-goo-canvas: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gtk2-imageview: installing perl (5.26.0-1) breaks dependency 'perl<5.25'

I did not install these. So I'd like to ignore whatever package is trying to install the offending ones. Both are dependencies of shutter and gscan2pdf. But I have neither installed. I tried installing shutter, but there were even more perl warnings. I installed gscan2pdf; for some reason yaourt decided that perl-goo-canvas was already installed. In any case, how can I figure out what package is requiring these packages. I only see shutter and gscan2pdf on the AUR entry for perl-goo-canvas.

Edit: I get the same error using pacman -Su.

Last edited by sfabius (2017-06-07 18:19:27)

Offline

#8 2017-06-07 18:25:15

mcstayinskool
Member
Registered: 2015-05-18
Posts: 9

Re: Perl 5.26 breaks some dependencies

Good info Scorpick. I uninstalled shutter (gnome-screenshot, aliased to screenshot, for my use is good enough). However, I still get the perl dependency failure. There's something else using those libs, but I don't know how to find it (or them).

:: Synchronizing package databases...
core is up to date
extra                               1667.5 KiB  4.21M/s 00:00 [##################################] 100%
community                              3.8 MiB  4.76M/s 00:01 [##################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gnome-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: gnome-vfs-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: gnomecanvas-perl: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gnome2-wnck: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-goo-canvas: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gtk2-imageview: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gtk2-unique: installing perl (5.26.0-1) breaks dependency 'perl<5.25'

Offline

#9 2017-06-07 18:26:15

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,318
Website

Re: Perl 5.26 breaks some dependencies

sfabius wrote:

I get the same error using pacman -Su.

pacman -Syu

...and remove or rebuild anything perl-related not managed by pacman.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#10 2017-06-07 18:27:21

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,318
Website

Re: Perl 5.26 breaks some dependencies

mcstayinskool wrote:

There's something else using those libs, but I don't know how to find it (or them).

man pacman

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#11 2017-06-07 20:26:40

mcstayinskool
Member
Registered: 2015-05-18
Posts: 9

Re: Perl 5.26 breaks some dependencies

man pacman

Fair enough, but after man-ning up,  I'm not seeing these packages as being required by anything. I don't install anything via anything but pacman, so I'm at a loss.

I'll let this sit for a few days, see if someone else comes up with a specific solution.

Offline

#12 2017-06-07 22:21:22

loqs
Member
Registered: 2014-03-06
Posts: 7,743

Re: Perl 5.26 breaks some dependencies

mcstayinskool wrote:

I'm not seeing these packages as being required by anything.

So how did you try removing "gnome-perl gnome-vfs-perl gnomecanvas-perl perl-gnome2-wnck perl-goo-canvas perl-gtk2-imageview perl-gtk2-unique"?

Offline

#13 2017-06-08 06:57:39

ivan.masich
Member
Registered: 2016-11-29
Posts: 6

Re: Perl 5.26 breaks some dependencies

I had similar problem:

error: failed to prepare transaction (could not satisfy dependencies)
:: perl-gnome2-wnck: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
:: perl-gtk2-unique: installing perl (5.26.0-1) breaks dependency 'perl<5.25'

Then I removed shutter and after removing I also removed all packages that were in list (after each removal) "==> Packages no longer required by any installed package:":

yaourt -R shutter
==> Packages no longer required by any installed package:
    gnome-perl perl-file-copy-recursive perl-file-which perl-gnome2-wnck perl-goo-canvas perl-gtk2-imageview perl-gtk2-unique perl-image-exiftool perl-json-xs perl-locale-gettext perl-path-class perl-proc-processtable perl-proc-simple 
    perl-sort-naturally perl-www-mechanize perl-xml-simple

yaourt -R gnome-perl perl-file-copy-recursive perl-file-which perl-gnome2-wnck perl-goo-canvas perl-gtk2-imageview perl-gtk2-unique perl-image-exiftool perl-json-xs perl-locale-gettext perl-path-class perl-proc-processtable perl-proc-simple perl-sort-naturally perl-www-mechanize perl-xml-simple
==> Packages no longer required by any installed package:
    gnome-vfs-perl gnomecanvas-perl goocanvas1 gtkimageview libgnomeui libunique libwnck perl-canary-stability perl-types-serialiser

yaourt -R gnome-vfs-perl gnomecanvas-perl goocanvas1 gtkimageview libgnomeui libunique libwnck perl-canary-stability perl-types-serialiser
==> Packages no longer required by any installed package:
    gtk2-perl libbonoboui

yaourt -R gtk2-perl libbonoboui
==> Packages no longer required by any installed package:
    libgnome libgnomecanvas pango-perl

yaourt -R libgnome libgnomecanvas pango-perl
==> Packages no longer required by any installed package:
    cairo-perl glib-perl gnome-vfs-nosmb libart-lgpl libbonobo libgnome-data

yaourt -R cairo-perl glib-perl gnome-vfs-nosmb libart-lgpl libbonobo libgnome-data
==> Packages no longer required by any installed package:
    gnome-mime-data orbit2

yaourt -R gnome-mime-data orbit2
==> Packages no longer required by any installed package:
    libidl2

yaourt -R libidl2

Then I didn't see original error "error: failed to prepare transaction (could not satisfy dependencies)" and packages upgrade was successful and finally I installed shutter again. Scorpick thank you for your help.

-------
UPDATE
When I tried to install shutter again I got error during building package "perl-gtk2-imageview", in AUR comments related to this package you can find solution, here is what you should do:

PhotonX commented on 2017-06-06 20:31 wrote:

Please bump the pkgrev (after today's perl update the package needs a rebuild). Also add PERL_USE_UNSAFE_INC=1 before the make command (so it is
PERL_USE_UNSAFE_INC=1  make

rather than just make. See also https://bbs.archlinux.org/viewtopic.php?id=226971 for reference.

Last edited by ivan.masich (2017-06-08 12:28:14)

Offline

Board footer

Powered by FluxBB