You are not logged in.

#1 2004-01-14 17:59:22

rayzorblayde
Member
Registered: 2004-01-04
Posts: 67

how to enable mit-shm shared memory in imlib?

I get a warning every time i start enlightenment telling me to enable mit-shm shared memory in my imlib config, but i have no idea how to do that. i know i have an executable file in /usr/bin called imlib-config, but there really isn't any help files associated with it (man or --help or -h). so, anyone know how i can enable shared memory?

here is the full warning:

Warning!

You seem to be running Enlightenment over a network Connection or on
an X Server that does not support Shared Memory, or you have disabled
MIT-SHM Shared memory in your Imlib configuration.  This means the
Enlightenment Pager will perform slowly and use more system resources
than it would when Shared Memory is available.

To improve performance please either enable MIT-SHM Shared Memory in
your Imlib config, if you disabled it, or disable Player snapshots.


That's pretty much all I have to go on. It has to do with the pager thing, and i could easily disable it im' sure, but i want to enable the shared memory in case any other progs need it, but just aren't saying so.

thanks.


loading.... please wait....

Offline

#2 2004-01-15 03:03:38

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: how to enable mit-shm shared memory in imlib?

i have posted a bug regarding this..... unitl you mentioned it i had forgotten that this issue had been raised before. since doing a search produced no answers for you i filed the bug. i am not convinced that it is something the package maintianer forgot but regardless we should be able to find out what to do if it is not a bug in the package.

thanks for bringing this issue up again.


AKA uknowme

I am not your friend

Offline

#3 2004-01-15 20:19:17

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: how to enable mit-shm shared memory in imlib?

Hi,

Im using (well, not right now, as im on vacations) E too, and run into the same issue.

Here are the links to the previous posts i made:

Problems with IMLIB and MIT-SHM:
http://bbs.archlinux.org/viewtopic.php? … ight=imlib

To the IMLIB manteiner:
http://bbs.archlinux.org/viewtopic.php? … ight=imlib


I also searched trough the development mailing list at E, and googled to death, but i coulndt find how to make it.

When i entered the E16 IRC channel at freenode, i asked for some help and i was told that some other ppl from Arch had the same issues and they couldnt solve it (didnt know what or how).

So i decided to go with the last thing i could do, _recompile_ Imlib:
I downloaded the sources from www.enlightenment.org and used the PKGBUILD from ABS (i thinks its in /var/abs/....) for them, edited it to name the new compilation version "-4" and runned makepkg then i uninstalled Imlib with pacman -Rd imlib and installed the new pkg with pacman -A imlib-x.xx-4.tar.gz

Now everything its working just fine, so i dont know what went wrong with the official compilation.

Just in case, i did some testing and im not "totally" sure that the working version was the one with the patch found next to the PKGBUILD file, so if the one compiled with the patch doesnt work, try without it.

If you have any questions just ask, i cant be more explicit right now because i dont have my Arch Linux box with me.[/b]


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#4 2004-01-17 06:22:34

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: how to enable mit-shm shared memory in imlib?

imlib has been rebuilt please instal and see if the problem persists.


AKA uknowme

I am not your friend

Offline

#5 2004-01-20 06:14:20

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: how to enable mit-shm shared memory in imlib?

I will try it a soon as i get home (in a couple of weeks that is).


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#6 2004-01-20 15:28:26

Guest
Guest

Re: how to enable mit-shm shared memory in imlib?

ok, i did a pacman -S imlib

it said it was up to date, but i 'upgraded' anyway.

still have the same problem.  should i be running a different command to update it?

#7 2004-01-20 15:30:07

rayzorblayde
Member
Registered: 2004-01-04
Posts: 67

Re: how to enable mit-shm shared memory in imlib?

sorry, ^^^^Guest^^^^^ was me


loading.... please wait....

Offline

#8 2004-01-20 16:15:56

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: how to enable mit-shm shared memory in imlib?

well if the version in the repository matches the version in your system you (the rel number should be different at least) you could try using the sync option when running pacman.


AKA uknowme

I am not your friend

Offline

#9 2004-01-20 16:45:10

rayzorblayde
Member
Registered: 2004-01-04
Posts: 67

Re: how to enable mit-shm shared memory in imlib?

sarah31 wrote:

well if the version in the repository matches the version in your system you (the rel number should be different at least) you could try using the sync option when running pacman.

thanks, i think that worked.  i restarted E and i didn't get the warning message.

wahoo! smile


loading.... please wait....

Offline

#10 2004-01-27 04:41:26

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: how to enable mit-shm shared memory in imlib?

Sarah i wanted to know if you made any changes to the pkg, as i rebuilded it with the same PKGBUILD and patch as the original and im having no problems, but, just in case im missing something...


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#11 2004-01-27 05:19:34

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: how to enable mit-shm shared memory in imlib?

i personally did nothing at all except file the bug. i assume that the package was just recompiled possibly had a configure option. i dunno i didn't look.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB