You are not logged in.

#1 2017-06-14 21:49:59

jugs
Member
Registered: 2007-12-05
Posts: 39

[SOLVED] GNOME: Can't lock screen

This is arguably a newbie corner question but I can't seem to understand why it's no longer working.

I'm running all the $currenversion gnome packages, the keybinding is still what it always was (Super + L). All the other Super + $key keybindings work no issue. Except when I press Super + L nothing happens...

I don't have any other applications running that would override the key binding, and on their own both keys work as well. Any suggestions?

Last edited by jugs (2017-06-15 02:14:34)

Offline

#2 2017-06-14 23:56:50

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,271

Re: [SOLVED] GNOME: Can't lock screen

Check your journal if some GDM error pops up.

Online

#3 2017-06-15 00:07:37

jugs
Member
Registered: 2007-12-05
Posts: 39

Re: [SOLVED] GNOME: Can't lock screen

V1del wrote:

Check your journal if some GDM error pops up.

Unfortunately nothing in the journal, thanks for the suggestion

Offline

#4 2017-06-15 01:31:47

Ropid
Member
Registered: 2015-03-09
Posts: 898

Re: [SOLVED] GNOME: Can't lock screen

Do you use GDM to log in? The screensaver and lock-screen features need GDM running and won't work if you start Gnome with startx or lightdm, etc.

Offline

#5 2017-06-15 01:54:21

jugs
Member
Registered: 2007-12-05
Posts: 39

Re: [SOLVED] GNOME: Can't lock screen

Ropid wrote:

Do you use GDM to log in? The screensaver and lock-screen features need GDM running and won't work if you start Gnome with startx or lightdm, etc.

Yessir, using GDM to start a GNOME Wayland session.

Offline

#6 2017-06-15 02:08:38

jugs
Member
Registered: 2007-12-05
Posts: 39

Re: [SOLVED] GNOME: Can't lock screen

Just saw this error in the journal finally:

gnome-shell[1041]: Screen lock is locked down, not locking

In the settings, under privacy the Screen Lock is set to Off? However, when I click on it to try and turn it on it is all greyed out.

Used dconf-editor and went to org.gnome.desktop
Saw that disable-lock-screen was enabled, and disabled it from there.
Everything is back to normal. Thanks for the support!

Last edited by jugs (2017-06-15 02:13:55)

Offline

#7 2018-10-03 06:32:16

m3thodic
Member
Registered: 2004-08-24
Posts: 66

Re: [SOLVED] GNOME: Can't lock screen

Thanks @jugs, mine was greyed out as well but going through dconf-editor fixed it. Back to normal!

Cheers.

Offline

#8 2018-10-03 08:50:01

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,271

Re: [SOLVED] GNOME: Can't lock screen

Glad to hear this still helped you, however please don't necrobump a year old thread: https://wiki.archlinux.org/index.php/Co … bumping.22

Online

Board footer

Powered by FluxBB