You are not logged in.

#1 2017-06-22 19:02:51

jucasu1960
Member
From: Asturias
Registered: 2014-09-06
Posts: 1
Website

Intentando compilar aplicaciones... obtengo error

***********************
application/california-application.vala:58.5-67.6: warning: the modifier `static' is not applicable to constants
host/host-main-window.vala:74.5-84.6: warning: the modifier `static' is not applicable to constants
mv -f .deps/california-california-resources.Tpo .deps/california-california-resources.Po
Compilation failed: 0 error(s), 2 warning(s)
make[2]: *** [Makefile:4649: california_vala.stamp] Error 1
make[2]: se sale del directorio '/tmp/yaourt-tmp-jcampos/aur-california/src/california-0.4.0/src'
make[1]: *** [Makefile:561: all-recursive] Error 1
make[1]: se sale del directorio '/tmp/yaourt-tmp-jcampos/aur-california/src/california-0.4.0'
make: *** [Makefile:414: all] Error 2
==> ERROR: Se produjo un fallo en build().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar california.
==> ¿Reiniciar la compilación de california? [s/N]
***********************
Archlinux(64)  + gnome en un i3 con 8Gb de Ram

Alguna idea ...?

Gracias

Juan desde Asturias

Offline

#2 2017-06-22 21:55:47

Alber
Member
From: Spain - España
Registered: 2011-11-11
Posts: 205

Re: Intentando compilar aplicaciones... obtengo error

Hola Juan

No tengo ni idea de cual puede ser la razón del error.
Quizá alguien que sepa más sobre compilar programas le sería de ayuda mostrar qué instrucciones has usado y cuál es el proceso que has seguido.
Por los mensajes, veo un aur, por lo que entiendo que estás construyendo un paquete desde el PKGBUILD.

Leyendo los comentarios que hay en la página:

mahe wrote:

Replacing "static const" by "const" solved the problem for me.
Reemplazando "static const" por "const" me resolvió el problema.

--- a/PKGBUILD
+++ b/PKGBUILD.fixed
@@ -19,6 +19,8 @@
./configure \
--prefix=/usr
sed -i 's#californiadocdir = ${prefix}#californiadocdir = ${datadir}#g' Makefile
+ sed -i 's/static const/const/' src/host/host-main-window.vala
+ sed -i 's/static const/const/' src/application/california-application.vala
make
}

Que más o menos es ir al ./configure del PKGBUILD y añadir las dos líneas que tienen el + delante.

./configure \
    --prefix=/usr
sed -i 's#californiadocdir = ${prefix}#californiadocdir = ${datadir}#g' Makefile
sed -i 's/static const/const/' src/host/host-main-window.vala
sed -i 's/static const/const/' src/application/california-application.vala

Otra opción que leo es:

pokulo wrote:

adding "--enable-fatal=no" to the ./configure call in PKGBUILD fixed this problem as well

Que supongo es añadir --enable-fatal=no en la misma línea donde pone --prefix=/usr

./configure \
    --prefix=/usr --enable-fatal=no
sed -i 's#californiadocdir = ${prefix}#californiadocdir = ${datadir}#g' Makefile
make

P.D. Puedes usar las etiquetas de BBCode para que el post quede más claro.

Offline

Board footer

Powered by FluxBB