You are not logged in.

#1 2017-07-04 08:00:31

Sxt
Member
Registered: 2017-07-04
Posts: 5

[SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

Hello,

I've finally decided to make the switch from ubuntu to archlinux on my laptop where I had both Ubuntu and Windows 10. I installed arch following the wiki guide on my ssd using the partitions already there from Ubuntu. Unfortunately I cannot manage to have grub shows Windows 10, only archlinux is shown. It must be a problem of installation/configuration of my arch because the dual boot was working fine with ubuntu before. I have tried every single possible solution of this forum I think but did not manage to make it work. Part of the difficulty is that I don't think I am using UEFI and most solutions regard UEFI. Two reasons support this : I don't think I have an EFI partion from my previous installation (see below) and when doing "ls /sys/firmware/efi/efivars" while on the usb for the installation, the folder did not exist.

My laptop was new and came with FreeBSD so windows was not preinstalled.

One point worth noting is that I did not do the following step in the installation guide because I do not remember having such a parition for ubuntu: (Problem might come frome this, I wanted to make sure I did not break my Windows install though)

# mkdir /mnt/boot
# mount /dev/sda2 /mnt/boot

My drives are partionned like this:

sda
|_sda1   100M   NTFS    (boot flag on)
|_sda2   80G    NTFS    (My windows 10 installation)
|_sda3   872M   NTFS    (diag flag on)
|_sda4   43G    ext4    (My arch installation)


sdb
|_sdb1   535G   NTFS   (I use it for Windows storage)
|_sdb2   2G     vfat   (called HP_TOOLS, I think it is an HP recovery partition, not a big fan of this but still it was recommended)
|_sdb3   48G    ext4   (not used right now)
|_sdb4   16G    swap   (archlinux swap) 

Summary of my steps for the installation
1. Made the USB using Rufus on Windows
2. Installation of arch. Reboot.
3. Here I got grub rescue
4. Boot back on USB
5. arch-chroot and install GRUB following wiki
6. Tries reinstalling GRUB booting on arch directly

Thank you for your help! If you need any more informations, please feel free to ask me.

Last edited by Sxt (2017-07-05 19:55:39)

Offline

#2 2017-07-04 08:19:48

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#3 2017-07-04 12:04:35

illuminati
Member
Registered: 2017-07-03
Posts: 7

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

Hello Sxt, You can try out reinstalling windows efi files through the installation medium.
insert the windows installation media, open the 'repair the pc' option
check the Troubleshoot option
open the command prompt and type in these commands

bootrec.exe/scanos

bootrec.exe/rebuildbcd

bootrec.exe/fixboot

bootrec.exe/fixmbr

reboot your pc - it will normally boot into your windows installation
goto bios setup and change boot preference to arch

after setting them up, open a terminal in arch and type in     -     sudo update-grub

Offline

#4 2017-07-04 14:22:41

Sxt
Member
Registered: 2017-07-04
Posts: 5

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

Did not work unfortunately I still see archlinux only, I did the following steps:
1. restored Windows bootloader with bootrec.exe /FixMbr and bootrec.exe /FixBoot
2. turned hibernation off
3. booted on usb, arch-chroot and reinstall grub + generate configuration files
4. Did the same as 3 in my archlinux installation directly just in case it would have any differences

illuminati wrote:

goto bios setup and change boot preference to arch
after setting them up, open a terminal in arch and type in     -     sudo update-grub

What do you mean by boot preference? Both arch and Windows are on the same disk

Last edited by Sxt (2017-07-04 14:23:33)

Offline

#5 2017-07-04 15:21:01

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

Do you have os-prober installed?


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#6 2017-07-04 15:55:56

Sxt
Member
Registered: 2017-07-04
Posts: 5

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

Yes I do have os-prober installed.

Offline

#7 2017-07-05 11:53:46

illuminati
Member
Registered: 2017-07-03
Posts: 7

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

What do you mean by boot preference? Both arch and Windows are on the same disk

Yeah! that y u need to set 1st boot preference to arch linux....
Did u try the installation media?
I had the same problem with arch install despite having the os-prober installed.....
Just go through the steps and it will work.....

Offline

#8 2017-07-05 15:07:53

Sxt
Member
Registered: 2017-07-04
Posts: 5

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

illuminati wrote:

What do you mean by boot preference? Both arch and Windows are on the same disk

Yeah! that y u need to set 1st boot preference to arch linux....
Did u try the installation media?
I had the same problem with arch install despite having the os-prober installed.....
Just go through the steps and it will work.....

I still don't know what you mean by 1st boot preference to arch linux. As far as I know in the bios you can only specify which disk you want to boot by default. Furthermore grub-update is not a command on Arch.

Offline

#9 2017-07-05 18:39:22

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

You could always skip auto detection and just drop your custom entry/script in /etc/grub.d. Personally I'm not much of a fan of automagic detections and I manage grub.cfg manually.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#10 2017-07-05 19:53:58

Sxt
Member
Registered: 2017-07-04
Posts: 5

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

R00KIE wrote:

You could always skip auto detection and just drop your custom entry/script in /etc/grub.d. Personally I'm not much of a fan of automagic detections and I manage grub.cfg manually.

Thank you very much it is working!

If anyone is wondering here is the menuentry of my custom file

menuentry "Windows 10" {
   insmod ntfs
   insmod ntldr
   insmod part_msdos
   insmod search_fs_uuid
   search --no-floppy --fs-uuid --set=root UUID_OF_MY_DISK
   ntldr /bootmgr
}

If you get an error "cannot find bootmgr", repair the mgr of your windows and reinstall grub + generate the config files.

Offline

#11 2017-07-21 22:31:37

vegangaro
Member
Registered: 2017-06-07
Posts: 8

Re: [SOLVED] Windows 10 not showing on grub (previously ok with ubuntu)

Sxt wrote:
R00KIE wrote:

You could always skip auto detection and just drop your custom entry/script in /etc/grub.d. Personally I'm not much of a fan of automagic detections and I manage grub.cfg manually.

Thank you very much it is working!

If anyone is wondering here is the menuentry of my custom file

menuentry "Windows 10" {
   insmod ntfs
   insmod ntldr
   insmod part_msdos
   insmod search_fs_uuid
   search --no-floppy --fs-uuid --set=root UUID_OF_MY_DISK
   ntldr /bootmgr
}

If you get an error "cannot find bootmgr", repair the mgr of your windows and reinstall grub + generate the config files.

Refer to https://wiki.archlinux.org/index.php/GR … menu_entry


C++ and KDE = PRAISE THE SUN!

Offline

Board footer

Powered by FluxBB