You are not logged in.

#1 2017-07-10 08:08:11

maxpesa
Member
From: Italy
Registered: 2017-07-10
Posts: 11

[SOLVED] NetworkManager keeps asking for WiFi password

Hi, installed Arch yesterday (PLASMA), everything works fine except for wifi (I followed the arch wiki for nm automatic setup).

Using NetworkManager, wired connection works fine, and connecting to new WiFi networks (e.g. my phone hotspot) works too.
I just can' use my home WiFi, the first I tried to set, as it keeps asking me the WPA2 password, never connecting.

Tried:
- connecting and disconnecting
- editing the password storage option under "WiFi Security" to "Unencrypted - available to all users"
- thought this would clash with kdewallet, tried disabling the wallet subsystem - no luck
- the same procedure with nm -tui

I still think this is indeed related to kwallet, firstly set to remember my password with blowfish encryption, even though I actually never connected, not even for a second.
It had happened before, in my years with Manjaro, but a workaroung was toggling Airplane Mode.

SOLUTION FOUND at this link https://bbs.archlinux.org/viewtopic.php?id=224932 or jump to the last post

Last edited by maxpesa (2017-07-11 16:04:25)


There are no passengers on spaceship earth. We are all crew.

Offline

#2 2017-07-10 08:10:01

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,310
Website

Re: [SOLVED] NetworkManager keeps asking for WiFi password

What card and driver? What is in your journal?

Connect manually for debugging purposes. Post the commands that you use and any error messages.



Moving to NC...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2017-07-10 08:30:29

maxpesa
Member
From: Italy
Registered: 2017-07-10
Posts: 11

Re: [SOLVED] NetworkManager keeps asking for WiFi password

DRIVER:
       

Network controller: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter (rev 01)
        Subsystem: Broadcom Limited Device 0608
        Kernel driver in use: bcma-pci-bridge
        Kernel modules: bcma

LOG:

ul 10 10:25:11 archPC plasmashell[5577]: QXcbConnection: XCB error: 2 (BadValue), sequence: 63483, resource id: 12582928, major code: 142 (Unknown), minor code: 3
Jul 10 10:27:53 archPC dhcpcd[307]: wlp2s0b1: new hardware address: 4e:da:ee:b6:a4:1c
Jul 10 10:27:54 archPC kernel: brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
Jul 10 10:27:54 archPC kernel: brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
Jul 10 10:27:54 archPC kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0b1: link is not ready
Jul 10 10:27:53 archPC NetworkManager[319]: <info>  [1499675273.9829] device (wlp2s0b1): set-hw-addr: set MAC address to 4E:DA:EE:B6:A4:1C (scanning)
Jul 10 10:27:54 archPC NetworkManager[319]: <info>  [1499675274.0858] device (wlp2s0b1): supplicant interface state: inactive -> disabled
Jul 10 10:27:54 archPC NetworkManager[319]: <info>  [1499675274.1294] device (wlp2s0b1): supplicant interface state: disabled -> inactive
Jul 10 10:27:54 archPC wpa_supplicant[452]: wlp2s0b1: Reject scan trigger since one is already pending
Jul 10 10:28:33 archPC plasmashell[5577]: QXcbConnection: XCB error: 2 (BadValue), sequence: 64055, resource id: 10485766, major code: 142 (Unknown), minor code: 3

Last edited by maxpesa (2017-07-10 13:46:28)


There are no passengers on spaceship earth. We are all crew.

Offline

#4 2017-07-10 09:38:21

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] NetworkManager keeps asking for WiFi password

That is not trying to connect manually, what jasonwryan means is disable all network managers you may have active and use wpa_supplicant and a dhcp client manually/directly.

That said, one thing that maybe be causing trouble is mac address randomization, trying to connect manually should help figure that out.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#5 2017-07-10 13:45:38

maxpesa
Member
From: Italy
Registered: 2017-07-10
Posts: 11

Re: [SOLVED] NetworkManager keeps asking for WiFi password

Don't know what you mean by "connecting manually", guessed you wanted something like:

[root@archPC maxpesa]# sudo systemctl stop NetworkManager.service
[root@archPC maxpesa]# wpa_supplicant -B -i wlp2s0b1 -c <(wpa_passphrase xxxx_4F5C xxxxx)
Successfully initialized wpa_supplicant                                                                                                                                                         
[root@archPC maxpesa]# dhcpcd wlp2s0b1                                                                                            
sending commands to master dhcpcd process   

Does not seem working

Last edited by maxpesa (2017-07-10 13:47:02)


There are no passengers on spaceship earth. We are all crew.

Offline

#6 2017-07-10 14:49:47

seth
Member
Registered: 2012-09-03
Posts: 11,242

Re: [SOLVED] NetworkManager keeps asking for WiFi password

https://wiki.archlinux.org/index.php/Wi … nual_setup

don't run wpa_supplicant in background and post actual erro messages instead of "does not seem working" - that's not information at all ("seem")

Offline

#7 2017-07-11 10:29:46

maxpesa
Member
From: Italy
Registered: 2017-07-10
Posts: 11

Re: [SOLVED] NetworkManager keeps asking for WiFi password

Tried the manual setup, with these commands:

sudo iw dev wlp2s0b1 scan
sudo wpa_supplicant -i wlp2s0b1 -c <(wpa_passphrase "Digicom_4F5C" "xxxx")                                                                                                                                                                                                                                                         
Successfully initialized wpa_supplicant                                                                                                                                                         
Failed to open config file '/dev/fd/63', error: No such file or directory                                                                                                                       
Failed to read or parse configuration '/dev/fd/63'

ando got this log

Jul 11 12:02:43 archPC kernel: brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
Jul 11 12:02:43 archPC kernel: brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
Jul 11 12:02:43 archPC kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0b1: link is not ready
Jul 11 12:02:43 archPC dhcpcd[264]: wlp2s0b1: new hardware address: fa:ae:5f:c7:2f:c4
Jul 11 12:02:43 archPC wpa_supplicant[263]: wlp2s0b1: Reject scan trigger since one is already pending
Jul 11 12:02:43 archPC NetworkManager[261]: <info>  [1499767363.2993] device (wlp2s0b1): supplicant interface state: inactive -> disabled
Jul 11 12:02:43 archPC NetworkManager[261]: <info>  [1499767363.3316] device (wlp2s0b1): supplicant interface state: disabled -> inactive
Jul 11 12:04:21 archPC plasmashell[598]: log_klipper: Checking clip data
Jul 11 12:04:21 archPC plasmashell[598]: log_klipper: Synchronize? false
Jul 11 12:04:21 archPC plasmashell[598]: QXcbConnection: XCB error: 2 (BadValue), sequence: 62713, resource id: 37748742, major code: 142 (Unknown), minor code: 3
Jul 11 12:04:42 archPC plasmashell[598]: QXcbConnection: XCB error: 2 (BadValue), sequence: 63322, resource id: 37748742, major code: 142 (Unknown), minor code: 3
Jul 11 12:04:42 archPC plasmashell[598]: QXcbConnection: XCB error: 2 (BadValue), sequence: 63411, resource id: 44040231, major code: 142 (Unknown), minor code: 3
Jul 11 12:04:46 archPC plasmashell[598]: QXcbConnection: XCB error: 2 (BadValue), sequence: 63510, resource id: 44040208, major code: 142 (Unknown), minor code: 3

The errors provided by the GUI just say "No secrets provided" when I finally close thepassphrase prompt

For comparison, the log when connecting (succesfully) to another WPA2 PSK network:

Jul 11 12:31:31 archPC kernel: wlp2s0b1: authenticate with 5c:a8:6a:88:03:13
Jul 11 12:31:31 archPC wpa_supplicant[263]: wlp2s0b1: SME: Trying to authenticate with 5c:a8:6a:88:03:13 (SSID='hotspot max' freq=2462 MHz)
Jul 11 12:31:31 archPC kernel: wlp2s0b1: send auth to 5c:a8:6a:88:03:13 (try 1/3)
Jul 11 12:31:31 archPC wpa_supplicant[263]: wlp2s0b1: Trying to associate with 5c:a8:6a:88:03:13 (SSID='hotspot max' freq=2462 MHz)
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.1767] device (wlp2s0b1): supplicant interface state: scanning -> authenticating
Jul 11 12:31:31 archPC kernel: wlp2s0b1: authenticated
Jul 11 12:31:31 archPC kernel: wlp2s0b1: associate with 5c:a8:6a:88:03:13 (try 1/3)
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.1814] device (wlp2s0b1): supplicant interface state: authenticating -> associating
Jul 11 12:31:31 archPC wpa_supplicant[263]: wlp2s0b1: Associated with 5c:a8:6a:88:03:13
Jul 11 12:31:31 archPC wpa_supplicant[263]: wlp2s0b1: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Jul 11 12:31:31 archPC kernel: wlp2s0b1: RX AssocResp from 5c:a8:6a:88:03:13 (capab=0x8431 status=0 aid=1)
Jul 11 12:31:31 archPC kernel: brcmsmac bcma0:1: brcmsmac: brcms_ops_bss_info_changed: associated
Jul 11 12:31:31 archPC kernel: brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: true (implement)
Jul 11 12:31:31 archPC kernel: wlp2s0b1: associated
Jul 11 12:31:31 archPC kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0b1: link becomes ready
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.1901] device (wlp2s0b1): supplicant interface state: associating -> associated
Jul 11 12:31:31 archPC kernel: brcmsmac bcma0:1: wl0: brcms_c_d11hdrs_mac80211:  txop exceeded phylen 159/256 dur 1778/1504
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.1992] device (wlp2s0b1): supplicant interface state: associated -> 4-way handshake
Jul 11 12:31:31 archPC wpa_supplicant[263]: wlp2s0b1: WPA: Key negotiation completed with 5c:a8:6a:88:03:13 [PTK=CCMP GTK=CCMP]
Jul 11 12:31:31 archPC wpa_supplicant[263]: wlp2s0b1: CTRL-EVENT-CONNECTED - Connection to 5c:a8:6a:88:03:13 completed [id=0 id_str=]
Jul 11 12:31:31 archPC dhcpcd[264]: wlp2s0b1: carrier acquired
Jul 11 12:31:31 archPC kernel: brcmsmac bcma0:1: wl0: brcms_c_d11hdrs_mac80211:  txop exceeded phylen 137/256 dur 1602/1504
Jul 11 12:31:31 archPC kdeinit5[521]: networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "RxBytes"
Jul 11 12:31:31 archPC kdeinit5[521]: networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "TxBytes"
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2056] device (wlp2s0b1): supplicant interface state: 4-way handshake -> completed
Jul 11 12:31:31 archPC dhcpcd[264]: wlp2s0b1: IAID 31:bb:4c:4d
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2056] device (wlp2s0b1): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'hotspot max'.
Jul 11 12:31:31 archPC dhcpcd[264]: wlp2s0b1: adding address fe80::6f7a:2a79:1e00:96f2
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2057] device (wlp2s0b1): state change: config -> ip-config (reason 'none', internal state 'managed')
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2062] dhcp4 (wlp2s0b1): activation: beginning transaction (timeout in 45 seconds)
Jul 11 12:31:31 archPC plasmashell[598]: networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "RxBytes"
Jul 11 12:31:31 archPC plasmashell[598]: networkmanager-qt: virtual void NetworkManager::DevicePrivate::propertyChanged(const QString&, const QVariant&) Unhandled property "TxBytes"
Jul 11 12:31:31 archPC plasmashell[598]: file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property 'width' of null
Jul 11 12:31:31 archPC plasmashell[598]: file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property 'width' of null
Jul 11 12:31:31 archPC plasmashell[598]: file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property 'width' of null
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2519] dhcp4 (wlp2s0b1):   address 192.168.43.154
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2519] dhcp4 (wlp2s0b1):   plen 24
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2519] dhcp4 (wlp2s0b1):   expires in 3600 seconds
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2520] dhcp4 (wlp2s0b1):   nameserver '192.168.43.1'
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2520] dhcp4 (wlp2s0b1):   hostname 'archPC'
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2520] dhcp4 (wlp2s0b1):   gateway 192.168.43.1
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2523] dhcp4 (wlp2s0b1): state changed unknown -> bound
Jul 11 12:31:31 archPC kernel: brcmsmac bcma0:1: brcms_ops_bss_info_changed: arp filtering: 1 addresses (implement)
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2592] device (wlp2s0b1): state change: ip-config -> ip-check (reason 'none', internal state 'managed')
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2621] device (wlp2s0b1): state change: ip-check -> secondaries (reason 'none', internal state 'managed')
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2653] device (wlp2s0b1): state change: secondaries -> activated (reason 'none', internal state 'managed')
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.2678] manager: NetworkManager state is now CONNECTED_LOCAL
Jul 11 12:31:31 archPC plasmashell[598]: file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property 'width' of null
Jul 11 12:31:31 archPC plasmashell[598]: file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property 'width' of null
Jul 11 12:31:31 archPC plasmashell[598]: file:///usr/lib/qt/qml/QtQuick/Controls/Button.qml:99: TypeError: Cannot read property 'width' of null
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.4767] manager: NetworkManager state is now CONNECTED_GLOBAL
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.4787] policy: set 'hotspot max' (wlp2s0b1) as default for IPv4 routing and DNS
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.4794] dns-mgr: Writing DNS information to /usr/bin/resolvconf
Jul 11 12:31:31 archPC dhcpcd[264]: wlp2s0b1: soliciting an IPv6 router
Jul 11 12:31:31 archPC NetworkManager[261]: <info>  [1499769091.5453] device (wlp2s0b1): Activation: successful, device activated.

-when I type the wrong password, the prompt asks me another one in a few seconds, while, with the right psw, it does indeed take much longer for the process to reiterate, suggesting that it's the router that is not allowing me in?

Last edited by maxpesa (2017-07-11 16:07:02)


There are no passengers on spaceship earth. We are all crew.

Offline

#8 2017-07-11 11:53:15

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] NetworkManager keeps asking for WiFi password

This 'Failed to open config file '/dev/fd/63', error: No such file or directory' should have raised a red flag right away. Save your configuration file to disk and try again.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#9 2017-07-11 13:58:16

maxpesa
Member
From: Italy
Registered: 2017-07-10
Posts: 11

Re: [SOLVED] NetworkManager keeps asking for WiFi password

R00KIE wrote:

This 'Failed to open config file '/dev/fd/63', error: No such file or directory' should have raised a red flag right away. Save your configuration file to disk and try again.

Indeed, tried to work with the wiki solution, got my etc/wpa_supplicant/example.conf like:

ctrl_interface=/run/wpa_supplicant
ctrl_interface_group=wheel
update_config=1
ap_scan=1

network={
	ssid="yyy"
	#psk="xxxx"
	psk=4b39fb3809c5a22621734e4d97dc3b5fb919b5616936c9ebdbbc338dd4693773
}

and tried

[root@archPC maxpesa]# wpa_supplicant -Dnl80211 -iwlp2s0b1 -c/etc/wpa_supplicant/example.conf
Successfully initialized wpa_supplicant
wlp2s0b1: SME: Trying to authenticate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: Trying to associate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: SME: Trying to authenticate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: Trying to associate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: SME: Trying to authenticate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: Trying to associate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: SME: Trying to authenticate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: Trying to associate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Digicom_4F5C" auth_failures=1 duration=10 reason=CONN_FAILED
wlp2s0b1: CTRL-EVENT-SSID-REENABLED id=0 ssid="Digicom_4F5C"
wlp2s0b1: SME: Trying to authenticate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: Trying to associate with 00:a0:a2:90:4f:5c (SSID='Digicom_4F5C' freq=2422 MHz)
wlp2s0b1: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Digicom_4F5C" auth_failures=2 duration=23 reason=CONN_FAILED

Last edited by maxpesa (2017-07-11 14:05:51)


There are no passengers on spaceship earth. We are all crew.

Offline

#10 2017-07-11 14:54:13

seth
Member
Registered: 2012-09-03
Posts: 11,242

Re: [SOLVED] NetworkManager keeps asking for WiFi password

Offline

#11 2017-07-11 16:02:29

maxpesa
Member
From: Italy
Registered: 2017-07-10
Posts: 11

Re: [SOLVED] NetworkManager keeps asking for WiFi password

Exact same problem (altough I believe, for a Digicom router, it should be more common), the solution provided there worked like a charm.

Note to fellow googlers: I did not reinstall Arch, as in the solution:
My steps were just:

2. broadcom-wl package was installed
3. Blacklist few other Broadcom modules - create file sudo nano /etc/modprobe.d/blacklist.conf, containing:

blacklist bcma
blacklist b43
blacklist b43legacy
blacklist brcm80211
blacklist ssb

4. Re-nstall networkmanager and plasma-nm packages <- just use pacman -S networkmanager plasma-nm
5. Disable services:
sudo systemctl disable dhcpcd@enp4s0.service
sudo systemctl disable netctl-auto@wlp3s0b1.service
5. Enable Network Manager as service:
sudo systemctl enable NetworkManager.service
6. reboot

I'd say that the trick actually just involves switching to the right driver, but I'd follow these steps anyway.

Thanks to the people that replied.

Last edited by maxpesa (2017-07-11 16:06:09)


There are no passengers on spaceship earth. We are all crew.

Offline

Board footer

Powered by FluxBB