You are not logged in.

#1 2006-07-01 11:45:50

From: Germany
Registered: 2006-07-01
Posts: 3

Webcam Philips SPC900NC Setup [SOLVED]

Hello Community!

After several unlucky tries and webcrawling for the possible solution I finally have to ask for help:
I've got a Philips SPC900NC webcam and want to get in running under arch.

My previous attempts were:
pwc driver out of the repos, and also follwing the arch webcam wiki
the latest pwc snapshot (pwc-v4l2-20060701-042701) from

in both cases hotplug or modprobe loads the module without any complain. However no /dev/video0 (or any similar) device is visible...
Also "dmesg" does not show the registering /dev/video0 part like in other examples seen in this forum..


usb 4-2: new full speed USB device using uhci_hcd and address 2
usb 4-2: configuration #1 chosen from 1 choice
Linux video capture interface: v1.00
pwc Philips webcam module version 9.0.2-unofficial loaded.
pwc Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
pwc Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
pwc the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and VCS-UM100.
usbcore: registered new driver Philips webcam
usbcore: registered new driver snd-usb-audio

Due to missing /dev/videoX any other application refuses to work..
Even creating the missing device with mknod does not help..

Does anybody have an idea whats wrong?
Thanks a lot!


#2 2006-07-02 13:16:19

From: Germany
Registered: 2006-07-01
Posts: 3

Re: Webcam Philips SPC900NC Setup [SOLVED]

Hello Again!
After trying nearly everything and even desperatly loading of every possible related video module in /lib/modules.... , I went back to basic and compiled my kernel by means of abs from source...

And that solved my problem somehow some patches does not seem to be included in the binary version available in the repositories???

So whenever you don't see a /dev/video something after connection a webcam, try to replace the downloaded kernel with a self compiled one
(makepkg in /var/abs/kernels/...) and then see if it helps!

My webcam now finally works wink


Board footer

Powered by FluxBB