You are not logged in.

#1 2017-09-05 13:59:52

The_Idiot_You_yell@
Member
Registered: 2015-05-30
Posts: 8

Arch on the GPD Pocket using KDE Plasma

These are my notes to get Arch Linux on the GPD Pocket.
   
Acknowledgements: 
https://github.com/njkli/gpd-pocket/ 
https://github.com/cawilliamson/ansible-gpdpocket/ 
https://github.com/nexus511/gpd-ubuntu-packages
https://www.reddit.com/r/GPDPocket/comm … pd_pocket/ 

Specs

Display: 7inch IPS 1920x1200 
CPU: Intel Atom X7-Z8750 
RAM: 8GB LPDDR3-1600 
Storage: 128GB eMMC SSD (non-replacable) 
Battery: 7000mAH 
WiFi: Broadcom 4356 802.11ac 
Audio: Realtek ALC5645 
Ports: 1 x USB 3 type A, 1 x MicroHDMI, 1 x USB 3 type C 1 x 3.5mm Headphone Jack

Installation

During Boot add "fbcon=rotate:1" to the kernel line to rotate the console.
Install using USB Ethernet following the wiki. 
During install add to /etc/pacman.conf

 [gpd-pocket]  
 SigLevel = Optional TrustAll  
 Server = https://github.com/njkli/$repo/raw/master/repo  

Install fan control and custom kernel using

#pacman -S gpd-fan linux-jwrdegoede linux-jwrdegoede-docs linux-jwrdegoede-headers

 

Power and Fan

Install

#pacman -S tlp

 
Edit /etc/default/tlp 

 DISK_DEVICES="mmcblk0"  
 DISK_IOSCHED="deadline"  

Copy fan config

cp /etc/default/gpd-fan.example /etc/default/gpd-fan

and uncomment settings

WiFi

Copy brcmfmac4356-pcie.txt from here to /lib/firmware/brcm/ then run

modprobe -r brcmfmac

modprobe brcmfmac

 
This did not work for me right away. I would get this error on boot

brcmfmac: brcmf_chip_recognition: chip backplane type 15 is not supported
brcmfmac: brcmf_pcie_probe: failed 14e4:43ec

To fix this, I installed the broadcom-wl-dkms and tested and then removed it now the wifi works just fine

Xorg

Create /etc/X11/xorg.conf.d/20-intel.conf to configure graphics.

 Section "Device"  
   Identifier  "Intel Graphics"  
   Driver      "intel"  
   Option      "AccelMethod"     "sna"  
   Option      "TearFree"        "true"  
   Option      "DRI"             "3"  
 EndSection

/etc/X11/xorg.conf.d/40-monior.conf to rotate the monitor.

 Section "Monitor"  
        Identifier "DSI1"  
        Option "Rotate" "right"  
 EndSection  

/etc/X11/xorg.conf.d/99-touchscreen.conf to rotate the touchscreen.

 Section "InputClass"  
   Identifier	"calibration"  
   MatchProduct	"Goodix Capacitive TouchScreen"  
   Option  "TransformationMatrix" "0 1 0 -1 0 1 0 0 1"  
 EndSection  

Alternatively you can copy the files from here

Sound

Copy chtrt5645.conf and HiFi.conf from here to /usr/share/alsa/ucm/chtrt5645/.
Append the following lines into /etc/pulse/default.pa

 set-card-profile alsa_card.platform-cht-bsw-rt5645 HiFi  
 set-default-sink alsa_output.platform-cht-bsw-rt5645.HiFi__hw_chtrt5645__sink  
 set-sink-port alsa_output.platform-cht-bsw-rt5645.HiFi__hw_chtrt5645__sink [Out] Speaker  

Turn off realtime_scheduleing by editing /etc/pulse/daemon.conf

 realtime-scheduling = no 
SDDM

Change DPI to be readable, append the following lines to /usr/share/sddm/scripts/Xsetup 

 # Set DPI  
 xrandr --dpi 168"  
Touchscreen Gestures

Install touchegg from AUR then copy config files from here and set permissions.

sudo cp touchegg.conf /usr/share/touchegg/
sudo chmod 0644 /usr/share/touchegg/touchegg/touchegg.conf
sudo cp 01_touchegg /etc/X11/xinit/xinitrc.d/  
sudo chmod 0755 /etc/X11/xinit/xinitrc.d/01_touchegg

 

KDE Display

In System Settings > Display and Monitor change Orientation to 90° Clockwise, and Scale Display to a comfortable size, 1.5 seems to be the best for me

Mouse Scroll Emulation

Create /home/$HOME/bin/mousescroll.sh 

 #!/bin/bash  
 # Emulate scroll wheel in built in nub while holding the right click button  
 xinput --set-prop pointer:"SINO WEALTH Gaming Keyboard" "libinput Middle Emulation Enabled" 1  
 # Trigger wheel emulation with button 3 (right click)  
 xinput --set-prop pointer:"SINO WEALTH Gaming Keyboard" "libinput Button Scrolling Button" 3  

Add script to SDDM Autostart in System Settings > Startup and Shutdown > Autostart.

Hope this helps anyone trying to get this going without repining the Arch ISO.

PS if this is in the wrong section sorry.

Offline

#2 2017-09-05 14:05:15

Slithery
Administrator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 5,374

Re: Arch on the GPD Pocket using KDE Plasma

This information belongs on the wiki, not in the forums.

Feel free to create a wiki page for this device and put any relevant information there instead.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2017-09-05 14:17:52

The_Idiot_You_yell@
Member
Registered: 2015-05-30
Posts: 8

Re: Arch on the GPD Pocket using KDE Plasma

I thought so just wasn't sure about the process. I'll get on it.

Offline

#4 2017-09-05 16:43:12

ghus
Banned
Registered: 2016-11-14
Posts: 420

Re: Arch on the GPD Pocket using KDE Plasma

Hi, can I ask you what BIOS version are you using?
I know the one released with the Ubuntu version (2017/06/28) is unlocked, but I did not resolve to make the fan starting: the 2017/07/05 (locked) that I am using now have solved that trouble, by enabling it:

Changelog (Google translate):
    1 - boot on the fan ( Probably to support GPD official Ubuntu firmware that doesn't seems to handle fan directly )

https://github.com/stockmind/gpd-pocket … -firmwares


I am using i3, on it, and I will try to enable audio and wifi : thanks a lot.

I'll like also to said that I appreciate to see a thread here, since most informations are on reddit, mostly for debian based OS, and the other discussion refers to the GPD Win.

As an information, the GPD says that when flashing the BIOS, it might be dangerous to keep the charging cable plugged, when doing the reboot.
At the moment, too, the charger adapters seems to be not all fine, if they give a 5/9 V with 3A , and that it's highly reccomend to use an adapter with the original one shipped with the device, that gives only 2A max.

Last edited by ghus (2017-09-05 16:54:26)

Offline

#5 2017-09-05 17:39:37

The_Idiot_You_yell@
Member
Registered: 2015-05-30
Posts: 8

Re: Arch on the GPD Pocket using KDE Plasma

I am using the 2017/06/28 BIOS. BTW I did figure out the wiki stuff so you can find that at https://wiki.archlinux.org/index.php/GPD_Pocket and add anything I may have missed.

Offline

#6 2017-12-04 23:40:14

ghus
Banned
Registered: 2016-11-14
Posts: 420

Re: Arch on the GPD Pocket using KDE Plasma

The_Idiot_You_yell@ wrote:

I am using the 2017/06/28 BIOS. BTW I did figure out the wiki stuff so you can find that at https://wiki.archlinux.org/index.php/GPD_Pocket and add anything I may have missed.

I've tought you are using the 2017/06/28 Ubuntu's BIOS: can I ask if there is a "Reset System with ME Disable ModeMEUD000" feature, there? I have this on the "Save & Exit" Tab.
Anyone may know what this feature means? I've fund similar results from other chinese devices, by searching the web, but did not understood what it does:

Reset System with ME disable ModeMEUD000 ME runs in temporary disable mode, not applicable if ME Ignition
FWMEUD001.

Thanks.

Offline

#7 2017-12-05 00:32:41

The_Idiot_You_yell@
Member
Registered: 2015-05-30
Posts: 8

Re: Arch on the GPD Pocket using KDE Plasma

Yes I can confirm that is an option, but I do not claim to know what it does.

Offline

#8 2017-12-05 08:16:23

ghus
Banned
Registered: 2016-11-14
Posts: 420

Re: Arch on the GPD Pocket using KDE Plasma

Im was trying to use this method (intelmetool - https://github.com/corna/me_cleaner/wik … it-work%3F ) just to check if there may be an answer to, but I can't even download the repo, I will try with the https://aur.archlinux.org/packages/intel-me-tools-git/ when I'll complete the reinstallation.

Offline

#9 2017-12-12 14:56:17

ghus
Banned
Registered: 2016-11-14
Posts: 420

Re: Arch on the GPD Pocket using KDE Plasma

Hi, sorry but I have again some questions, for the installation: can you please direct me on the right way?
By following the wiki I've added the "pacman -Syy" command, after had added the gpd-pocket-support repo (I don't know, but I've tought it was needed).
What I did not understood is how to configure the boot for the Hans de Goede's kernel: I've tried to use a file called linux-jwrdegoede.conf

title   Arch Linux - jwrdegoede (https://github.com/jwrdegoede/linux-sunxi)
linux   /vmlinuz-linux-jwrdegoede
initrd  /intel-ucode.img
initrd  /initramfs-linux-jwrdegoede.img
options root=/dev/mmcblk0p2 i915.fastboot=1 i915.semaphores=1 fbcon=rotate:1 rw quiet

on /boot/loader/entries/   and ran

bootctl install

Did I have to create a different initramfs image , perhaps also with a command that differs from (?)

mkinitcpio -p linux

The EFI partition it's correct...
Thanks again for your patience, and sorry for my not understandings.

Last edited by ghus (2017-12-14 19:01:01)

Offline

#10 2017-12-30 10:12:31

ghus
Banned
Registered: 2016-11-14
Posts: 420

Re: Arch on the GPD Pocket using KDE Plasma

Offline

#11 2018-01-17 12:11:21

ghus
Banned
Registered: 2016-11-14
Posts: 420

Re: Arch on the GPD Pocket using KDE Plasma

Hi, can I ask an advice on how to enable the USB Gadget mode, with the unlocked Bios, after had changing those settings?

1) Enable USB gadget support, goto: "Chipset" -> "South Bridge" -> "USB Configuration" And change the following 2 options:
"USB OTG Support" : "PCI"
"DRD Access Method" : "Mmio"
This will allow you to load gadget drivers (e.g. "modprobe g_serial") and then connect the GPD-win to a PC and have it show up as an usb device

(it's for the GPD WIN but tought it's the same)
http://hansdegoede.livejournal.com/17445.html

Offline

Board footer

Powered by FluxBB