You are not logged in.

#1 2017-09-13 13:51:08

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

I have Asus Zenbook UX305UA 

Configuration: 
Processor: i5 6th gen (Skylake) 
Ram: 8GB 
Storage: 256 GB 
No dedicated graphics

I had booted with latest iso and I am getting black/blank screen after selecting

 Boot Arch Linux 

. I had researched and found this https://wiki.archlinux.org/index.php/in … modules.22 but how to add line in kernel parameter in live boot?
If there is any alternative solution please guide me.

Last edited by vaibhavsingh97 (2017-09-14 12:27:21)

Offline

#2 2017-09-13 14:06:13

dockland
Member
From: Sweden
Registered: 2015-06-06
Posts: 635

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

UEFI or MBR?
Secureboot enabled?

To add parameter(s) press "e" key during initialization


I possess a device, in my pocket, that is capable of accessing the entirety of information known to man.
I use it to look at funny pictures of cats and to argue with strangers.

Offline

#3 2017-09-13 14:07:43

loqs
Member
Registered: 2014-03-06
Posts: 2,923

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

Kernel_parameters#Configuration  please see the first note in that section.

Offline

#4 2017-09-13 14:08:25

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

UEFI and Secure boot disabled

Offline

#5 2017-09-13 14:25:31

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

loqs wrote:

Kernel_parameters#Configuration  please see the first note in that section.

I am booting from a live USB so this solution not working sad

Offline

#6 2017-09-13 14:26:17

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

dockland wrote:

UEFI or MBR?
Secureboot enabled?

To add parameter(s) press "e" key during initialization

UEFI and Secure boot disabled
I tried still blank/black screen sad

Offline

#7 2017-09-13 14:32:56

loqs
Member
Registered: 2014-03-06
Posts: 2,923

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

vaibhavsingh97 wrote:
loqs wrote:

Kernel_parameters#Configuration  please see the first note in that section.

I am booting from a live USB so this solution not working sad

https://wiki.archlinux.org/index.php/Ke … figuration

The Arch Linux installation medium uses Syslinux for BIOS systems, and systemd-boot for UEFI systems.

So did you the follow the steps for systemd-boot and what paramaters did you add/change?

Offline

#8 2017-09-13 14:41:56

Blasphemist
Member
From: Colorado
Registered: 2013-01-17
Posts: 150

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

Did you disable UEFI or has it worked before with it disabled? I'd enable it if you don't depend on it being disabled for something in place now.


Simple and Open

Offline

#9 2017-09-13 14:50:24

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

loqs wrote:
vaibhavsingh97 wrote:
loqs wrote:

Kernel_parameters#Configuration  please see the first note in that section.

I am booting from a live USB so this solution not working sad

https://wiki.archlinux.org/index.php/Ke … figuration

The Arch Linux installation medium uses Syslinux for BIOS systems, and systemd-boot for UEFI systems.

So did you the follow the steps for systemd-boot and what paramaters did you add/change?

I am adding

 i915.modeset=1  

Offline

#10 2017-09-13 14:52:48

loqs
Member
Registered: 2014-03-06
Posts: 2,923

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

If you switch it to the following is the result the same?

i915.modeset=0

Edit:
spelling

Last edited by loqs (2017-09-13 14:53:10)

Offline

#11 2017-09-13 15:48:49

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

loqs wrote:

If you switch it to the following is the result the same?

i915.modeset=0

Edit:
spelling

yes, I tried but the result is same

Offline

#12 2017-09-13 15:56:33

loqs
Member
Registered: 2014-03-06
Posts: 2,923

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

Try the following if the screen goes blank is any text displayed before it does?

modprobe.blacklist=i915 earlyprintk=efi loglevel=7

Offline

#13 2017-09-14 12:26:35

vaibhavsingh97
Member
Registered: 2016-08-15
Posts: 32

Re: Failed to boot via Arch Linux: 2017.09.01 in Skylake processor[SOLVED]

loqs wrote:

Try the following if the screen goes blank is any text displayed before it does?

modprobe.blacklist=i915 earlyprintk=efi loglevel=7

I tried with

 nomodeset 

and i succeded. But thanks for help

Last edited by vaibhavsingh97 (2017-09-14 12:27:47)

Offline

Board footer

Powered by FluxBB