You are not logged in.

#1 2017-10-08 12:32:42

Registered: 2011-12-29
Posts: 21

No audio from headphone jack (Clevo P775DM3)

A sthe title says, I get no audio from headphones connected to the headphone jack. The headphones work if plugged into the line-out jack, however the amp only works with the headphone port.
I followed a guide here: but I get stuck at the last step.
I managed to identify the i2c address of the jack, which is 0x1b, just like the article. When audio is playing from the speakers and I plug the headphones into the jack, the speakers stop playing, but no sound is coming from the headphones.
Running init-headphone gives me this error:

[root@souvlakia stavros]# init-headphone -v
INFO:root:Version: 0.10
DEBUG:root:Available i2c busses: ['NVIDIA i2c adapter 6 at 1:00.0', 'NVIDIA i2c adapter 1 at 1:00.0', 'NVIDIA i2c adapter 9 at 1:00.0', 'NVIDIA i2c adapter 7 at 1:00.0', 'NVIDIA i2c adapter 2 at 1:00.0', 'SMBus I801 adapter at f000', 'NVIDIA i2c adapter 8 at 1:00.0']
DEBUG:root:Supported i2c bus names: ['SMBus I801 adapter']
DEBUG:root:Selected i2c bus: SMBus I801 adapter at f000
INFO:SMBus:Opening I2C bus: /dev/i2c-0
INFO:SMBus:Setting I2C slave address: 115
INFO:SMBus:Writing byte data on I2C bus: (device_cmd: 0xa, value: 0x41)
ERROR:SMBus:Can't transfer data on I2C bus
INFO:SMBus:Closing I2C bus
ERROR:root:Operation failed
DEBUG:root:Exception occurred:
Traceback (most recent call last):
  File "/usr/bin/init-headphone", line 337, in <module>
  File "/usr/bin/init-headphone", line 323, in main
  File "/usr/bin/init-headphone", line 245, in init
  File "/usr/bin/init-headphone", line 261, in set_effect
  File "/usr/bin/init-headphone", line 237, in write_data_to_device
  File "/usr/bin/init-headphone", line 227, in prolog
    i2c_bus.write_byte_data(0x0a, 0x41)
  File "/usr/bin/init-headphone", line 140, in write_byte_data
    self.__access(I2C_SMBUS_WRITE, device_cmd, I2C_SMBUS_BYTE_DATA, data)
  File "/usr/bin/init-headphone", line 134, in __access
    raise RuntimeError("Can't transfer data on I2C bus")
RuntimeError: Can't transfer data on I2C bus
[root@souvlakia stavros]# init-headphone --help
usage: init-headphone [-h] [--version] [-v] [-f] [command]

Manage the headphone amplifier found in some Clevo laptops
(see the list of supported models below)

positional arguments:
  command        see the list of available commands below, init is the default
                 if the argument is omitted

optional arguments:
  -h, --help     show this help message and exit
  --version      show program's version number and exit
  -v, --verbose  increase output verbosity
  -f, --force    for compatibility with previous versions

available commands:
  init           initialize amplifier (with effect1)
  effect0        no change
  effect1        bass boost
  effect4        boost everything
  mute           turn output off
  unmute         turn output on

supported models:
  N1xxSD, P37xSM-A, P65xSE, P770ZM, W130SV, W230SD, W230SS, W25CSx, W330AU, 
  W330SU2, W355SDQ, W3xxSS, W510TU, W510TU-L, W5xxSU2, W650SF, W670SFQ, W6xxSB, 
  W840AU, W942SV, W942SW, W945SUW, W94xTU, W94xTU-L, W95xTU, W970KLQ, W970SUW, 
  W970SUY, W970TUQ, W9xxAUx, W9xxKL, W9xxKU, W9xxSU1, W9xxSU2, WA50SBQ, 

This probably means the P775DM3 is not supported by this. Is there another workaround I can use?

Last edited by stavrakis (2017-10-08 12:41:49)


#2 2017-12-08 00:58:42

From: Earth
Registered: 2016-12-02
Posts: 3

Re: No audio from headphone jack (Clevo P775DM3)

@stavrakis Finally got around to trying to set this up on my P650 and I stumbled on the exact same issue.

Any chance you found anything more about this in the meantime?


#3 2017-12-11 18:52:40

Registered: 2011-12-29
Posts: 21

Re: No audio from headphone jack (Clevo P775DM3)

Unfortunately no, I can get hdajackretask to re-map the jack, but I cannot activate the amp. In windows I can hear the mechanical click inside the chassis, but not in arch.


#4 2017-12-11 19:09:55

From: Earth
Registered: 2016-12-02
Posts: 3

Re: No audio from headphone jack (Clevo P775DM3)

No problem. I had just started looking into it.

In my case I have a P650RS, so different model, *but* it may be a similar issue. Need to go and check what's inside the P775.

So far I have found a very good source of information for the P650RS:
If you find anything related to yours, I'd like to know as the hardware issue may be the same or at least very similar.

During the holidays I may look into this to see if I can get a software solution working, can't promise a timeline though.
Good news (if you're willing to do so) is that a hardware mod seems like a very feasible and simple alternative if you look at the board and the schematics (link within the link).
If I can't reverse engineer the windows driver I'll do that instead (with care you can make the hardware mod reversible).


#5 2018-01-10 01:40:07

From: Earth
Registered: 2016-12-02
Posts: 3

Re: No audio from headphone jack (Clevo P775DM3)

Ok, so I gave up on reverse engineering for now. I'm not getting anywhere doing it over wine as I can't communicate with the device on the I2C bus (e.g. running i2cdetect will only list the device the 1st time).
Since I don't have a windows license and even then my knowledge on the subject is quite limited, I think it's fair to say I wouldn't be figuring it out any time soon.

On the upside, a quick hardware mod is indeed possible. smile
This is because the DAC, although it takes the SMBus in as well, it seems to default to the right pins (SPDIF signal) and just works.
Hopefully it's the same for your model.

I'll add the relevant info to the page for my laptop later, maybe this weekend.

Currently there are only these (comparatively) minor issues, of which I'm still battling with the 2nd:

  • Power consumption on idle increases massively by 2-3W. The relay and the amplifier biasing current doesn't explain such an increase, so I'm guessing it's from the DAC (no publicly available datasheet that I could find) being always on.

    • The relay will click once when turning on the PC and once when turning off. My current tpm configuration automatically disables some parts from the audio (visible for instance in the SPDIF light going dark), but the relay remains on with my current hack.

    • There may be simple ways (without hardware switches) to improve on this, but I took a minimal changes approach to check if it worked.

  • Following @PAPPPmAc posts I have the jack detection working: mutes the internal speakers and puts sound through the headphones. However, it has only 2 sound levels: muted and deafening loud (i.e. maximum).

    • Selecting the SPDIF output manually, one can then control the volume on the SPDIF stream and therefore control the volume as expected. This is not automated though, and it's easy to un-mute the headphone output and blasting your ears off...

    • I've tried changing things with hdajackretask, but without any luck. I'm pretty sure there's an easy solution to this and it's just my lack of knowledge of ALSA, etc. Help would be very welcome here.


Board footer

Powered by FluxBB