You are not logged in.

#1 2017-10-10 09:08:59

epinephrine
Member
From: Frankfurt
Registered: 2012-10-18
Posts: 84

[SOLVED]Dell XPS 13: root partition mounted read-only resuming/suspend

Hi,

Since the latest kernel update to 4.13.4, my laptop has the root partition immediately mounted as read-only after suspend and I cannot remount it rw since sudo (or just anything) throws errors as well. Anyone experiencing this lately? I can only reboot the system using Alt+SysRq+reisub...

The problem does not occur with the LTS kernel, so it must be a regression in 4.13.4.

When resuming from suspend with the console open, I can see a stream of error messages running over the screen for a few seconds. This is the final screen:
suspend resume error kernel 4.13.4.


Edit: Partial Solution: Add intel_iommu=off to your kernel boot parameters.

Last edited by epinephrine (2017-10-11 15:29:43)

Offline

#2 2017-10-10 21:10:22

epinephrine
Member
From: Frankfurt
Registered: 2012-10-18
Posts: 84

Re: [SOLVED]Dell XPS 13: root partition mounted read-only resuming/suspend

Offline

#3 2017-10-10 21:46:50

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 471

Re: [SOLVED]Dell XPS 13: root partition mounted read-only resuming/suspend

Various screen lockups and also resume from suspend started failing after the kernel 4.12->4.13 kernel update on my XPS 13 9343. Adding intel_iommu=off boot parameter fixed all problems. See the plethora of other posts around here about the issue.

Offline

#4 2017-10-11 15:26:28

epinephrine
Member
From: Frankfurt
Registered: 2012-10-18
Posts: 84

Re: [SOLVED]Dell XPS 13: root partition mounted read-only resuming/suspend

I just upgraded to 4.13.5, added intel_iommu=off to my kernel parameters and the problem is indeed solved. Thank you.
BTW, my lts kernel is loaded with intel_iommu=igfx_off, which seems to be sufficient, at least for 4.9.

Offline

#5 2017-10-11 15:38:59

jean_no
Member
Registered: 2007-09-18
Posts: 46

Re: [SOLVED]Dell XPS 13: root partition mounted read-only resuming/suspend

Hi

epinephrine wrote:

I just upgraded to 4.13.5, added intel_iommu=off to my kernel parameters...

No longer needed with kernel 4.13.5

A+

Offline

Board footer

Powered by FluxBB