You are not logged in.

#1 2017-10-28 14:36:33

hippieben
Member
Registered: 2013-10-27
Posts: 218

[FIXED] T450s linux-ck SD Card reader doesn't work

Seems to be just with linux-ck kernel, works with the normal arch kernel. 

I get this is dmesg when sticking a card it, but nothing shows up in $lsblk or Gnome Disks.

[   44.128011] mmc0: cannot verify signal voltage switch
[   44.299265] mmc0: new ultra high speed SDR104 SDXC card at address 59b4
[   44.299500] mmcblk0: mmc0:59b4 6EHHP 58.5 GiB 
[   44.300230]  mmcblk0: p1
[ben@pluto ~]$ lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (3) I218-V (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #6 (rev e3)
00:1c.1 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
03:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

Anyone seen this?  Is it a regression in 4.13.10 or a -ck specific issue?

Last edited by hippieben (2017-11-02 19:50:14)

Offline

#2 2017-11-02 16:54:13

loqs
Member
Registered: 2014-03-06
Posts: 3,100

Re: [FIXED] T450s linux-ck SD Card reader doesn't work

Which release of linux-ck 4.13.10?

Offline

#3 2017-11-02 17:21:18

hippieben
Member
Registered: 2013-10-27
Posts: 218

Re: [FIXED] T450s linux-ck SD Card reader doesn't work

loqs wrote:

Which release of linux-ck 4.13.10?

Grabbed it from [reop-ck], happens with both -ck and -ck-broadwell

Offline

#4 2017-11-02 18:15:02

loqs
Member
Registered: 2014-03-06
Posts: 3,100

Re: [FIXED] T450s linux-ck SD Card reader doesn't work

There have been three releases of linux-ck 4.13.10 to date:  linux-ck 4.13.10-1, linux-ck 4.13.10-2, linux-ck 4.13.10-3.  I was asking which one of those the system experiencing the issue is using.
Check

pacman -Q linux-ck

Edit fixed grammar

Last edited by loqs (2017-11-02 18:15:59)

Offline

#5 2017-11-02 18:20:36

hippieben
Member
Registered: 2013-10-27
Posts: 218

Re: [FIXED] T450s linux-ck SD Card reader doesn't work

loqs wrote:

There have been three releases of linux-ck 4.13.10 to date:  linux-ck 4.13.10-1, linux-ck 4.13.10-2, linux-ck 4.13.10-3.  I was asking which one of those the system experiencing the issue is using.
Check

pacman -Q linux-ck

Edit fixed grammar

4.13.10-1 Looks like that's the latest release in the repo.  Will build 4.13.10-3 from AUR and report back.

REPORT: Looks like -3 works.  Not sure if it's the build environment or an issue with -1.

Last edited by hippieben (2017-11-02 19:45:13)

Offline

#6 2017-11-02 19:49:15

loqs
Member
Registered: 2014-03-06
Posts: 3,100

Re: [FIXED] T450s linux-ck SD Card reader doesn't work

It should be issue with 4.13.10-1 see https://bbs.archlinux.org/viewtopic.php … 6#p1746046 which is fixed in releases 2 and 3.

Offline

#7 2017-11-02 19:49:59

hippieben
Member
Registered: 2013-10-27
Posts: 218

Re: [FIXED] T450s linux-ck SD Card reader doesn't work

loqs wrote:

It should be issue with 4.13.10-1 see https://bbs.archlinux.org/viewtopic.php … 6#p1746046 which is fixed in releases 2 and 3.

Awesome, hopefully the repo will catch up soon.  Thanks.

Offline

Board footer

Powered by FluxBB