You are not logged in.

#1 2017-11-05 10:59:21

MasterMax
Member
Registered: 2011-11-11
Posts: 12

rtl8192se very slow

I reinstalled arch after switching to an ssd, thus it used to work in the past without problems.
With

cat /etc/modprobe.d/rtl8192se.conf 
options rtl8192se fwlps=N ips=N swlps=N swenc=Y

I am getting very high speed, but only for a limited time. Not setting these options results in slow speed all the time. If I reconnect manually, or if I reload the module using

sudo rmmod rtl8192se; sudo modprobe rtl8192se

it is fast again for a limited time.

Additional information:
lspci -k:

04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)
	Subsystem: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller
	Kernel driver in use: rtl8192se
	Kernel modules: rtl8192se

dmesg | grep rtl:

[    3.757717] rtl8192se: Power Save off (module option)
[    3.757719] rtl8192se: FW Power Save off (module option)
[    3.757780] rtl8192se: Driver for Realtek RTL8192SE/RTL8191SE
[    3.768370] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[    3.856184] rtl8192se 0000:04:00.0 wlp4s0: renamed from wlan0
[   12.171988] rtl8192se: switch case 0x5e not processed

I did not find information about the switch case error.

dmesg | grep wlp

[    3.856184] rtl8192se 0000:04:00.0 wlp4s0: renamed from wlan0
[    5.194286] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[    5.346717] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[    5.501211] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[    5.633870] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   11.068760] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   12.137524] wlp4s0: authenticate with 70:4f:57:24:17:18
[   12.157041] wlp4s0: send auth to 70:4f:57:24:17:18 (try 1/3)
[   12.160884] wlp4s0: authenticated
[   12.166758] wlp4s0: associate with 70:4f:57:24:17:18 (try 1/3)
[   12.170332] wlp4s0: RX AssocResp from 70:4f:57:24:17:18 (capab=0x431 status=0 aid=5)
[   12.172012] wlp4s0: associated
[   12.172069] IPv6: ADDRCONF(NETDEV_CHANGE): wlp4s0: link becomes ready

iwconfig always shows this (no matter if fast or slow):

wlp4s0    IEEE 802.11  ESSID:"essidname"  
          Mode:Managed  Frequency:2.432 GHz  Access Point: 70:4f:57:24:17:18   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:3224   Missed beacon:0

Offline

#2 2017-11-05 11:23:24

lo1
Member
Registered: 2017-09-25
Posts: 215

Re: rtl8192se very slow

I'm basically clueless, but my rtl8723be works fine with the same options as yours and

disable_watchdog=1

so you could give it a try. Which network manager are you using? Have you tried using another one?

systemctl list-units --state=active | grep net

Offline

Board footer

Powered by FluxBB