You are not logged in.

#1 2017-12-07 09:47:26

unnilquadium
Member
Registered: 2017-08-27
Posts: 30

Pulseaudio mixer tray icon

Hi!

Since the last update to pavucontrol, everytime I log into xfce4 the pulseaudio mixer icon in the system tray is grayed out (as if the audio was muted), but the audio works normally.
If I roll the mouse pointer over the icon, it then lights up and stays that way.

This is a very minor bug, but I was thinking about filing a bug report on this, just so it is reported.

I'm very new at this and I never filed a bug report before. Is it acceptable to report a bug this small?

Thank you smile

Offline

#2 2017-12-07 11:05:03

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: Pulseaudio mixer tray icon

Before filing a bug, you should make sure this caused by something being wrong with your system/user configuration. Creating a new user, and checking whether the bug appears with that user as well, is good way to make sure your user configuration isn't the culprit.

Also, as the issue was caused by an update, you should try to figure out which package update actually introduced the issue. Check pacman.log for which packages got updated when the problem started. Try downgrading at least the most obvious ones and see if the problem persists. Reporting a bug with nothing but "an update broke my system", won't be helpful.

In some cases, it may be better to report the issue directly to upstream developers of the offending package, but if you're unsure just report to arch bugzilla.

EDIT. I only now realized you said pavucontrol update caused the issue. However it looks like pavucontrol was last updated on january 2016 so I'm not sure what's going on. Are you using some unofficial repositories?

Last edited by ooo (2017-12-07 11:20:09)

Offline

#3 2017-12-07 11:36:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,246

Re: Pulseaudio mixer tray icon

They likely mean xfce4-pulseaudio-plugin, by the rest of the post. But yeah before opening a bugreport make sure you have the culprit and the terminology right. Pavucontrol doesn't provide tray icons so you are unlikely to refer to it.

Offline

#4 2017-12-07 15:42:20

dviktor
Member
Registered: 2015-10-18
Posts: 92

Re: Pulseaudio mixer tray icon

I can confirm the same issue after upgrading package named above. This issue is on two different machines

Offline

#5 2017-12-07 16:12:15

verndog
Member
Registered: 2007-09-21
Posts: 46

Re: Pulseaudio mixer tray icon

I also have the exact same issue. I looked into config files, checked pavucontrol settings. Nothing to indicate muting on boot.

Offline

#6 2017-12-07 16:23:35

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,802

Re: Pulseaudio mixer tray icon

verndog wrote:

I also have the exact same issue. I looked into config files, checked pavucontrol settings. Nothing to indicate muting on boot.

Are you sure this is the same issue? The OP's audio works, it's just the xfce4-pulseaudio-plugin icon that's misbehaving.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#7 2017-12-07 16:29:57

verndog
Member
Registered: 2007-09-21
Posts: 46

Re: Pulseaudio mixer tray icon

slithery wrote:
verndog wrote:

I also have the exact same issue. I looked into config files, checked pavucontrol settings. Nothing to indicate muting on boot.

Are you sure this is the same issue? The OP's audio works, it's just the xfce4-pulseaudio-plugin icon that's misbehaving.

I have the same issue as the op stated. volume is grayed out on boot. What else could I say.

Offline

#8 2017-12-07 19:42:26

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: Pulseaudio mixer tray icon

There appers to be new version 0.3.4 of xfce4-pulseaudio-plugin out, but not yet on repos. You should check if that fixes the issue.

If it doesn't, since multiple users seem to have the same issue, you should open a bug report.

Last edited by ooo (2017-12-07 19:42:38)

Offline

#9 2017-12-07 22:53:16

unnilquadium
Member
Registered: 2017-08-27
Posts: 30

Re: Pulseaudio mixer tray icon

OK, thank you. I'll wait for the next version.

Offline

#10 2017-12-08 10:37:34

unnilquadium
Member
Registered: 2017-08-27
Posts: 30

Re: Pulseaudio mixer tray icon

After upgrading xfce4-pulseaudio-plugin to version 0.3.4-1 the problem persists.
I'm opening the bug report.

EDIT: I can also confirm that this problem is related to xfce4-pulseaudio-plugin. Version 0.3.2 of that package works properly.

Last edited by unnilquadium (2017-12-08 10:53:47)

Offline

#11 2018-01-21 14:54:21

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,543
Website

Re: Pulseaudio mixer tray icon

@unnilquadium - Please post the link to the upstream bug report for others finding this thread.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs • 1.21 JIGOWATTS!

Offline

#12 2018-03-08 09:33:25

Condor
Member
Registered: 2017-12-01
Posts: 26

Re: Pulseaudio mixer tray icon

I had the same issue, see bug 14071 over at Xfce's bugtracker.

The xfce4-pulseaudio-plugin was fixed in revision 0.3.5, which was shipped as package a couple days ago.

Offline

Board footer

Powered by FluxBB