You are not logged in.

#1 2017-12-13 04:27:10

erakis
Member
Registered: 2017-12-12
Posts: 9

Dell Precision 7510 - No sound after resume from suspend

Hi,

If I suspend my laptop and then resume it the sound in all application stop working (there is no sound coming out of the speakers).

Steps to reproduce the problem

  1. I'm listening a video through Chromium, the video and sound are both properly properly working (Youtube)

  2. I suspend the laptop and then resume it.

  3. I click on the play button of youtube video but now there a freezing delay (~1min) before the video restart.

  4. Once the video restart playing, the video plays well but no sound get out from speaker or headphone like I had before supending the computer.

Same problem for audacy or any application related to sound playing.

I read carefully the arch linux troubleshooting at No_sound_after_resume_from_suspend and tried a lot of thing but nothing work. I can get sound working back.

The only workaround I found to get the sound working again is by opening the windows [Menu + Preferences + Power Management]. It is like the audio get reset or I don't know. But using this hack every time I open my laptop cover is a little bit annoying. But I hope this may give you more information on my problem or an alternative solution...

My hardware/software configuration

Dell Precision 7510 
Intel(R) Core(TM) i5-6300HQ CPU @ 2.30GHz
Intel Corporation HD Graphics 530
Radeon HD 8890M / R9 M275X/M375X
8GB RAM (2 x 4096 SK Hynix)
500GB SSD INTEL SSDSA2BW60

Arch Linux Linux 4.14.4-1-ARCH #1 SMP PREEMPT Tue Dec 5 19:10:06 UTC 2017 x86_64 GNU/Linux
Cinnamon 3.6.6
GDM 3.26.2.1

Information about sound cards

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdfd48000 irq 135
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xdfc60000 irq 134

Here is what I've tried yet

Trying to reloading pulseaudio

$ /usr/bin/pasuspender /bin/true
Connection failure: Timeout

Killing and restarting pulseaudio

$ pulseaudio -k
$ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {48ef8c709bcc4d319ab3c46e630c5401}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.

$ pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed

Getting more information about failure of pulseaudio

$pulseaudio -vvvv 
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 11.1
D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -Wall -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 4.14.4-1-ARCH #1 SMP PREEMPT Tue Dec 5 19:10:06 UTC 2017
D: [pulseaudio] main.c: Found 4 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is 48ef8c709bcc4d319ab3c46e630c5401.
I: [pulseaudio] main.c: Session ID is c3.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/mbeaudet/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-11.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed

Next I tried the solution proposed in the following troubleshooting at  Daemon_startup_failed but always no positive result.

$ rm -rf /tmp/pulse* ~/.pulse* ~/.config/pulse
$ pulseaudio -k
$ pulseaudio --start
N: [pulseaudio] main.c: User-configured server at {48ef8c709bcc4d319ab3c46e630c5401}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.

I tried running alsamixer, it lunch without problem, but If I tried selected the sound card HDA ATI HDMI the program hang/freeze, I have to close the console.

Maybe the program is running multiple time ?

$ ps aux | grep pulseaudio
gdm       4947  0.0  0.1 1148404 11576 ?       Ssl  21:56   0:00 /usr/bin/pulseaudio --daemonize=no
erakis    5238  1.4  0.1 1757460 15248 ?       Dsl  22:01   0:32 /usr/bin/pulseaudio --daemonize=no
erakis    7666  0.0  0.0  12108  2224 pts/1    S+   22:38   0:00 grep pulseaudio

I tried killing all instance to restart pulseaudio but without success

$ sudo killall -9 pulseaudio
[sudo] password for erakis: 
$ ps aux | grep pulseaudio
erakis     5238  1.4  0.1 1757460 15368 ?       Ds   22:01   0:34 /usr/bin/pulseaudio --daemonize=no
gdm       7682  0.0  0.0 739780  7772 ?        Ssl  22:40   0:00 /usr/bin/pulseaudio --daemonize=no
erakis     7695  0.0  0.0  12108  2280 pts/1    S+   22:41   0:00 grep pulseaudio

Maybe the process auto-spawn, but it is configured to NO.

$ cat /etc/pulse/client.conf | grep autospawn
autospawn = no
; autospawn = yes

Getting a test from pulseaudio but I got nothing.

$ pulseaudio --check
$ 

I tried installing pavucontrol but the application hang while starting. I had to kill it after waiting more than 10 minutes. It like the pulseaudio deamon is not responding ? Is the problem could be other thing like driver or other related kernel mod ?

Result of dmesg

$ dmesg | curl -F c=@- https://ptpb.pw 
https://ptpb.pw/CkH9

Result of lspci

$ lspci | curl -F c=@- https://ptpb.pw 
https://ptpb.pw/ftBA

Best regards,
Martin

Offline

Board footer

Powered by FluxBB