You are not logged in.

#1 2017-12-14 09:36:20

seenxu
Member
Registered: 2008-08-25
Posts: 108

[solved]after latest upgrade qt application can't find LibQt5Core.so.5

$ qt5ct 
qt5ct: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

$ uic
uic: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

the qt5-base is installed

$ pacman -Ql qt5-base | grep -i LibQt5Core
qt5-base /usr/lib/libQt5Core.prl
qt5-base /usr/lib/libQt5Core.so
qt5-base /usr/lib/libQt5Core.so.5
qt5-base /usr/lib/libQt5Core.so.5.10
qt5-base /usr/lib/libQt5Core.so.5.10.0
$ ls /usr/lib/libQt5Core.* -l
-rw-r--r-- 1 root root    1114 Dez  7 08:30 /usr/lib/libQt5Core.prl
lrwxrwxrwx 1 root root      20 Dez  7 08:30 /usr/lib/libQt5Core.so -> libQt5Core.so.5.10.0
lrwxrwxrwx 1 root root      20 Dez  7 08:30 /usr/lib/libQt5Core.so.5 -> libQt5Core.so.5.10.0
lrwxrwxrwx 1 root root      20 Dez  7 08:30 /usr/lib/libQt5Core.so.5.10 -> libQt5Core.so.5.10.0
-rwxr-xr-x 1 root root 5250712 Dez  7 08:30 /usr/lib/libQt5Core.so.5.10.0

Last edited by seenxu (2017-12-15 16:17:22)

Offline

#2 2017-12-14 09:38:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 6,753

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Are you using a non-repo QT5 theme? Rebuild it.

Online

#3 2017-12-14 09:54:04

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

$ yaourt -Qs qt | grep -E '^[a-z]'
local/adwaita-qt4 1.0-1 (adwaita-qt)
local/adwaita-qt5 1.0-1 (adwaita-qt)
extra/attica-qt4 0.4.2-3
community/fcitx-qt4 4.2.9.5-1 (fcitx-im)
community/fcitx-qt5 1.2.1-2 (fcitx-im)
extra/libdbusmenu-qt4 0.9.3+16.04.20160218-1
extra/phonon-qt4 4.9.1-4
extra/phonon-qt4-gstreamer 4.9.0-3
extra/phonon-qt5 4.9.1-4
extra/phonon-qt5-gstreamer 4.9.0-3
extra/polkit-qt4 0.112.0+git20160226-1
extra/poppler-qt5 0.61.1-1
extra/pyqt5-common 5.9.2-2
extra/python-pyqt5 5.9.2-2
extra/python2-pyqt5 5.9.2-2
extra/qt4 4.8.7-23
extra/qt5-base 5.10.0-1 (qt qt5)
extra/qt5-declarative 5.10.0-1 (qt qt5)
extra/qt5-location 5.10.0-1 (qt qt5)
extra/qt5-multimedia 5.10.0-1 (qt qt5)
extra/qt5-script 5.10.0-1 (qt qt5)
extra/qt5-sensors 5.10.0-1 (qt qt5)
extra/qt5-svg 5.10.0-1 (qt qt5)
extra/qt5-tools 5.10.0-1 (qt qt5)
extra/qt5-webchannel 5.10.0-1 (qt qt5)
extra/qt5-webengine 5.10.0-1 (qt qt5)
extra/qt5-webkit 5.212.0alpha2-11 (qt qt5)
extra/qt5-x11extras 5.10.0-1 (qt qt5)
extra/qt5-xmlpatterns 5.10.0-1 (qt qt5)
community/qt5ct 0.34-2

at the moment, I had installed two qt themes, adwaita-qt4 and adwaita-qt5 from aur, recompile adwaita-qt, issue persists.

Last edited by seenxu (2017-12-14 09:59:19)

Offline

#4 2017-12-14 10:05:14

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 319
Website

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Is your Arch fully upgraded? Qt5ct was rebuild against of Qt 5.10 7 days ago, and it works, uic is a part of qt5-base and it works, too.

Offline

#5 2017-12-14 10:32:29

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

# pacdiffviewer 
0 .pacorig found
0 .pacnew found
0 .pacsave found
0 files are orphans

* pacdiff is clean
* latest mirrors are enabled in /etc/pacman.d/mirrorlist
* `pacman -Syu` sys "there is nothing to do"

Offline

#6 2017-12-14 13:57:47

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 319
Website

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Yeah..., maybe check integration of yours packages? Missing for qt5ct and uic lib (libQt5Core.so.5) is delivered by qt5-base and this packages (and lib too) is in 5.10 version in your system. Qt5ct was rebuild against of Qt 5.10 with 0.34-2 version and this package in this version is in your system, too. So everything looks ok, but doesn't work wink The other Qt5 apps work well?

Offline

#7 2017-12-14 15:00:23

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

qt5* is installed as dependencies from goldendict, which is, of course, failed to start with the same warning.

I had also try to pacman -Rs goldendict, and reinstall everything with empty /var/cache/pacman/pkg/, still the same.

 
$ sudo pacman -S goldendict
resolving dependencies...
:: There are 2 providers available for phonon-qt5-backend:
:: Repository extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Enter a number (default=1): 1
looking for conflicting packages...
warning: dependency cycle detected:
warning: phonon-qt5-gstreamer will be installed before its phonon-qt5 dependency

Packages (20) double-conversion-3.0.0-1  libxkbcommon-x11-0.7.2-1  phonon-qt5-4.9.1-4  phonon-qt5-gstreamer-4.9.0-3  qt5-base-5.10.0-1  qt5-declarative-5.10.0-1  qt5-location-5.10.0-1  qt5-sensors-5.10.0-1  qt5-svg-5.10.0-1  qt5-tools-5.10.0-1  qt5-webchannel-5.10.0-1
              qt5-webkit-5.212.0alpha2-11  qt5-x11extras-5.10.0-1  qt5-xmlpatterns-5.10.0-1  tslib-1.14-1  xcb-util-image-0.4.0-1  xcb-util-keysyms-0.4.0-1  xcb-util-renderutil-0.3.9-1  xcb-util-wm-0.4.1-1  goldendict-1.5.0RC2-6

Total Download Size:     0,20 MiB
Total Installed Size:  171,04 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 xcb-util-keysyms-0.4.0-1-x86_64                                                                                                             6,8 KiB   676K/s 00:00 [######################################################################################################] 100%
 xcb-util-renderutil-0.3.9-1-x86_64                                                                                                          8,2 KiB   817K/s 00:00 [######################################################################################################] 100%
 xcb-util-wm-0.4.1-1-x86_64                                                                                                                 30,5 KiB  1525K/s 00:00 [######################################################################################################] 100%
 xcb-util-image-0.4.0-1-x86_64                                                                                                              15,9 KiB  1593K/s 00:00 [######################################################################################################] 100%
 tslib-1.14-1-x86_64                                                                                                                        81,4 KiB  2034K/s 00:00 [######################################################################################################] 100%
 libxkbcommon-x11-0.7.2-1-x86_64                                                                                                            18,0 KiB  1801K/s 00:00 [######################################################################################################] 100%
 double-conversion-3.0.0-1-x86_64                                                                                                           45,6 KiB  2,23M/s 00:00 [######################################################################################################] 100%
(20/20) checking keys in keyring                                                                                                                                    [######################################################################################################] 100%
(20/20) checking package integrity                                                                                                                                  [######################################################################################################] 100%
(20/20) loading package files                                                                                                                                       [######################################################################################################] 100%
(20/20) checking for file conflicts                                                                                                                                 [######################################################################################################] 100%
(20/20) checking available disk space                                                                                                                               [######################################################################################################] 100%
:: Processing package changes...
( 1/20) installing xcb-util-keysyms                                                                                                                                 [######################################################################################################] 100%
( 2/20) installing xcb-util-renderutil                                                                                                                              [######################################################################################################] 100%
( 3/20) installing xcb-util-wm                                                                                                                                      [######################################################################################################] 100%
( 4/20) installing xcb-util-image                                                                                                                                   [######################################################################################################] 100%
( 5/20) installing tslib                                                                                                                                            [######################################################################################################] 100%
( 6/20) installing libxkbcommon-x11                                                                                                                                 [######################################################################################################] 100%
( 7/20) installing double-conversion                                                                                                                                [######################################################################################################] 100%
( 8/20) installing qt5-base                                                                                                                                         [######################################################################################################] 100%
Optional dependencies for qt5-base
    qt5-svg: to use SVG icon themes [pending]
    postgresql-libs: PostgreSQL driver [installed]
    libmariadbclient: MariaDB driver [installed]
    unixodbc: ODBC driver [installed]
    libfbclient: Firebird/iBase driver [installed]
    freetds: MS SQL driver
    gtk3: GTK platform plugin [installed]
( 9/20) installing qt5-xmlpatterns                                                                                                                                  [######################################################################################################] 100%
(10/20) installing qt5-declarative                                                                                                                                  [######################################################################################################] 100%
(11/20) installing qt5-location                                                                                                                                     [######################################################################################################] 100%
Optional dependencies for qt5-location
    gypsy: Gypsy geolocation plugin
(12/20) installing qt5-sensors                                                                                                                                      [######################################################################################################] 100%
Optional dependencies for qt5-sensors
    qt5-declarative: QML bindings [installed]
(13/20) installing qt5-webchannel                                                                                                                                   [######################################################################################################] 100%
(14/20) installing qt5-webkit                                                                                                                                       [######################################################################################################] 100%
Optional dependencies for qt5-webkit
    gst-plugins-good: Webm codec support [installed]
(15/20) installing qt5-svg                                                                                                                                          [######################################################################################################] 100%
(16/20) installing qt5-x11extras                                                                                                                                    [######################################################################################################] 100%
(17/20) installing qt5-tools                                                                                                                                        [######################################################################################################] 100%
Optional dependencies for qt5-tools
    qt5-doc: documentation
    qt5-webkit: for Qt Assistant [installed]
(18/20) installing phonon-qt5-gstreamer                                                                                                                             [######################################################################################################] 100%
Optional dependencies for phonon-qt5-gstreamer
    pulseaudio: PulseAudio support [installed]
    gst-plugins-good: PulseAudio support and good codecs [installed]
    gst-plugins-bad: additional codecs [installed]
    gst-plugins-ugly: additional codecs [installed]
    gst-libav: libav codec [installed]
(19/20) installing phonon-qt5                                                                                                                                       [######################################################################################################] 100%
Optional dependencies for phonon-qt5
    pulseaudio: PulseAudio support [installed]
(20/20) installing goldendict                                                                                                                                       [######################################################################################################] 100%
:: Running post-transaction hooks...
(1/3) Updating icon theme caches...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...

Last edited by seenxu (2017-12-14 15:16:15)

Offline

#8 2017-12-14 15:05:42

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 21,585
Website

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

How about some actual diagnostic information about the error:

type qt5ct
ldd /usr/bin/qt5ct
env | grep ^LD

Last edited by Trilby (2017-12-14 15:07:35)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#9 2017-12-14 15:07:25

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 319
Website

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Maybe it's something with dependencies. Try to install (almost) whole qt5 (qt5-doc or qt5-examples for sure is not neccessary) and try again. If everything will be works (as expected), there is something with wrong dependencies. If not - who knows.

Offline

#10 2017-12-14 15:18:49

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Trilby wrote:

How about some actual diagnostic information about the error:

type qt5ct
ldd /usr/bin/qt5ct
env | grep ^LD
$ type qt5ct
qt5ct is /usr/bin/qt5ct
 
$ ldd /usr/bin/qt5ct
	linux-vdso.so.1 (0x00007ffc78a8d000)
	libQt5Widgets.so.5 => /usr/lib/libQt5Widgets.so.5 (0x00007f8c7483a000)
	libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0x00007f8c7407b000)
	libQt5Core.so.5 => not found
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f8c73cf4000)
	libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f8c73add000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f8c73725000)
	libQt5Core.so.5 => not found
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f8c73507000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f8c731bb000)
	libQt5Core.so.5 => not found
	libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f8c72f30000)
	libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f8c72cfa000)
	libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f8c72a5b000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007f8c72844000)
	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f8c752fb000)
	libGLX.so.0 => /usr/lib/libGLX.so.0 (0x00007f8c72613000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f8c722d4000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x00007f8c720c2000)
	libGLdispatch.so.0 => /usr/lib/libGLdispatch.so.0 (0x00007f8c71e0c000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f8c71c08000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f8c718e9000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007f8c71623000)
	libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f8c713f7000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f8c711ce000)
	libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f8c70f5b000)
	libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f8c70d4b000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f8c70b47000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f8c70941000)

$ env | grep ^LD

interesting to note, there is no env var starting with *LD*

Offline

#11 2017-12-15 15:02:37

progandy
Member
Registered: 2012-05-17
Posts: 3,370

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Hmm, maybe run "ldconfig -X" as root to rebuild /etc/ld.so.cache?

Last edited by progandy (2017-12-15 15:06:09)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#12 2017-12-15 15:05:38

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

progandy wrote:

Hmm, maybe run "ldconfig -X" as root to rebuild /etc/ld.so.cache?


tried, still the same error.

Offline

#13 2017-12-15 15:08:51

seth
Member
Registered: 2012-09-03
Posts: 11,332

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

stat /usr/lib/libQt5Core.so

Offline

#14 2017-12-15 15:18:45

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,823
Website

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Please post the output from the following:

$ pacman -Qi qt5-base qt5ct
$ pacman -Qkk qt5-base qt5ct
$ file /usr/lib/libQt5Core.so.5.10.0
$ sha1sum /usr/lib/libQt5Core.so.5.10.0
$ ldd /usr/lib/libQt5Core.so.5.10.0

Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#15 2017-12-15 15:18:53

progandy
Member
Registered: 2012-05-17
Posts: 3,370

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Does this work?

/usr/lib/ld-linux-x86-64.so.2 --inhibit-cache /usr/bin/uic -v

Maybe you can see some where it tries to look for libQt5Core. "uic -v" works for me and prints "uic 5.10.0", so here is an extract from the debug log of a working run (both with and without cache)

$ LD_DEBUG=files,libs uic -v
...
     26090:	
     26090:	file=libQt5Core.so.5 [0];  needed by uic [0]
     26090:	find library=libQt5Core.so.5 [0]; searching
     26090:	 search cache=/etc/ld.so.cache
     26090:	  trying file=/usr/lib/libQt5Core.so.5
     26090:	
     26090:	file=libQt5Core.so.5 [0];  generating link map
     26090:	  dynamic: 0x00007fd1cfa4eaa0  base: 0x00007fd1cf34f000   size: 0x0000000000705660
     26090:	    entry: 0x00007fd1cf3e4d80  phdr: 0x00007fd1cf34f040  phnum:                 11
     26090:	
...
$ LD_DEBUG=files,libs /usr/lib/ld-linux-x86-64.so.2 --inhibit-cache /usr/bin/uic -v
...
     26225:	
     26225:	file=libQt5Core.so.5 [0];  needed by /usr/bin/uic [0]
     26225:	find library=libQt5Core.so.5 [0]; searching
     26225:	 search path=/usr/lib/tls/x86_64/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls:/usr/lib/x86_64/x86_64:/usr/lib/x86_64:/usr/lib/x86_64:/usr/lib		(system search path)
     26225:	  trying file=/usr/lib/tls/x86_64/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/tls/libQt5Core.so.5
     26225:	  trying file=/usr/lib/x86_64/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/libQt5Core.so.5
     26225:	
     26225:	file=libQt5Core.so.5 [0];  generating link map
     26225:	  dynamic: 0x00007f0572588aa0  base: 0x00007f0571e89000   size: 0x0000000000705660
     26225:	    entry: 0x00007f0571f1ed80  phdr: 0x00007f0571e89040  phnum:                 11
     26225:	
...

Last edited by progandy (2017-12-15 15:21:05)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#16 2017-12-15 15:21:06

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

seth wrote:
stat /usr/lib/libQt5Core.so
# stat /usr/lib/libQt5Core.so
  File: /usr/lib/libQt5Core.so -> libQt5Core.so.5.10.0
  Size: 20        	Blocks: 0          IO Block: 4096   symbolic link
Device: fe01h/65025d	Inode: 2361912     Links: 1
Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2017-12-14 16:09:51.000000000 +0100
Modify: 2017-12-07 08:30:35.000000000 +0100
Change: 2017-12-14 16:09:51.586408356 +0100
 Birth: -

Last edited by seenxu (2017-12-15 15:21:19)

Offline

#17 2017-12-15 15:24:31

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

WorMzy wrote:

Please post the output from the following:

$ pacman -Qi qt5-base qt5ct
$ pacman -Qkk qt5-base qt5ct
$ file /usr/lib/libQt5Core.so.5.10.0
$ sha1sum /usr/lib/libQt5Core.so.5.10.0
$ ldd /usr/lib/libQt5Core.so.5.10.0
$ pacman -Qi qt5-base qt5ct
Name            : qt5-base
Version         : 5.10.0-1
Description     : A cross-platform application and UI framework
Architecture    : x86_64
URL             : http://qt-project.org/
Licenses        : GPL3  LGPL3  FDL  custom
Groups          : qt  qt5
Provides        : None
Depends On      : libjpeg-turbo  xcb-util-keysyms  xcb-util-renderutil  libgl  fontconfig  xdg-utils  xcb-util-wm  libxrender  libxi  sqlite
                  xcb-util-image  icu  pcre2  tslib  libinput  libsm  libxkbcommon-x11  libproxy  libcups  double-conversion
Optional Deps   : qt5-svg: to use SVG icon themes [installed]
                  postgresql-libs: PostgreSQL driver [installed]
                  libmariadbclient: MariaDB driver [installed]
                  unixodbc: ODBC driver [installed]
                  libfbclient: Firebird/iBase driver [installed]
                  freetds: MS SQL driver
                  gtk3: GTK platform plugin [installed]
Required By     : qt5-svg
Optional For    : cmake  openal  pinentry  v4l-utils
Conflicts With  : qtchooser
Replaces        : None
Installed Size  : 57,76 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Do 07 Dez 2017 08:31:01 CET
Install Date    : Fr 15 Dez 2017 16:22:00 CET
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Name            : qt5ct
Version         : 0.34-2
Description     : Qt5 Configuration Utility
Architecture    : x86_64
URL             : https://qt5ct.sourceforge.net
Licenses        : BSD
Groups          : None
Provides        : None
Depends On      : qt5-svg
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 742,00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Do 07 Dez 2017 12:42:53 CET
Install Date    : Fr 15 Dez 2017 16:22:00 CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
$ pacman -Qkk qt5-base qt5ct
warning: qt5-base: /usr/share/doc (No such file or directory)
qt5-base: 3521 total files, 1 altered file
qt5ct: 16 total files, 0 altered files
$ file /usr/lib/libQt5Core.so.5.10.0
/usr/lib/libQt5Core.so.5.10.0: ELF 64-bit LSB shared object, x86-64, version 1 (GNU/Linux), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, BuildID[sha1]=39a438e07f0e721d66ffdd5b72e0e33c9f1d80a1, for GNU/Linux 3.17.0, stripped
$ sha1sum /usr/lib/libQt5Core.so.5.10.0
7c77a05111a3cefbd501eb5ec3d2e8902e8d2270  /usr/lib/libQt5Core.so.5.10.0
$ ldd /usr/lib/libQt5Core.so.5.10.0
	linux-vdso.so.1 (0x00007ffc5bbdd000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f5411542000)
	libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007f54112c3000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007f54110ac000)
	libicui18n.so.60 => /usr/lib/libicui18n.so.60 (0x00007f5410c09000)
	libicuuc.so.60 => /usr/lib/libicuuc.so.60 (0x00007f5410850000)
	libpcre2-16.so.0 => /usr/lib/libpcre2-16.so.0 (0x00007f54105d8000)
	libdouble-conversion.so.1 => /usr/lib/libdouble-conversion.so.1 (0x00007f54103c8000)
	libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f54101c4000)
	libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f540fea5000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f540fb1e000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007f540f7d2000)
	libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f540f5bb000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007f540f203000)
	/lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f5411e66000)
	libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007f540eee7000)
	librt.so.1 => /usr/lib/librt.so.1 (0x00007f540ecdf000)
	liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007f540eab9000)
	liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007f540e8a4000)
	libicudata.so.60 => /usr/lib/libicudata.so.60 (0x00007f540cd0f000)
	libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f540ca9c000)
	libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007f540c887000)

Last edited by seenxu (2017-12-15 15:28:01)

Offline

#18 2017-12-15 15:25:57

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

progandy wrote:

Does this work?

/usr/lib/ld-linux-x86-64.so.2 --inhibit-cache /usr/bin/uic -v

Maybe you can see some where it tries to look for libQt5Core. "uic -v" works for me and prints "uic 5.10.0", so here is an extract from the debug log of a working run (both with and without cache)

$ LD_DEBUG=files,libs uic -v
...
     26090:	
     26090:	file=libQt5Core.so.5 [0];  needed by uic [0]
     26090:	find library=libQt5Core.so.5 [0]; searching
     26090:	 search cache=/etc/ld.so.cache
     26090:	  trying file=/usr/lib/libQt5Core.so.5
     26090:	
     26090:	file=libQt5Core.so.5 [0];  generating link map
     26090:	  dynamic: 0x00007fd1cfa4eaa0  base: 0x00007fd1cf34f000   size: 0x0000000000705660
     26090:	    entry: 0x00007fd1cf3e4d80  phdr: 0x00007fd1cf34f040  phnum:                 11
     26090:	
...
$ LD_DEBUG=files,libs /usr/lib/ld-linux-x86-64.so.2 --inhibit-cache /usr/bin/uic -v
...
     26225:	
     26225:	file=libQt5Core.so.5 [0];  needed by /usr/bin/uic [0]
     26225:	find library=libQt5Core.so.5 [0]; searching
     26225:	 search path=/usr/lib/tls/x86_64/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls:/usr/lib/x86_64/x86_64:/usr/lib/x86_64:/usr/lib/x86_64:/usr/lib		(system search path)
     26225:	  trying file=/usr/lib/tls/x86_64/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/tls/libQt5Core.so.5
     26225:	  trying file=/usr/lib/x86_64/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
     26225:	  trying file=/usr/lib/libQt5Core.so.5
     26225:	
     26225:	file=libQt5Core.so.5 [0];  generating link map
     26225:	  dynamic: 0x00007f0572588aa0  base: 0x00007f0571e89000   size: 0x0000000000705660
     26225:	    entry: 0x00007f0571f1ed80  phdr: 0x00007f0571e89040  phnum:                 11
     26225:	
...
$ /usr/lib/ld-linux-x86-64.so.2 --inhibit-cache /usr/bin/uic -v
/usr/bin/uic: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
$ LD_DEBUG=files,libs uic -v
      8907:	
      8907:	WARNING: Unsupported flag value(s) of 0x8000000 in DT_FLAGS_1.
      8907:	
      8907:	file=libQt5Core.so.5 [0];  needed by uic [0]
      8907:	find library=libQt5Core.so.5 [0]; searching
      8907:	 search cache=/etc/ld.so.cache
      8907:	 search path=/usr/lib/tls/x86_64/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls:/usr/lib/x86_64/x86_64:/usr/lib/x86_64:/usr/lib/x86_64:/usr/lib		(system search path)
      8907:	  trying file=/usr/lib/tls/x86_64/x86_64/libQt5Core.so.5
      8907:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
      8907:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
      8907:	  trying file=/usr/lib/tls/libQt5Core.so.5
      8907:	  trying file=/usr/lib/x86_64/x86_64/libQt5Core.so.5
      8907:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
      8907:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
      8907:	  trying file=/usr/lib/libQt5Core.so.5
      8907:	
uic: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
$ LD_DEBUG=files,libs /usr/lib/ld-linux-x86-64.so.2 --inhibit-cache /usr/bin/uic -v
      9024:	file=/usr/bin/uic [0];  generating link map
      9024:	
      9024:	WARNING: Unsupported flag value(s) of 0x8000000 in DT_FLAGS_1.
      9024:	  dynamic: 0x00007f81a73ed820  base: 0x00007f81a7161000   size: 0x000000000028d020
      9024:	    entry: 0x00007f81a7179720  phdr: 0x00007f81a7161040  phnum:                  9
      9024:	
      9024:	
      9024:	file=libQt5Core.so.5 [0];  needed by /usr/bin/uic [0]
      9024:	find library=libQt5Core.so.5 [0]; searching
      9024:	 search path=/usr/lib/tls/x86_64/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls/x86_64:/usr/lib/tls:/usr/lib/x86_64/x86_64:/usr/lib/x86_64:/usr/lib/x86_64:/usr/lib		(system search path)
      9024:	  trying file=/usr/lib/tls/x86_64/x86_64/libQt5Core.so.5
      9024:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
      9024:	  trying file=/usr/lib/tls/x86_64/libQt5Core.so.5
      9024:	  trying file=/usr/lib/tls/libQt5Core.so.5
      9024:	  trying file=/usr/lib/x86_64/x86_64/libQt5Core.so.5
      9024:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
      9024:	  trying file=/usr/lib/x86_64/libQt5Core.so.5
      9024:	  trying file=/usr/lib/libQt5Core.so.5
      9024:	
/usr/bin/uic: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

Last edited by seenxu (2017-12-15 15:27:11)

Offline

#19 2017-12-15 15:35:59

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,618

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

Is this on a physical system or on a VM/container? Which kernel and glibc version?

Last edited by arojas (2017-12-15 15:36:38)

Offline

#20 2017-12-15 15:45:22

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

arojas wrote:

Is this on a physical system or on a VM/container? Which kernel and glibc version?

I'm running arch an old thinkpad x200, due to the intel graphic displayport issue, I am still running kernel-3.14.79 on this host, which is the only kernel version that has stable support on displayport output to external monitor, other kernel version I tried, will frozen the host after x hours.

Offline

#21 2017-12-15 15:55:11

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 319
Website

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

seenxu wrote:
$ pacman -Qkk qt5-base qt5ct
warning: qt5-base: /usr/share/doc (No such file or directory)
qt5-base: 3521 total files, 1 altered file

What did you changed in qt5-base package? There should be /usr/share/doc (see list of files: https://www.archlinux.org/packages/extr … ase/files/) and any altered files. Maybe just reinstall qt5-base?

Offline

#22 2017-12-15 16:03:16

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

arojas wrote:

Is this on a physical system or on a VM/container? Which kernel and glibc version?

I had just booted into 4.4.x kernel, it works!

Offline

#23 2017-12-15 16:07:12

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

pb wrote:
seenxu wrote:
$ pacman -Qkk qt5-base qt5ct
warning: qt5-base: /usr/share/doc (No such file or directory)
qt5-base: 3521 total files, 1 altered file

What did you changed in qt5-base package? There should be /usr/share/doc (see list of files: https://www.archlinux.org/packages/extr … ase/files/) and any altered files. Maybe just reinstall qt5-base?

* I add `usr/share/doc/*` to the NoExtract in `/etc/pacman.conf` to avoid install any of the doc related files.
* I had just revert the NoExtract setting, install intact qt5-base, problem persists.
* with or without `/usr/share/doc/qt/*`, qt5 works in kernel-4.4.x, but not kernel-3.14.x, so the problem is caused by the unmaintained old kernel.

Offline

#24 2017-12-15 16:11:06

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,618

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

You problem is indeed the old kernel. Qt 5.10 uses the renameat2 system call which is only available since kernel 3.15

Last edited by arojas (2017-12-15 16:12:26)

Offline

#25 2017-12-15 16:16:25

seenxu
Member
Registered: 2008-08-25
Posts: 108

Re: [solved]after latest upgrade qt application can't find LibQt5Core.so.5

arojas wrote:

You problem is indeed the old kernel. Qt 5.10 uses the renameat2 system call which is only available since kernel 3.16

bad luck for my old x200.

luckily enough, I am using qt5 only for goldendict, in aur there is goldendict-git can be compiled with qt4, i could struggle to use kernel-3.14.x for now. but anyway, sooner or later upgrade kernel is the only way out.

again, thanks everyone involved in this thread.

Offline

Board footer

Powered by FluxBB