You are not logged in.

#1 2017-12-14 17:07:17

DooMIII
Member
Registered: 2017-12-14
Posts: 7

Keyboard Layout issue in KDE plasma : no dead keys (azerty)

Hello all,

I have an arch linux dell xps 13 with gnome and KDE plasma.

I installed SDDM (after gdm, which i deleted) and set all locales I could get my hand on to fr_FR.UTF-8. I set sddm.conf to "QtVirtualKeyboard"

In SDDM screen, azerty keyboard works great (with dead keys ^ and ¨ working "âôöÏ" etc...)

In gnome, works great too.

In KDE Plasma, many issues : 

- The default layout is qwerty, even though i set everything to "fr_FR..."
- Whenever i set manually an azerty layout in KDE settings, i have azerty but dead keys issues :
     *In gtk/gnome apps like Firefox, gedit, i have azerty and dead keys need to be pressed twice before working, to get â i have to press "^^a" instead of "^a"
     *In qt4/5 apps like kate or KDE search bar, i have azerty but NO dead keys

I wonder what sets the keyboard back to qwerty during KDE login... all locales are set to FR... and i wonder how to get back "normal" dead keys. (I want dead keys)

Hope somebody has an idea...

Offline

#2 2017-12-15 13:32:01

DooMIII
Member
Registered: 2017-12-14
Posts: 7

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

Actually, even though everything has been set to fr, I still have this :

$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     us
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us+inet(evdev)"     };
        xkb_geometry  { include "pc(pc105)"     };
};

and this

$ setxkbmap -query
rules:      evdev
model:      pc105
layout:     us

I assume this is for X11 only and not Wayland/KDE but there must be something from KDE grabbing the wrong info at some point after login...

However SDDM splash screen IS in azerty by default...

Offline

#3 2017-12-16 14:14:27

fjvinal
Member
From: Madrid
Registered: 2012-06-23
Posts: 45

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

I have a similar issue (no tildes in vowels) with the Spanish keyboard in KDE/Plasma with Wayland.
With Xorg all works fine.

Offline

#4 2017-12-16 14:24:31

DooMIII
Member
Registered: 2017-12-14
Posts: 7

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

You are right, just found out you can run plasma without wayland and the issue vanishes.

On Xorg I have french/azerty by default and no trouble with â ï (But no way to write `E or ~n but that may be a normal feature of french keyboards..)

I thought ~ was only needed on n in spanish.

Last edited by DooMIII (2017-12-16 14:28:06)

Offline

#5 2017-12-17 20:32:46

fjvinal
Member
From: Madrid
Registered: 2012-06-23
Posts: 45

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

In Wayland/Spanish 'ñ' works and 'áéíóúü' do not work.

Offline

#6 2017-12-17 20:42:49

fjvinal
Member
From: Madrid
Registered: 2012-06-23
Posts: 45

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

Actually, is the main reason why I cannnot migrate to Plasma/Wayland. Also some issues with the menus in Chromium.

Offline

#7 2017-12-19 00:54:05

DooMIII
Member
Registered: 2017-12-14
Posts: 7

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

Well you could use Firefox, it got better with latest patch. Anyway, I will stick to KDE/Xorg too i suppose.

Still no idea why plasma/wayland starts on qwerty layout... i will have another look when I have time.

It seems default layout won't go to azerty by default. Then the layout manually applied works poorly (dead keys, qt vs gtk..)

Offline

#8 2021-02-18 12:55:09

mergen
Member
Registered: 2019-10-27
Posts: 7

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

Offline

#9 2021-02-18 15:02:12

Al3s
Member
Registered: 2011-10-12
Posts: 26

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

I have my keyboard set to spanish layout in the Preferences but in reality it still works as US layout.
I've been using X all this time but I check the Wayland session in each new version of Plasma and this issue is new for me. I guess I'm back to X.
hmm

Offline

#10 2021-02-22 10:47:20

asshur
Member
Registered: 2009-03-06
Posts: 18

Re: Keyboard Layout issue in KDE plasma : no dead keys (azerty)

Can confirm the workaround defined at the bug report works in my Wayland session (at least dead keys in a qwerty environment)

Include following line in /etc/environment

QT_IM_MODULE=

(edited for formatfing)

Last edited by asshur (2021-02-22 10:51:00)

Offline

Board footer

Powered by FluxBB