You are not logged in.

#1 2018-01-25 14:29:06

sanjaychak01
Member
Registered: 2018-01-25
Posts: 37

gnome-terminal not working after system updates, says locale problem

Running gnome-terminal gives me the following error:
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

When I check the system logs, I see the following messages:
Jan 25 19:41:51 ananda-arch gnome-terminal-server[3841]: Locale not supported.
Jan 25 19:41:51 ananda-arch systemd[3405]: gnome-terminal-server.service: Main process exited, code=exited, status=9/n/a
Jan 25 19:41:51 ananda-arch systemd[3405]: gnome-terminal-server.service: Failed with result 'exit-code'.
Jan 25 19:41:51 ananda-arch systemd[3405]: Failed to start GNOME Terminal Server.

When I run "localectl list-locales", the output is "en_US.utf8". Accordingly, my /etc/locale.conf is "LANG=en_US.utf8"
/etc/locale.conf has just one entry uncommented: "en_US.UTF-8 UTF-8"

$ locale
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=es_US.UTF-8
LC_TIME=es_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=es_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=es_US.UTF-8
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=es_US.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

So, everything is US. Now, where is the problem?


_____________________________________________
Running Gnome on Archlinux - great combo!

Offline

#2 2018-01-25 14:33:24

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,600

Re: gnome-terminal not working after system updates, says locale problem

There are a lot of es_US.UTF-8 in that locale output, it stands to reason that you likely want to uncomment es_US.UTF-8 in your /etc/locale.conf as well and rerun locale-gen

Offline

#3 2018-01-25 16:25:43

sanjaychak01
Member
Registered: 2018-01-25
Posts: 37

Re: gnome-terminal not working after system updates, says locale problem

Thanks a lot, V1del. I went to Gnome -> Region & Language settings, and the region was set to United States. But I nevertheless selected US again, and when I restarted the gnome session, the locale was fine.

[sanjay@ananda-arch ~]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

And now the terminal works fine. Thanks a lot for your help!


_____________________________________________
Running Gnome on Archlinux - great combo!

Offline

#4 2019-09-15 20:54:08

ziongate
Member
Registered: 2017-08-18
Posts: 10

Re: gnome-terminal not working after system updates, says locale problem

Had the same error message, but locales are not my issue

gnome-terminal works with

dbus-launch gnome-terminal

or
use

dbus-update-activation-environment --all

in your .xinitrc

Offline

#5 2019-09-15 21:26:34

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,050
Website

Re: gnome-terminal not working after system updates, says locale problem

Don't necrobump with irrelevant information: https://wiki.archlinux.org/index.php/Co … bumping.22

Closing


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB