You are not logged in.

#1 2018-02-10 20:31:42

Orionis
Member
Registered: 2018-01-19
Posts: 13

[SOLVED] How to make USB available in initramfs

I recently installed Arch with a USB boot. During the boot process, the initramfs is supposed to mount a partition on the USB drive it booted from. However, after placing a "ls-l /dev/disk/by-id" in the custom hook, I found out that the USB device doesn't exist in the initramfs.

My hooks are:

HOOKS=(base udev autodetect modconf block keyboard decrypt zfs filesystems)

It is my understanding that the "block" hook should enable usb mass storage devices.

I tried using different USB ports, I added "xhci-hcd" to the MODULES= section, just in case it just happened to be on the USB3 controller. The drive isn't amoung the devices.

Can it be done? If so, how?

EDIT: The fallback initramfs doesn't work either.
EDIT2: It appears I spoke too soon. The USB device wasn't initialized yet, I needed a do/while loop in the hook.

Last edited by Orionis (2018-02-10 21:13:53)

Offline

Board footer

Powered by FluxBB