You are not logged in.

#1 2018-02-17 20:58:09

Gunslinger13
Member
Registered: 2016-06-26
Posts: 12

SOLVED Warn about old perl modules

Hi Everyone,
I ran into this while updating Arch. I looked at the Arch Home Page and tried the command"  pacman -Qqo '/usr/lib/perl5/vendor_perl' to get a list
but that command shows no  needed packages. Everything seems to work fine.  Any ideas about whats going on? Or should I ignore the warning
Thanks for any help
GS

Last edited by Gunslinger13 (2018-02-17 22:12:25)

Offline

#2 2018-02-17 21:02:46

loqs
Member
Registered: 2014-03-06
Posts: 5,956

Re: SOLVED Warn about old perl modules

The perl package now uses a versioned path for compiled modules. This means that modules built for a non-matching perl version will not be loaded any more and must be rebuilt.

A pacman hook warns about affected modules during the upgrade by showing output like this:

WARNING: '/usr/lib/perl5/vendor_perl' contains data from at least 143 packages which will NOT be used by the installed perl interpreter.
-> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/vendor_perl'

You must rebuild all affected packages against the new perl package before you can use them again. The change also affects modules installed directly via CPAN. Rebuilding will also be necessary again with future major perl updates like 5.28 and 5.30.

Please note that rebuilding was already required for major updates prior to this change, however now perl will no longer try to load the modules and then fail in strange ways.

If the build system of some software does not detect the change automatically, you can use perl -V:vendorarch in your PKGBUILD to query perl for the correct path. There is also sitearch for software that is not packaged with pacman.

Did you get such a warning?  What do you mean by no needed packages?  What was the actual output of

pacman -Qqo '/usr/lib/perl5/vendor_perl'

Offline

#3 2018-02-17 21:30:21

Gunslinger13
Member
Registered: 2016-06-26
Posts: 12

Re: SOLVED Warn about old perl modules

Hi,
When I run that command :
Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/vendor_perl'
I do not get a list of modules.
Thanks for the help

Offline

#4 2018-02-17 21:43:08

loqs
Member
Registered: 2014-03-06
Posts: 5,956

Re: SOLVED Warn about old perl modules

A pacman hook warns about affected modules during the upgrade by showing output like this:

WARNING: '/usr/lib/perl5/vendor_perl' contains data from at least 143 packages which will NOT be used by the installed perl interpreter.
-> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/vendor_perl'
loqs wrote:

Did you get such a warning?

Offline

#5 2018-02-17 21:49:23

Gunslinger13
Member
Registered: 2016-06-26
Posts: 12

Re: SOLVED Warn about old perl modules

Hey,
All iI got was "Warning about old perl modules"  I guess it doesn't  matter then?
I'm was  wondering if it was something to be concerned about.
Thanks for your time

Offline

#6 2018-02-17 21:52:12

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 25,886
Website

Re: SOLVED Warn about old perl modules

You could avoid this sort of miscommunication in future by pasting the exact output from the terminal, rather than paraprhrasing the bits you think are relevant.


Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#7 2018-02-17 21:52:36

loqs
Member
Registered: 2014-03-06
Posts: 5,956

Re: SOLVED Warn about old perl modules

You can see the two warnings the perl hook produces here.
I suggest you check your pacman.log for exactly what the message was.

Offline

#8 2018-02-17 22:54:58

Gunslinger13
Member
Registered: 2016-06-26
Posts: 12

Re: SOLVED Warn about old perl modules

Thanks everyone

Offline

#9 2018-02-18 03:21:47

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,369

Re: SOLVED Warn about old perl modules

So the hook that says it will warn you about old perl modules exited without actually warning you, and you thought the name of the hook itself *was* the warning?


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB