You are not logged in.

#1 2018-02-19 20:15:40

mousewithtypewriter
Member
Registered: 2018-02-19
Posts: 9

[SOLVED]bootloader failure:File system /boot is not a fat efi

I was attempting to install the bootloader like this.

bootctl --path=/dev/sda1 install

but the correct way is this

bootctl --path=/boot install

to the mount point not the node.

Last edited by mousewithtypewriter (2018-02-23 18:45:21)

Offline

#2 2018-02-19 20:21:38

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,305
Website

Re: [SOLVED]bootloader failure:File system /boot is not a fat efi

mousewithtypewriter wrote:

bootctl --path=/dev/sda1 install

That should be `bootctl --path=/boot install` or if you are outside the chroot maybe --path=/mnt/boot

The --path parameter needs the mount point, not the device node.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2018-02-19 20:25:08

lo1
Member
Registered: 2017-09-25
Posts: 560

Re: [SOLVED]bootloader failure:File system /boot is not a fat efi

Please, before going any further, consider reformatting your first post: as it is, it's like reading a poem. Use code tags when posting output from a console https://bbs.archlinux.org/help.php and post full commands you entered for partitioning and installing your bootloader.

Also, if you were following the wiki to install systemd-boot https://wiki.archlinux.org/index.php/Sy … t#EFI_boot :

Wiki wrote:

Mount your EFI System Partition (ESP) properly. esp is used to denote the mountpoint in this article.
....
Type the following command to install systemd-boot:

# bootctl --path=esp install

Finally you must configure the boot loader to function properly.  #tip for later

EDIT: Trilby was faster

Last edited by lo1 (2018-02-19 20:25:50)

Offline

#4 2018-02-19 20:28:04

mousewithtypewriter
Member
Registered: 2018-02-19
Posts: 9

Re: [SOLVED]bootloader failure:File system /boot is not a fat efi

Trilby wrote:
mousewithtypewriter wrote:

bootctl --path=/dev/sda1 install

That should be `bootctl --path=/boot install` or if you are outside the chroot maybe --path=/mnt/boot

The --path parameter needs the mount point, not the device node.

This makes sense, thank you for pointing this out.  I will try it when I get home today and mark as solved if this resolves the issue, which I am sure it will.  I will also edit my post to make the formatting better.

Last edited by mousewithtypewriter (2018-02-19 20:32:21)

Offline

Board footer

Powered by FluxBB