You are not logged in.

#1 2018-02-21 03:37:15

Registered: 2007-08-29
Posts: 42

[SOLVED] Folding at home failing since system upgrade

Has anyone else noticed that Folding@Home is failing to start with any work unit since upgrade to Linux 4.15.3-2?

The foldingathome package hasn't changed and has been working fine for ~3 years.
I see the following log from Folding@Home repeated many times in the file:

03:32:11:WU00:FS00:Started FahCore on PID 1191
03:32:11:Started thread 14 on PID 1147
03:32:11:WU00:FS00:Core PID:1195
03:32:11:WU00:FS00:FahCore 0xa4 started
03:32:11:WU00:FS00:0xa4:Folding@Home Gromacs GB Core
03:32:11:WU00:FS00:0xa4:Version 2.27 (Dec. 15, 2010)
03:32:11:WU00:FS00:0xa4:Preparing to commence simulation
03:32:11:WU00:FS00:0xa4:- Ensuring status. Please wait.
03:32:20:WU00:FS00:0xa4:- Looking at optimizations...
03:32:20:WU00:FS00:0xa4:- Working with standard loops on this execution.
03:32:20:WU00:FS00:0xa4:Examination of work files indicates 8 consecutive improper terminations of core.
03:32:21:WU00:FS00:0xa4:- Expanded 879108 -> 2055196 (decompressed 233.7 percent)
03:32:21:WU00:FS00:0xa4:Called DecompressByteArray: compressed_data_size=879108 data_size=2055196, decompressed_data_size=2055196 diff=0
03:32:21:WU00:FS00:0xa4:- Digital signature verified
03:32:21:WU00:FS00:0xa4:Project: 8637 (Run 3, Clone 613, Gen 74)
03:32:21:WU00:FS00:0xa4:Entering M.D.
03:32:27:WU00:FS00:FahCore returned: INTERRUPTED (102 = 0x66)

I've deleted the work unit and tried again, and I've also deleted the fahcore_a4 executable, with no change in behavior.

My hardware configuration hasn't changed and everything else running on the system seems to be running just fine.
I'm using the stock linux kernel package.

Apologies if this is the wrong forum; I searched and I didn't see any recent mention of this failure, nor did I see a forum where this would fit.

Last edited by darkfoon (2018-02-25 00:14:32)


#2 2018-02-22 21:03:32

From: Poland
Registered: 2009-12-20
Posts: 284

Re: [SOLVED] Folding at home failing since system upgrade

I can confirm that it doesn't work:

20:46:08:WU00:FS00:0xa4:- Digital signature verified
20:46:08:WU00:FS00:0xa4:Project: 8631 (Run 1, Clone 532, Gen 23)
20:46:08:WU00:FS00:0xa4:Entering M.D.
20:46:14:WU00:FS00:FahCore returned: INTERRUPTED (102 = 0x66)

Linux linux 4.15.2-2-ARCH

I think you should look for help here:
Try to disable GPU support if possible and recheck. In the end, you might have to report issue here:


#3 2018-02-25 00:05:35

Registered: 2007-08-29
Posts: 42

Re: [SOLVED] Folding at home failing since system upgrade

Thanks for confirming it's not just me. Based on the link you shared, the issue is vsyscall is disabled by default in the latest kernel, but FaH core a4 is compiled against an old version of glibc that depends on vsyscall for gettimeofday().

In case anyone else hits this issue and searches, here's the workaround I used:
edit /etc/default/grub and add vsyscall=emulate to your default linux kernel command line:

GRUB_CMDLINE_LINUX_DEFAULT="... vsyscall=emulate ..."

NOTE: this will weaken some protections against certain kinds of security vulnerabilities, so don't do this on any system that is in production or running servers or is externally exposed.

For more information on what changed with vsyscall, read this:

You can validate for yourself that the default ArchLinux kernel is compiled with vsyscall defaulting to disabled ("NONE"), but is compiled with the option to turn it on via emulation, with this command:

zcat /proc/config.gz | grep VSYSCALL

Another folding@home-type project hit this issue on Debian late last year: … ux-distros

Last edited by darkfoon (2018-02-25 00:06:04)


#4 2018-03-23 06:22:11

Registered: 2018-03-23
Posts: 10

Re: [SOLVED] Folding at home failing since system upgrade

Thanks for the tip! I recently switched to Arch from Antergos, where I had the same problem but had forgotten to note the solution. In my case I am using systemd-boot, so I added vsyscall=emulate to the end of the options line in /boot/loader/entries/arch.conf and rebooted.


Board footer

Powered by FluxBB