You are not logged in.

#1 2018-02-23 00:37:03

senorsmile
Member
Registered: 2010-12-12
Posts: 72

auto boot custom archiso after X seconds

I'm trying to modify the syslinux setup in a customer archiso I'm creating. 

I tried following the instructions here:
https://wiki.archlinux.org/index.php/sy … oot_prompt

but adding
              PROMPT 1
              TIMEOUT 15

to syslinux.cfg does absolutely nothing.

I tried changing PROMPT 1 to PROMPT 0.  Lots of googling is giving me lots of confusing options.

Offline

#2 2019-02-10 01:29:15

N_BaH
Member
Registered: 2015-12-30
Posts: 47

Re: auto boot custom archiso after X seconds

hi,

has anybody got an idea about this ?

I changed syslinux/syslinux.cfg whith no effects
and work/x86_64/airootfs/boot/syslinux/syslinux.cfg with the same no go.

I've removed work/* each time.

what else do you want to know ?

edit: btw, does anybody succeed to add a timeout ?

Last edited by N_BaH (2019-02-10 19:29:01)

Offline

#3 2019-03-22 06:01:09

nixawk
Member
Registered: 2015-01-23
Posts: 7

Re: auto boot custom archiso after X seconds

Try to add the params into archiso_head.cfg.

~/Projects/isobuild/livecd ➭ ll syslinux
total 72K
-rw-r--r-- 1 debug debug  195 Mar 21 15:48 archiso.cfg
-rw-r--r-- 1 debug debug  809 Mar 21 15:48 archiso_head.cfg
-rw-r--r-- 1 debug debug 1.3K Mar 21 15:48 archiso_pxe.cfg
-rw-r--r-- 1 debug debug  418 Mar 21 15:48 archiso_sys.cfg
-rw-r--r-- 1 debug debug  615 Mar 21 15:48 archiso_tail.cfg
-rw-r--r-- 1 debug debug  45K Mar 21 15:48 splash.png
-rw-r--r-- 1 debug debug   74 Mar 21 15:48 syslinux.cfg

Thanks for sharing.

Offline

#4 2019-03-25 18:19:44

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 843

Re: auto boot custom archiso after X seconds

releng/efiboot/loader/loader.conf -> timeout 15?
I don't remember setting prompt anywhere, though...

Offline

#5 2019-03-26 00:01:00

N_BaH
Member
Registered: 2015-12-30
Posts: 47

Re: auto boot custom archiso after X seconds

setting TIMEOUT in archiso_head.cfg did it.

thank you.

it seems that both files have to be configure to honor timeout be it in BIOS (archiso_head.cfg) or in UEFI (efiboot/loader/loader.conf).

Last edited by N_BaH (2019-03-26 02:15:13)

Offline

#6 2019-03-26 14:15:50

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 843

Re: auto boot custom archiso after X seconds

senorsmile wrote:

I tried changing PROMPT 1 to PROMPT 0.  Lots of googling is giving me lots of confusing options.

I didn't remember setting PROMPT indeed, so I looked up why that was again.

You're using the default 'releng' files in it you see:

UI boot/syslinux/vesamenu.c32

I f you use that line, PROMPT is overridden.

see: https://wiki.syslinux.org/wiki/index.ph … =Config#UI

Offline

Board footer

Powered by FluxBB