You are not logged in.

#1 2018-02-23 10:19:08

satriani
Member
Registered: 2015-06-26
Posts: 26

[SOLVED] PRIME with AMD Radeon 530 - Error of failed request: BadValue

Hello,

I have a "Dell Inspiron 15 5570-0326" in front of me, with an Intel® Core ™ i7-8550U 4x 1.80 GHz
and AMD Radeon 530 4.0 GB

I have the following drivers installed
xf86-video-amdgpu 1.4.0-1
xf86-video-intel 1:2.99.917+812+g75795523-1
xf86-video-vesa 2.4.0-1

systemd-boot: modeset=1 enable_rc6=1 enable_fbc=1 quiet splash
MODULES="dm_mod dm_crypt ext4 aes_x86_64 sha256 sha512"

$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x68 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 1 name:Intel
Provider 1: id: 0x3f cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 0 outputs: 0 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:01:00.0

$ xrandr --setprovideroutputsource 0 1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  35 (RRSetProviderOutputSource)
  Value in failed request:  0x3f
  Serial number of failed request:  16
  Current serial number in output stream:  17

$ xrandr --setprovideroffloadsink 1 0

$ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2)

I am grateful for any help.

Thanks in advance

Last edited by satriani (2018-02-24 06:12:03)

Offline

#2 2018-02-23 10:26:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,101

Re: [SOLVED] PRIME with AMD Radeon 530 - Error of failed request: BadValue

You have to explicitly set the DRI_PRIME env variable.

DRI_PRIME=1 glxinfo | grep OpenGL

As detailed in https://wiki.archlinux.org/index.php/PR … offloading

Offline

#3 2018-02-23 10:44:31

satriani
Member
Registered: 2015-06-26
Posts: 26

Re: [SOLVED] PRIME with AMD Radeon 530 - Error of failed request: BadValue

Ah, that's right smile

$ DRI_PRIME=1 glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: AMD ICELAND (DRM 3.23.0 / 4.15.4-1-ARCH, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.3.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.3.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.3.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

Last edited by satriani (2018-02-24 06:11:19)

Offline

#4 2018-11-12 05:42:15

pandarm
Member
Registered: 2018-07-09
Posts: 11

Re: [SOLVED] PRIME with AMD Radeon 530 - Error of failed request: BadValue

Hello
i have same laptop and same problem

$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x68 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 1 name:Intel
Provider 1: id: 0x3f cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 0 outputs: 0 associated providers: 1 name:Unknown AMD Radeon GPU @ pci:0000:01:00.0
$ xrandr --setprovideroffloadsink 1 0
$ glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa DRI Intel(R) UHD Graphics 620 (Kabylake GT2) 
$ DRI_PRIME=1 glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: AMD ICELAND (DRM 3.26.0, 4.18.16-arch1-1-ARCH, LLVM 7.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.2.4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.4 (Compatibility Profile) Mesa 18.2.4
OpenGL shading language version string: 4.40
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.2.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
$ xrandr --setprovideroutputsource 0 1
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  35 (RRSetProviderOutputSource)
  Value in failed request:  0x3f
  Serial number of failed request:  16
  Current serial number in output stream:  17

i install amd&intel&vesa driver but not active amd gpu
any one can help me ?

Offline

#5 2018-11-12 09:00:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,101

Re: [SOLVED] PRIME with AMD Radeon 530 - Error of failed request: BadValue

As evident you don have a problem and your amdgpu works to the extent allowed by DRI_PRIME=1. If you have an actual issue please clarify on your intents and what you expect to work and doesn't currently in your own thread.

Don't necrobump.

Closing.

Offline

Board footer

Powered by FluxBB