You are not logged in.

#1 2018-02-24 12:20:12

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 99

Read-only filesystem error when using pacstrap during installation

Hello guys!

I am trying to install Arch on my laptop (I already know how, I've done it many times) but I am getting an error when using pacstrap or trying to write to /sys (to change schedulers for example), saying that it is a read-only FS.

Any ideas on what might be happening?


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#2 2018-02-24 13:26:29

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 99

Re: Read-only filesystem error when using pacstrap during installation

A little more info (The importan part is at the end):

==> Creating install root at /mnt
==> Installing packages to /mnt
:: Synchronizing package databases...
downloading core.db...
downloading extra.db...
downloading community.db...
:: There are 50 members in group base:
:: Repository core
   1) bash  2) bzip2  3) coreutils  4) cryptsetup  5) device-mapper  6) dhcpcd  7) diffutils  8) e2fsprogs  9) file  10) filesystem  11) findutils  12) gawk  13) gcc-libs  14) gettext  15) glibc  16) grep  17) gzip  18) inetutils  19) iproute2  20) iputils  21) jfsutils  22) less  23) licenses  24) linux  25) logrotate  26) lvm2  27) man-db  28) man-pages  29) mdadm  30) nano  31) netctl  32) pacman  33) pciutils  34) pcmciautils  35) perl  36) procps-ng  37) psmisc  38) reiserfsprogs  39) s-nail  40) sed  41) shadow  42) sysfsutils  43) systemd-sysvcompat  44) tar  45) texinfo  46) usbutils  47) util-linux  48) vi  49) which  50) xfsprogs

Enter a selection (default=all): 
:: There are 26 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file  7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff  14) gzip  15) libtool  16) m4  17) make  18) pacman  19) patch  20) pkg-config  21) sed  22) sudo  23) systemd  24) texinfo  25) util-linux  26) which

Enter a selection (default=all): 
resolving dependencies...
looking for conflicting packages...

Packages (154) acl-2.2.52-4  archlinux-keyring-20180108-1  argon2-20171227-3  attr-2.4.47-3  ca-certificates-20170307-1  ca-certificates-cacert-20140824-4  ca-certificates-mozilla-3.35-1  ca-certificates-utils-20170307-1  cracklib-2.9.6-1  curl-7.58.0-1  db-5.3.28-3  dbus-1.12.4-1  expat-2.2.5-1  gc-7.6.4-1  gdbm-1.14.1-1  glib2-2.54.3+2+g94b38beff-1  gmp-6.1.2-1  gnupg-2.2.4-2  gnutls-3.5.18-1  gpgme-1.10.0-1  guile-2.2.3-1  hwids-20171003-1  iana-etc-20180131-1  iptables-1.6.2-2  json-c-0.13-1  kbd-2.0.4-1  keyutils-1.5.10-1  kmod-24-1  krb5-1.16-1  libaio-0.3.110-1  libarchive-3.3.2-1  libassuan-2.5.1-1  libatomic_ops-7.6.2-1  libcap-2.25-1  libcap-ng-0.7.8-1  libelf-0.170-1  libffi-3.2.1-2  libgcrypt-1.8.2-1  libgpg-error-1.27-1  libidn-1.33-2  libidn2-2.0.4-2  libksba-1.3.5-1  libldap-2.4.45-4  libmnl-1.0.4-1  libmpc-1.1.0-1  libnftnl-1.0.9-1  libnghttp2-1.30.0-1  libnl-3.4.0-1  libpcap-1.8.1-2  libpipeline-1.5.0-1  libpsl-0.19.1-1  libsasl-2.1.26-12  libseccomp-2.3.2-2  libsecret-0.18.5+14+g9980655-1  libssh2-1.8.0-2  libsystemd-237.64-1  libtasn1-4.13-1  libtirpc-1.0.2-3  libunistring-0.9.8-1  libusb-1.0.21-2  libutil-linux-2.31.1-1  linux-api-headers-4.14.8-1  linux-firmware-20180119.2a713be-1  lz4-1:1.8.1.2-1  lzo-2.10-1  mkinitcpio-24-2  mkinitcpio-busybox-1.27.2-1  mpfr-4.0.1-1  ncurses-6.1-3  nettle-3.4-1  npth-1.5-1  openresolv-3.9.0-1  openssl-1.1.0.g-1  p11-kit-0.23.9-1  pacman-mirrorlist-20180203-1  pam-1.3.0-1  pambase-20171006-1  pcre-8.41-1  pcre2-10.31-1  pinentry-1.1.0-1  popt-1.16-9  readline-7.0.003-1  sqlite-3.22.0-1  thin-provisioning-tools-0.7.5-1  tzdata-2018c-1  xz-5.2.3-1  zlib-1:1.2.11-2  zstd-1.3.3-1  autoconf-2.69-4  automake-1.15.1-1  bash-4.4.019-1  binutils-2.29.1-2  bison-3.0.4-3  btrfs-progs-4.15.1-1  bzip2-1.0.6-7  coreutils-8.29-1  cryptsetup-2.0.1-1  device-mapper-2.02.177-1  dhcpcd-7.0.1-1  diffutils-3.6-1  e2fsprogs-1.43.9-1  fakeroot-1.22-1  file-5.32-1  filesystem-2017.10-2  findutils-4.6.0-2  flex-2.6.4-1  gawk-4.2.0-3  gcc-7.3.0-1  gcc-libs-7.3.0-1  gettext-0.19.8.1-2  glibc-2.26-11  grep-3.1-1  groff-1.22.3-7  gzip-1.9-1  inetutils-1.9.4-5  iproute2-4.15.0-1  iputils-20161105.1f2bb12-2  jfsutils-1.1.15-4  less-530-1  libtool-2.4.6+40+g6ca5e224-4  licenses-20171006-1  linux-4.15.5-1  logrotate-3.13.0-1  lvm2-2.02.177-1  m4-1.4.18-1  make-4.2.1-2  man-db-2.8.1-1  man-pages-4.15-1  mdadm-4.0-1  nano-2.9.3-1  netctl-1.15-1  pacman-5.0.2-2  patch-2.7.6-1  pciutils-3.5.6-1  pcmciautils-018-7  perl-5.26.1-2  pkg-config-0.29.2-1  procps-ng-3.3.12-3  psmisc-23.1-1  reiserfsprogs-3.6.27-1  s-nail-14.9.7-1  sed-4.4-1  shadow-4.5-4  sudo-1.8.22-1  sysfsutils-2.1.0-9  systemd-237.64-1  systemd-sysvcompat-237.64-1  tar-1.30-1  texinfo-6.5-1  usbutils-009-1  util-linux-2.31.1-1  vi-1:070224-2  which-2.21-2  xfsprogs-4.14.0-1

Total Download Size:    283.99 MiB
Total Installed Size:  1029.95 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading linux-api-headers-4.14.8-1-any.pkg.tar.xz...
downloading tzdata-2018c-1-any.pkg.tar.xz...
downloading iana-etc-20180131-1-any.pkg.tar.xz...
downloading filesystem-2017.10-2-x86_64.pkg.tar.xz...
downloading glibc-2.26-11-x86_64.pkg.tar.xz...
downloading gcc-libs-7.3.0-1-x86_64.pkg.tar.xz...
downloading ncurses-6.1-3-x86_64.pkg.tar.xz...
downloading readline-7.0.003-1-x86_64.pkg.tar.xz...
downloading bash-4.4.019-1-x86_64.pkg.tar.xz...
downloading bzip2-1.0.6-7-x86_64.pkg.tar.xz...
downloading attr-2.4.47-3-x86_64.pkg.tar.xz...
downloading acl-2.2.52-4-x86_64.pkg.tar.xz...
downloading gmp-6.1.2-1-x86_64.pkg.tar.xz...
downloading libcap-2.25-1-x86_64.pkg.tar.xz...
downloading gdbm-1.14.1-1-x86_64.pkg.tar.xz...
downloading db-5.3.28-3-x86_64.pkg.tar.xz...
downloading perl-5.26.1-2-x86_64.pkg.tar.xz...
downloading openssl-1.1.0.g-1-x86_64.pkg.tar.xz...
downloading coreutils-8.29-1-x86_64.pkg.tar.xz...
downloading libgpg-error-1.27-1-x86_64.pkg.tar.xz...
downloading libgcrypt-1.8.2-1-x86_64.pkg.tar.xz...
downloading lz4-1:1.8.1.2-1-x86_64.pkg.tar.xz...
downloading xz-5.2.3-1-x86_64.pkg.tar.xz...
downloading libsystemd-237.64-1-x86_64.pkg.tar.xz...
downloading device-mapper-2.02.177-1-x86_64.pkg.tar.xz...
downloading popt-1.16-9-x86_64.pkg.tar.xz...
downloading libutil-linux-2.31.1-1-x86_64.pkg.tar.xz...
downloading json-c-0.13-1-x86_64.pkg.tar.xz...
downloading argon2-20171227-3-x86_64.pkg.tar.xz...
downloading cryptsetup-2.0.1-1-x86_64.pkg.tar.xz...
downloading expat-2.2.5-1-x86_64.pkg.tar.xz...
downloading dbus-1.12.4-1-x86_64.pkg.tar.xz...
downloading libmnl-1.0.4-1-x86_64.pkg.tar.xz...
downloading libnftnl-1.0.9-1-x86_64.pkg.tar.xz...
downloading libnl-3.4.0-1-x86_64.pkg.tar.xz...
downloading libusb-1.0.21-2-x86_64.pkg.tar.xz...
downloading libpcap-1.8.1-2-x86_64.pkg.tar.xz...
downloading iptables-1.6.2-2-x86_64.pkg.tar.xz...
downloading zlib-1:1.2.11-2-x86_64.pkg.tar.xz...
downloading cracklib-2.9.6-1-x86_64.pkg.tar.xz...
downloading e2fsprogs-1.43.9-1-x86_64.pkg.tar.xz...
downloading libsasl-2.1.26-12-x86_64.pkg.tar.xz...
downloading libldap-2.4.45-4-x86_64.pkg.tar.xz...
downloading keyutils-1.5.10-1-x86_64.pkg.tar.xz...
downloading krb5-1.16-1-x86_64.pkg.tar.xz...
downloading libtirpc-1.0.2-3-x86_64.pkg.tar.xz...
downloading pambase-20171006-1-any.pkg.tar.xz...
downloading pam-1.3.0-1-x86_64.pkg.tar.xz...
downloading kbd-2.0.4-1-x86_64.pkg.tar.xz...
downloading kmod-24-1-x86_64.pkg.tar.xz...
downloading hwids-20171003-1-any.pkg.tar.xz...
downloading libidn-1.33-2-x86_64.pkg.tar.xz...
downloading libelf-0.170-1-x86_64.pkg.tar.xz...
downloading libseccomp-2.3.2-2-x86_64.pkg.tar.xz...
downloading shadow-4.5-4-x86_64.pkg.tar.xz...
downloading util-linux-2.31.1-1-x86_64.pkg.tar.xz...
downloading pcre2-10.31-1-x86_64.pkg.tar.xz...
downloading systemd-237.64-1-x86_64.pkg.tar.xz...
downloading dhcpcd-7.0.1-1-x86_64.pkg.tar.xz...
downloading diffutils-3.6-1-x86_64.pkg.tar.xz...
downloading file-5.32-1-x86_64.pkg.tar.xz...
downloading findutils-4.6.0-2-x86_64.pkg.tar.xz...
downloading mpfr-4.0.1-1-x86_64.pkg.tar.xz...
downloading gawk-4.2.0-3-x86_64.pkg.tar.xz...
downloading pcre-8.41-1-x86_64.pkg.tar.xz...
downloading libffi-3.2.1-2-x86_64.pkg.tar.xz...
downloading glib2-2.54.3+2+g94b38beff-1-x86_64.pkg.tar.xz...
downloading libunistring-0.9.8-1-x86_64.pkg.tar.xz...
downloading gettext-0.19.8.1-2-x86_64.pkg.tar.xz...
downloading grep-3.1-1-x86_64.pkg.tar.xz...
downloading less-530-1-x86_64.pkg.tar.xz...
downloading gzip-1.9-1-x86_64.pkg.tar.xz...
downloading inetutils-1.9.4-5-x86_64.pkg.tar.xz...
downloading iproute2-4.15.0-1-x86_64.pkg.tar.xz...
downloading sysfsutils-2.1.0-9-x86_64.pkg.tar.xz...
downloading iputils-20161105.1f2bb12-2-x86_64.pkg.tar.xz...
downloading jfsutils-1.1.15-4-x86_64.pkg.tar.xz...
downloading licenses-20171006-1-any.pkg.tar.xz...
downloading linux-firmware-20180119.2a713be-1-any.pkg.tar.xz...
downloading mkinitcpio-busybox-1.27.2-1-x86_64.pkg.tar.xz...
downloading libarchive-3.3.2-1-x86_64.pkg.tar.xz...
downloading mkinitcpio-24-2-any.pkg.tar.xz...
downloading linux-4.15.5-1-x86_64.pkg.tar.xz...
downloading logrotate-3.13.0-1-x86_64.pkg.tar.xz...
downloading libaio-0.3.110-1-x86_64.pkg.tar.xz...
downloading thin-provisioning-tools-0.7.5-1-x86_64.pkg.tar.xz...
downloading lvm2-2.02.177-1-x86_64.pkg.tar.xz...
downloading groff-1.22.3-7-x86_64.pkg.tar.xz...
downloading libpipeline-1.5.0-1-x86_64.pkg.tar.xz...
downloading man-db-2.8.1-1-x86_64.pkg.tar.xz...
downloading man-pages-4.15-1-any.pkg.tar.xz...
downloading mdadm-4.0-1-x86_64.pkg.tar.xz...
downloading nano-2.9.3-1-x86_64.pkg.tar.xz...
downloading openresolv-3.9.0-1-any.pkg.tar.xz...
downloading netctl-1.15-1-any.pkg.tar.xz...
downloading libtasn1-4.13-1-x86_64.pkg.tar.xz...
downloading p11-kit-0.23.9-1-x86_64.pkg.tar.xz...
downloading ca-certificates-utils-20170307-1-any.pkg.tar.xz...
downloading ca-certificates-mozilla-3.35-1-x86_64.pkg.tar.xz...
downloading ca-certificates-cacert-20140824-4-any.pkg.tar.xz...
downloading ca-certificates-20170307-1-any.pkg.tar.xz...
downloading libssh2-1.8.0-2-x86_64.pkg.tar.xz...
downloading libidn2-2.0.4-2-x86_64.pkg.tar.xz...
downloading libpsl-0.19.1-1-x86_64.pkg.tar.xz...
downloading libnghttp2-1.30.0-1-x86_64.pkg.tar.xz...
downloading curl-7.58.0-1-x86_64.pkg.tar.xz...
downloading npth-1.5-1-x86_64.pkg.tar.xz...
downloading libksba-1.3.5-1-x86_64.pkg.tar.xz...
downloading libassuan-2.5.1-1-x86_64.pkg.tar.xz...
downloading libsecret-0.18.5+14+g9980655-1-x86_64.pkg.tar.xz...
downloading pinentry-1.1.0-1-x86_64.pkg.tar.xz...
downloading nettle-3.4-1-x86_64.pkg.tar.xz...
downloading gnutls-3.5.18-1-x86_64.pkg.tar.xz...
downloading sqlite-3.22.0-1-x86_64.pkg.tar.xz...
downloading gnupg-2.2.4-2-x86_64.pkg.tar.xz...
downloading gpgme-1.10.0-1-x86_64.pkg.tar.xz...
downloading pacman-mirrorlist-20180203-1-any.pkg.tar.xz...
downloading archlinux-keyring-20180108-1-any.pkg.tar.xz...
downloading pacman-5.0.2-2-x86_64.pkg.tar.xz...
downloading pciutils-3.5.6-1-x86_64.pkg.tar.xz...
downloading pcmciautils-018-7-x86_64.pkg.tar.xz...
downloading procps-ng-3.3.12-3-x86_64.pkg.tar.xz...
downloading psmisc-23.1-1-x86_64.pkg.tar.xz...
downloading reiserfsprogs-3.6.27-1-x86_64.pkg.tar.xz...
downloading s-nail-14.9.7-1-x86_64.pkg.tar.xz...
downloading sed-4.4-1-x86_64.pkg.tar.xz...
downloading systemd-sysvcompat-237.64-1-x86_64.pkg.tar.xz...
downloading tar-1.30-1-x86_64.pkg.tar.xz...
downloading texinfo-6.5-1-x86_64.pkg.tar.xz...
downloading usbutils-009-1-x86_64.pkg.tar.xz...
downloading vi-1:070224-2-x86_64.pkg.tar.xz...
downloading which-2.21-2-x86_64.pkg.tar.xz...
downloading xfsprogs-4.14.0-1-x86_64.pkg.tar.xz...
downloading m4-1.4.18-1-x86_64.pkg.tar.xz...
downloading autoconf-2.69-4-any.pkg.tar.xz...
downloading automake-1.15.1-1-any.pkg.tar.xz...
downloading binutils-2.29.1-2-x86_64.pkg.tar.xz...
downloading bison-3.0.4-3-x86_64.pkg.tar.xz...
downloading fakeroot-1.22-1-x86_64.pkg.tar.xz...
downloading flex-2.6.4-1-x86_64.pkg.tar.xz...
downloading libmpc-1.1.0-1-x86_64.pkg.tar.xz...
downloading gcc-7.3.0-1-x86_64.pkg.tar.xz...
downloading libtool-2.4.6+40+g6ca5e224-4-x86_64.pkg.tar.xz...
downloading make-4.2.1-2-x86_64.pkg.tar.xz...
downloading patch-2.7.6-1-x86_64.pkg.tar.xz...
downloading pkg-config-0.29.2-1-x86_64.pkg.tar.xz...
downloading sudo-1.8.22-1-x86_64.pkg.tar.xz...
downloading lzo-2.10-1-x86_64.pkg.tar.xz...
downloading zstd-1.3.3-1-x86_64.pkg.tar.xz...
downloading btrfs-progs-4.15.1-1-x86_64.pkg.tar.xz...
downloading libcap-ng-0.7.8-1-x86_64.pkg.tar.xz...
downloading libatomic_ops-7.6.2-1-x86_64.pkg.tar.xz...
downloading gc-7.6.4-1-x86_64.pkg.tar.xz...
downloading guile-2.2.3-1-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing linux-api-headers...
installing tzdata...
installing iana-etc...
installing filesystem...
installing glibc...
Optional dependencies for glibc
    gd: for memusagestat
installing gcc-libs...
installing ncurses...
installing readline...
installing bash...
Optional dependencies for bash
    bash-completion: for tab completion
installing bzip2...
installing attr...
installing acl...
installing gmp...
installing libcap...
installing gdbm...
installing db...
installing perl...
installing openssl...
Optional dependencies for openssl
    ca-certificates [pending]
installing coreutils...
installing libgpg-error...
installing libgcrypt...
installing lz4...
installing xz...
installing libsystemd...
installing device-mapper...
installing popt...
installing libutil-linux...
installing json-c...
installing argon2...
installing cryptsetup...
installing expat...
installing dbus...
installing libmnl...
installing libnftnl...
installing libnl...
installing libusb...
installing libpcap...
installing iptables...
installing zlib...
installing cracklib...
installing e2fsprogs...
installing libsasl...
installing libldap...
installing keyutils...
installing krb5...
installing libtirpc...
installing pambase...
installing pam...
installing kbd...
installing kmod...
installing hwids...
installing libidn...
installing libelf...
installing libseccomp...
installing shadow...
installing libcap-ng...
installing util-linux...
Optional dependencies for util-linux
    python: python bindings to libmount
installing pcre2...
installing systemd...
Initializing machine ID from random generator.
Created symlink /etc/systemd/system/getty.target.wants/getty@tty1.service → /usr/lib/systemd/system/getty@.service.
Created symlink /etc/systemd/system/multi-user.target.wants/remote-fs.target → /usr/lib/systemd/system/remote-fs.target.
:: Append 'init=/usr/lib/systemd/systemd' to your kernel command line in your
   bootloader to replace sysvinit with systemd, or install systemd-sysvcompat
Optional dependencies for systemd
    libmicrohttpd: remote journald capabilities
    quota-tools: kernel-level quota management
    systemd-sysvcompat: symlink package to provide sysvinit binaries [pending]
    polkit: allow administration as unprivileged user
installing dhcpcd...
Optional dependencies for dhcpcd
    openresolv: resolvconf support [pending]
installing diffutils...
installing file...
installing findutils...
installing mpfr...
installing gawk...
installing pcre...
installing libffi...
installing glib2...
Optional dependencies for glib2
    python: for gdbus-codegen and gtester-report
    libelf: gresource inspection tool [installed]
installing libunistring...
installing gettext...
Optional dependencies for gettext
    git: for autopoint infrastructure updates
installing grep...
installing less...
installing gzip...
installing inetutils...
installing iproute2...
Optional dependencies for iproute2
    linux-atm: ATM support
installing sysfsutils...
installing iputils...
Optional dependencies for iputils
    xinetd: for tftpd
installing jfsutils...
installing licenses...
installing linux-firmware...
installing mkinitcpio-busybox...
installing libarchive...
installing mkinitcpio...
Optional dependencies for mkinitcpio
    xz: Use lzma or xz compression for the initramfs image [installed]
    bzip2: Use bzip2 compression for the initramfs image [installed]
    lzop: Use lzo compression for the initramfs image
    lz4: Use lz4 compression for the initramfs image [installed]
    mkinitcpio-nfs-utils: Support for root filesystem on NFS
installing linux...
Optional dependencies for linux
    crda: to set the correct wireless channels of your country
installing logrotate...
installing libaio...
installing thin-provisioning-tools...
installing lvm2...
installing groff...
Optional dependencies for groff
    netpbm: for use together with man -H command interaction in browsers
    psutils: for use together with man -H command interaction in browsers
    libxaw: for gxditview
installing libpipeline...
installing man-db...
Optional dependencies for man-db
    gzip [installed]
installing man-pages...
installing mdadm...
installing nano...
installing openresolv...
installing netctl...
Optional dependencies for netctl
    dialog: for the menu based wifi assistant
    dhclient: for DHCP support (or dhcpcd)
    dhcpcd: for DHCP support (or dhclient) [installed]
    wpa_supplicant: for wireless networking support
    ifplugd: for automatic wired connections through netctl-ifplugd
    wpa_actiond: for automatic wireless connections through netctl-auto
    ppp: for PPP connections
    openvswitch: for Open vSwitch connections
installing libtasn1...
installing p11-kit...
installing ca-certificates-utils...
installing ca-certificates-mozilla...
installing ca-certificates-cacert...
installing ca-certificates...
installing libssh2...
installing libidn2...
installing libpsl...
installing libnghttp2...
installing curl...
installing npth...
installing libksba...
installing libassuan...
installing libsecret...
Optional dependencies for libsecret
    gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
installing pinentry...
Optional dependencies for pinentry
    gtk2: gtk2 backend
    qt5-base: qt backend
    gcr: gnome3 backend
installing nettle...
installing gnutls...
Optional dependencies for gnutls
    guile: for use with Guile bindings [pending]
installing sqlite...
installing gnupg...
Optional dependencies for gnupg
    libldap: gpg2keys_ldap [installed]
    libusb-compat: scdaemon
    pcsclite: scdaemon
installing gpgme...
installing pacman-mirrorlist...
installing archlinux-keyring...
installing pacman...
installing pciutils...
installing pcmciautils...
installing procps-ng...
installing psmisc...
installing reiserfsprogs...
installing s-nail...
Optional dependencies for s-nail
    smtp-forwarder: for sending mail
installing sed...
installing systemd-sysvcompat...
installing tar...
installing texinfo...
installing usbutils...
Optional dependencies for usbutils
    python2: for lsusb.py usage
    coreutils: for lsusb.py usage [installed]
installing vi...
Optional dependencies for vi
    s-nail: used by the preserve command for notification [installed]
installing which...
installing xfsprogs...
installing m4...
installing autoconf...
installing automake...
installing binutils...
installing bison...
installing fakeroot...
installing flex...
installing libmpc...
installing gcc...
Optional dependencies for gcc
    lib32-gcc-libs: for generating code for 32-bit ABI
installing libtool...
installing libatomic_ops...
installing gc...
installing guile...
installing make...
installing patch...
Optional dependencies for patch
    ed: for patch -e functionality
installing pkg-config...
installing sudo...
installing lzo...
installing zstd...
installing btrfs-progs...
:: Running post-transaction hooks...
(1/9) Updating linux module dependencies...
(2/9) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.15.5-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.15.5-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
(3/9) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
(4/9) Updating udev hardware database...
(5/9) Updating system user accounts...
(6/9) Creating temporary files...
[      456.11231823788] systemd-tmpfiles[4091]: Failed to create file /sys/devices/system/cpu/microcode/reload: Read-only file system
(7/9) Arming ConditionNeedsUpdate...
(8/9) Updating the info directory file...
(9/9) Rebuilding certificate stores...

Thanks!


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#3 2018-02-24 14:51:48

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 99

Re: Read-only filesystem error when using pacstrap during installation

Another good example (ran from Xterm in an Xsession, the same happens in standalone terminal):

[carter@ArchHP ~]$ sudo echo deadline > /sys/block/sda/queue/scheduler 
bash: /sys/block/sda/queue/scheduler: Permission denied

"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#4 2018-02-24 15:04:35

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,651

Re: Read-only filesystem error when using pacstrap during installation

Welcome to the forums CarterCox smile
In the future you can edit your previous post if no-one else has posted since.

Do you actually have a problem? I believe that you can safely ignore the error in your pacstrap output, as the correct file will be created when you reboot.

As for your second issue, that is completely separate and for a different reason entirely (note it says permission denied, not read-only filesystem). The elevated permissions given by sudo don't carry over to the other side of the redirect, and your user doesn't have permissions to write to the file. The correct method would be...

echo deadline | sudo tee -a /sys/block/sda/queue/scheduler

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#5 2018-02-24 15:07:50

ugjka
Member
From: Latvia
Registered: 2014-04-01
Posts: 1,069

Re: Read-only filesystem error when using pacstrap during installation

CarterCox wrote:

Another good example (ran from Xterm in an Xsession, the same happens in standalone terminal):

[carter@ArchHP ~]$ sudo echo deadline > /sys/block/sda/queue/scheduler 
bash: /sys/block/sda/queue/scheduler: Permission denied

https://stackoverflow.com/questions/822 … sion-to-wr


Github | Soundcloud

"Once you hit 10 nested VMs you're basically brad pitt with women who matter" ~ echoline

Offline

#6 2018-02-24 22:00:01

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 99

Re: Read-only filesystem error when using pacstrap during installation

I swear I used tee, and I still got the same, that's why I thought it was a read-only FS. I used "sudo su" and then echoed. Thanks!!!

About the other issue, I though they were both the same, so I figured, I solve one, then solve the other. The system works fine with or without the error there, so it wasn't really the problem, so I guess it's solved. Thanks again Slithery!


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#7 2018-02-24 22:32:19

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,307
Website

Re: Read-only filesystem error when using pacstrap during installation

Slithery, for the correct method I suspect you intended a pipe not a redirection:

echo deadline | sudo tee ...

Either that or you are using a very very old shell where that was the syntax for piping.

Last edited by Trilby (2018-02-24 22:32:51)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#8 2018-02-25 00:55:18

CarterCox
Member
From: US
Registered: 2018-02-24
Posts: 99

Re: Read-only filesystem error when using pacstrap during installation

Trilby wrote:

Slithery, for the correct method I suspect you intended a pipe not a redirection:

echo deadline | sudo tee ...

Either that or you are using a very very old shell where that was the syntax for piping.

Heh, I missed it. Yeah I got it anyways. I had seen it in another forum but for some reason didn't work. Maybe I did it wrong.

I should mark the thread as solved.


"S’matter Buddy? You look a little – what’s the word I’m looking for here – Stupid."

Offline

#9 2018-02-25 01:34:04

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,651

Re: Read-only filesystem error when using pacstrap during installation

Good spot. Have edited my original post smile


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB