You are not logged in.

#1 2018-02-26 19:43:12

W_KIWAN
Member
Registered: 2018-02-23
Posts: 20

wifi enable/disable button

hello ,
wifi enable/disable button doesnt work after log in it works just before log in to arch or when log out, how to solve that issue?
hp elitebook 755 g3
arch 4.15.5-1 (gnome DE)
thanks in advance

Offline

#2 2018-02-26 20:42:11

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,117

Re: wifi enable/disable button

First, please fix your shift key.

What is the output of rfkill   ?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2018-02-26 20:50:56

W_KIWAN
Member
Registered: 2018-02-23
Posts: 20

Re: wifi enable/disable button

ewaller wrote:

First, please fix your shift key.

What is the output of rfkill   ?

thanks for ur response the output is:

 $rfkill 
ID TYPE      DEVICE      SOFT      HARD
 0 wlan      phy0   unblocked unblocked
 1 bluetooth hci0   unblocked unblocked 

Last edited by W_KIWAN (2018-02-26 20:54:32)

Offline

#4 2018-02-26 20:56:19

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,117

Re: wifi enable/disable button

It appears that there are no hard or soft blocks on your wireless, so if things are not working, the wifi enable is not the issue.  If you activate the switch, does the output of the rfkill command change?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#5 2018-02-26 20:58:20

W_KIWAN
Member
Registered: 2018-02-23
Posts: 20

Re: wifi enable/disable button

ewaller wrote:

It appears that there are no hard or soft blocks on your wireless, so if things are not working, the wifi enable is not the issue.  If you activate the switch, does the output of the rfkill command change?

no i am getting the same output
well i am wondering why the key works fine before loging in !! strange isnt ?

Last edited by W_KIWAN (2018-02-26 21:00:08)

Offline

#6 2018-02-26 21:16:48

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,117

Re: wifi enable/disable button

Let us back up a few steps.

What do you mean by "wifi enable/disable button doesnt work" ?
How do you know it is not working ?

By the way, I agree that it may not be working if rfkill does not see a change.  But, what led you to say that it is not working?  Are you trying to disable wifi?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2018-02-26 21:22:19

W_KIWAN
Member
Registered: 2018-02-23
Posts: 20

Re: wifi enable/disable button

ewaller wrote:

Let us back up a few steps.

What do you mean by "wifi enable/disable button doesnt work" ?
How do you know it is not working ?

By the way, I agree that it may not be working if rfkill does not see a change.  But, what led you to say that it is not working?  Are you trying to disable wifi?

a button in my machine to disable or enable wifi adapter in many linux disto that button change diable the wifi and change the device to airplane mode in arch is working fine before login (GDM)  after login seems is not working for some resone

Offline

#8 2018-02-26 21:29:52

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,117

Re: wifi enable/disable button

So, you are trying to turn off wireless, and it is not working.

What desktop environment are you using? I see you are using Gnome.  I doubt the problem is GDM itself; you can verify that by disabling GDM and starting you desktop environment with xinit or startx.

If you change to a different console (Ctrl-Alt-F2) and log in, does the 'button' then change the state of rfkill?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#9 2018-02-26 21:42:50

W_KIWAN
Member
Registered: 2018-02-23
Posts: 20

Re: wifi enable/disable button

ewaller wrote:

So, you are trying to turn off wireless, and it is not working.

What desktop environment are you using? I see you are using Gnome.  I doubt the problem is GDM itself; you can verify that by disabling GDM and starting you desktop environment with xinit or startx.

If you change to a different console (Ctrl-Alt-F2) and log in, does the 'button' then change the state of rfkill?

yes you are right its GDM problem its working in startx session.
thank you I appreciate your effort.

Last edited by W_KIWAN (2018-02-26 22:09:33)

Offline

#10 2018-02-26 22:02:10

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 19,953
Website

Re: wifi enable/disable button

I think ewaller is a bit too polite to raise the issue again, but his comment on the shift key was related to this:

code of conduct wrote:

A sincere effort to use modest and proper language and grammar is a sign of respect toward the community that will certainly be appreciated and is quite likely to elicit positive responses. Please refrain from using so-called "textspeak", "netspeak", "leetspeak" and all other forms of internet slang.

Please make an effort.  It will pay off.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

Board footer

Powered by FluxBB