You are not logged in.

#1 2018-03-03 10:49:22

datxinitric
Member
Registered: 2017-04-18
Posts: 26

kvm problem

I was following the instructions on kvm on archwiki but I think I wrote the command that should be written on the virtual machine on my host computer and my host computer thinks it is a virtual machine. Now it gives kernel panic. How do remove kvm? I booted with arch iso and mounted everything. What should I do in chroot?


why use vim when there is vis?

Offline

#2 2018-03-03 12:42:04

loqs
Member
Registered: 2014-03-06
Posts: 6,372

Re: kvm problem

datxinitric wrote:

I was following the instructions on kvm on archwiki but I think I wrote the command that should be written on the virtual machine on my host computer and my host computer thinks it is a virtual machine.

What command was that?

datxinitric wrote:

Now it gives kernel panic.

What is the output of the panic?

Offline

#3 2018-03-03 13:15:11

lo1
Member
Registered: 2017-09-25
Posts: 584

Re: kvm problem

@loqs, probably the OP appended '-device x-iommu' and/or simili to their cmd line.

@datxinitric, be more specific when you ask for support in the forums and post exactly what you did wrapped in code tags.

Offline

#4 2018-03-03 13:56:24

datxinitric
Member
Registered: 2017-04-18
Posts: 26

Re: kvm problem

I did write:

echo 550 > /proc/sys/vm/nr_hugepages
qemu-system-x86_64 -enable-kvm -m 1024 -mem-path /dev/hugepages -hda <disk_image> [...] 

and added

vm.nr_hugepages = 550

to my /etc/sysctl.d/40-hugepage.conf file
It says

No init Found

in the kernel panic

Last edited by datxinitric (2018-03-03 14:02:30)


why use vim when there is vis?

Offline

#5 2018-03-03 14:01:42

loqs
Member
Registered: 2014-03-06
Posts: 6,372

Re: kvm problem

You can disable /etc/sysctl.d/40-hugepage.conf by deleting it or changing the extension from .conf.

Offline

#6 2018-03-03 14:04:07

datxinitric
Member
Registered: 2017-04-18
Posts: 26

Re: kvm problem

loqs wrote:

You can disable /etc/sysctl.d/40-hugepage.conf by deleting it or changing the extension from .conf.

there is no files in /etc/sysctl.d/


why use vim when there is vis?

Offline

#7 2018-03-03 14:17:12

lo1
Member
Registered: 2017-09-25
Posts: 584

Re: kvm problem

Hugepages are ok, seems to me that you may have damaged something else.

datxinitrc wrote:

and added

vm.nr_hugepages = 550
to my /etc/sysctl.d/40-hugepage.conf file

....

there is no files in /etc/sysctl.d/

What's in your /etc/fstab?

Offline

#8 2018-03-03 14:22:38

datxinitric
Member
Registered: 2017-04-18
Posts: 26

Re: kvm problem

lo1 wrote:

Hugepages are ok, seems to me that you may have damaged something else.

datxinitrc wrote:

and added

vm.nr_hugepages = 550
to my /etc/sysctl.d/40-hugepage.conf file

....

there is no files in /etc/sysctl.d/

What's in your /etc/fstab?

Swap and root is mounted nothing else


why use vim when there is vis?

Offline

#9 2018-03-03 14:33:10

lo1
Member
Registered: 2017-09-25
Posts: 584

Re: kvm problem

My previous post contains an implied question: where the hell did your 40-hugepages.conf go?

Also, what else did you do before editing it? I suspect this will be fixed only by looking at ~/.bash_history...

Offline

Board footer

Powered by FluxBB