You are not logged in.

#1 2018-03-04 18:50:47

kendew
Member
Registered: 2016-11-09
Posts: 9

[SOLVED] Speakers output buzzing sound since 4.15

I could really use some guidance on an issue I've been having with sound on booting Arch.  This problem only emerged after the kernel upgraded to 4.15.  Before that, for the last two years I've been using this NUC6CAYH this problem never occurred, so I think this is a kernel related issue.
Basically, about halfway through the booting process before the login screen appears the speakers come on and produce a loud and annoying buzzing noise.  This noise continues even after logging in.  Starting pavucontrol stops it and restores silence.  At the moment my workaround has been to autostart pavucontrol but I'd prefer to get to the source of this problem and eliminate it. 
Any help will be much appreciated.
Kendew

Last edited by kendew (2018-05-12 20:34:07)

Offline

#2 2018-05-12 06:54:44

nahant
Member
Registered: 2011-12-26
Posts: 3

Re: [SOLVED] Speakers output buzzing sound since 4.15

I have exactly the same issue since 4.15 and unsuccessfully tested yesterday with 4.16.8.

In my case pavucontrol makes the problem disappear only temporary (and so does the KDE settings application). After a minute or so the buzzing sound returns. Seems to be some periodic background task that triggers it again.

Currently I use linux-lts which is 4.14.x at the moment to avoid the issue. However this problem will become a showstopper once linux-lts is updated to something >= 4.15.

Offline

#3 2018-05-12 09:12:14

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 4,686

Re: [SOLVED] Speakers output buzzing sound since 4.15

Online

#4 2018-05-12 19:24:10

nahant
Member
Registered: 2011-12-26
Posts: 3

Re: [SOLVED] Speakers output buzzing sound since 4.15

@V1del: Thanks a lot! Your tip fixed the buzzing noise.

Offline

#5 2018-05-12 20:33:04

kendew
Member
Registered: 2016-11-09
Posts: 9

Re: [SOLVED] Speakers output buzzing sound since 4.15

Finally since I started this post in March I have been able to fix the problem, or at least so far so good.  Good riddance to it.
In my case I only needed to add
options snd_hda_intel power_save=0
to /etc/modprobe.d/modprobe.conf
Thanks for help in solving this problem.
Since nahant also reports problem solved I'll mark this post solved.
Kendew

Last edited by kendew (2018-05-12 20:35:16)

Offline

Board footer

Powered by FluxBB