You are not logged in.

#1 2018-03-09 19:33:20

jukki
Member
Registered: 2018-03-09
Posts: 19

[solved] Can't enable A2DP in certain bluetooth devices

Hi,

New to arch but loving it already!

I made a fresh install few days ago, and I'm having problems with certain bluetooth sound devices. I have few bluetooth headphones and few bluetooth speakers, some of them work, some not. Situation was the same with Fedora I used previously.

I have Ausdom M05 -headphones, which work perfectly (they did work also in Fedora). A2DP can be enabled and it works ok.

Here's pulseaudio output when those Ausdom headphones are connected:

  * index: 2
	name: <bluez_sink.E8_07_BF_03_18_98.a2dp_sink>
	driver: <module-bluez5-device.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: 
	priority: 9050
	volume: front-left: 22284 /  34% / -28.11 dB,   front-right: 22284 /  34% / -28.11 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 47.16 ms
	max request: 3 KiB
	max rewind: 0 KiB
	monitor source: 3
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	fixed latency: 45.32 ms
	card: 1 <bluez_card.E8_07_BF_03_18_98>
	module: 23
	properties:
		bluetooth.protocol = "a2dp_sink"
		device.description = "Ausdom M05"
		device.string = "E8:07:BF:03:18:98"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_E8_07_BF_03_18_98"
		bluez.class = "0x240404"
		bluez.alias = "Ausdom M05"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
	ports:
		headset-output: Headset (priority 0, latency offset 0 usec, available: yes)
			properties:
				
	active port: <headset-output>

I have also Panasonic's RT-HTX80B -headphones (great for the price, btw.), but here I can't enable the A2DP from gnome's menus or via pavucontrol. In Fedora I could enable the A2DP, but that wasn't usable as the sound skipped continuously. Here's pulseaudios output on those headphones:

  * index: 3
	name: <bluez_sink.D8_AF_F1_A9_00_DE.headset_head_unit>
	driver: <module-bluez5-device.c>
	flags: HARDWARE HW_VOLUME_CTRL LATENCY 
	state: SUSPENDED
	suspend cause: IDLE 
	priority: 9050
	volume: mono: 19660 /  30%
	        balance 0.00
	base volume: 65536 / 100%
	volume steps: 16
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 4
	sample spec: s16le 1ch 8000Hz
	channel map: mono
	             Mono
	used by: 0
	linked by: 0
	fixed latency: 128.00 ms
	card: 3 <bluez_card.D8_AF_F1_A9_00_DE>
	module: 26
	properties:
		bluetooth.protocol = "headset_head_unit"
		device.intended_roles = "phone"
		device.description = "RP-HTX80B"
		device.string = "D8:AF:F1:A9:00:DE"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_D8_AF_F1_A9_00_DE"
		bluez.class = "0x240404"
		bluez.alias = "RP-HTX80B"
		device.icon_name = "audio-headset-bluetooth"
	ports:
		headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
	active port: <headset-output>
 

I have built-in intel bluetooth adapter, but I have tried also with separate USB-dongle, without success.

I'm starting to think that the problem is not in pulseaudio, but in somewhere else. Do you have any advice?

Last edited by jukki (2018-03-12 18:56:31)

Offline

#2 2018-03-10 06:52:00

jukki
Member
Registered: 2018-03-09
Posts: 19

Re: [solved] Can't enable A2DP in certain bluetooth devices

Updates:

Tried with JBL Charge 2+: A2DP works, but sound is skipping all the time, not usable at all. Output:

-- Logs begin at Thu 2018-03-08 22:42:21 EET, end at Sat 2018-03-10 08:45:48 EET. --
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 58107 us (= 10248 bytes) in audio stre>
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 65093 us (= 11480 bytes) in audio stre>
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 65715 us (= 11592 bytes) in audio stre>
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 117423 us (= 20712 bytes) in audio str>
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 66082 us (= 11656 bytes) in audio stre>
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 57775 us (= 10188 bytes) in audio stre>
Mar 10 08:45:36 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 36409 us (= 6420 bytes) in audio stream
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 34851 us (= 6144 bytes) in audio stream
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 73325 us (= 12932 bytes) in audio stre>
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 73087 us (= 12892 bytes) in audio stre>
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 80702 us (= 14232 bytes) in audio stre>
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 73465 us (= 12956 bytes) in audio stre>
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 35090 us (= 6188 bytes) in audio stream
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 58098 us (= 10248 bytes) in audio stre>
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 51066 us (= 9008 bytes) in audio stream
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 50100 us (= 8836 bytes) in audio stream
Mar 10 08:45:37 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 81089 us (= 14304 bytes) in audio stre>
Mar 10 08:45:38 localhost pulseaudio[13035]: W: [bluetooth] module-bluez5-device.c: Skipping 58058 us (= 10240 bytes) in audio stre>
Mar 10 08:45:40 localhost kernel: Bluetooth: hci0: last event is not cmd complete (0x0f)
Mar 10 08:45:48 localhost bluetoothd[442]: Suspend: Connection timed out (110)

Bose Soundlink Color: Bluetooth pairing is successful, but the speakers does not appear in the sound settings.

Offline

#3 2018-03-10 08:06:29

igor1982
Member
Registered: 2010-05-12
Posts: 18

Re: [solved] Can't enable A2DP in certain bluetooth devices

I confirm the same problem that BOSE SoundLink Mini can be paired successfully, but the speaker does not appear in the sound settings.

Offline

#4 2018-03-12 18:55:44

jukki
Member
Registered: 2018-03-09
Posts: 19

Re: [solved] Can't enable A2DP in certain bluetooth devices

My problems are mostly considered [solved]. Solution:

1) A2DP sink unavailable: GDM was blocking bluetooth access to sound device. Was completely solved with this:
https://www.debuntu.org/how-to-disable- … nd-in-gdm/

2) Continues stuttering/skipping of the sound: This was due to my bluetooth mouse using the same bluetooth controller as headphones. Using wired USB mouse is now my workaround, now I'd need to search instructions configuring the system so that mouse/keyboard use internal intel bluetooth and pulseaudio uses the dongle.

Offline

#5 2018-03-12 19:23:56

jukki
Member
Registered: 2018-03-09
Posts: 19

Re: [solved] Can't enable A2DP in certain bluetooth devices

And final update: This was easy to do using bluetoothctl as instructed here: https://wiki.archlinux.org/index.php/bluetooth

Happy arching from now on!

Offline

Board footer

Powered by FluxBB