You are not logged in.

#1 2018-03-10 11:33:37

darthrob
Member
Registered: 2018-03-10
Posts: 3

[Solved] Unable to launch VLC since upgrading to 3.0.1 from 2.X

Hi,

Been eagerly waiting for the update for VLC 3 to hit stable. Unfortunately, since the upgrade, I find it won't start.

Launching it from the command line gives the following error:

VLC media player 3.0.1 Vetinari (revision 3.0.1-0-gec0f700fcc)                  
[0000561dee27e330] main libvlc: Running vlc with the default interface. Use 'cvl
c' to use vlc without interface.                                                
The X11 connection broke: Maximum allowed requested length exceeded (code 4)    
XIO:  fatal IO error 22 (Invalid argument) on X server ":0"
      after 450 requests (450 known processed) with 0 events remaining.
QMutex: destroying locked mutex

I've checked and the following dependencies are installed:

Depends On      : a52dec  libdvbpsi  libxpm  libdca  libproxy  libtiger  lua    
                  libmatroska  taglib  libmpcdec  ffmpeg  faad2  libupnp
                  libmad  libmpeg2  xcb-util-keysyms  libtar  libxinerama
                  libsecret  libarchive  qt5-base  qt5-x11extras  qt5-svg
                  freetype2  fribidi  harfbuzz  fontconfig  libxml2  gnutls
                  libplacebo  wayland-protocols

I'm running Wayland, but under X11 it won't launch either.

I can't seem to find any reference to anyone having the same issues, which would suggest it's an issue with my set up rather than a bug. Would appreciate if anyone's come across this kind of issue before, how they resolved it.

Cheers

Last edited by darthrob (2018-03-11 00:08:43)

Offline

#2 2018-03-10 15:06:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,003

Re: [Solved] Unable to launch VLC since upgrading to 3.0.1 from 2.X

A few googlers mention that this might happen due to invalid icons or similar. What's your qt5 theme/icon set ?

Offline

#3 2018-03-11 00:08:20

darthrob
Member
Registered: 2018-03-10
Posts: 3

Re: [Solved] Unable to launch VLC since upgrading to 3.0.1 from 2.X

Looks like it was my icon set, Flat Remix. That's a pity, I rather liked that set. There are a few others that seem to have the same issue. I'll switch back to Adwaita, for now, to be safe.

Cheers.

Offline

#4 2018-03-11 17:59:28

darthrob
Member
Registered: 2018-03-10
Posts: 3

Re: [Solved] Unable to launch VLC since upgrading to 3.0.1 from 2.X

For anyone else with the same issue. It is possible to lock the icon set to Adwaita for QT5 applications only.

I simply installed qt5ct from the Arch repos

Set the following setting in /etc/profile.d/qt5ct.sh

export QT_QPA_PLATFORMTHEME="qt5ct"

Set the executable flag on the file. Logged out and logged back in.

Then from qt5ct, I set the icon set to Adwaita and was able to set Flat Remix back up in Gnome Tweak Tool. Now I have my preferred icon theme back, and more finely tuned QT5 applications.

Cheers

Offline

#5 2018-06-13 08:06:15

dmitryrck
Member
Registered: 2018-06-13
Posts: 1

Re: [Solved] Unable to launch VLC since upgrading to 3.0.1 from 2.X

I have the same issue, but I solved it in another way. I found out that the variable QT_SCALE_FACTOR is the root of this problem.

If I try to run VLC using it:

$ env QT_SCALE_FACTOR=2 vlc
VLC media player 3.0.2 Vetinari (revision 3.0.2-0-gd7b653cf14)
[00005611a3088570] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Qt: Session management error: Could not open network socket
The X11 connection broke: Maximum allowed requested length exceeded (code 4)
XIO:  fatal IO error 2 (No such file or directory) on X server ":0"
      after 449 requests (449 known processed) with 0 events remaining.
QMutex: destroying locked mutex
$

It does not work.

But, if I unset it:

$ env -u QT_SCALE_FACTOR vlc  
VLC media player 3.0.2 Vetinari (revision 3.0.2-0-gd7b653cf14)
[000055d186592570] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Qt: Session management error: Could not open network socket
[000055d1865960e0] main playlist: playlist is empty
xkbcommon: ERROR: Key "<CAPS>" added to modifier map for multiple modifiers; Using Control, ignoring Lock
QObject::~QObject: Timers cannot be stopped from another thread
$

VLC runs fine (and it is good looking, no small or big fonts : )

My recommendation (if this unset solves for you too) is to copy the desktop file:

cp /usr/share/applications/vlc.desktop ~/.local/share/applications

And edit the Exec= line following the wiki: https://wiki.archlinux.org/index.php/De … _variables

If you open it using terminal you can set an alias, also in the wiki: https://wiki.archlinux.org/index.php/Bash#Aliases

Before reploying I updated my machine, but it happens with version 3.0.2 and 3.0.3.

My machine is an updated Arch linux running in a macbook pro early 2015 (I set QT_SCALE_FACTOR because of the HiDPI).

P. S.: I have not tried the other solution.

Last edited by dmitryrck (2018-06-13 08:14:42)

Offline

Board footer

Powered by FluxBB