You are not logged in.

#1 2018-03-25 15:44:05

COVERek
Member
From: Lodz
Registered: 2015-06-23
Posts: 4
Website

Gnome 3.28 - Settings not working

Hi,
I have problem with enter to the gmone settings... it's not working... hmm

$ gnome-control-center -v
Failed to register: Ttimeout was reached

What is it?   O_o

Offline

#2 2018-03-25 18:18:52

-MacNuke-
Member
Registered: 2013-01-29
Posts: 21

Re: Gnome 3.28 - Settings not working

I have the same problem. I could open it at least once since I changed my background image after update to 3.28. But now even after reboot nothing gnome-control-center based things are working.

Offline

#3 2018-03-25 20:56:04

blispx
Member
Registered: 2017-11-29
Posts: 25

Re: Gnome 3.28 - Settings not working

For me too, on another computer with fresh arch the same, grrrr hmm

Offline

#4 2018-03-25 22:14:03

manchoz
Member
From: Turin, Italy
Registered: 2015-09-27
Posts: 2
Website

Re: Gnome 3.28 - Settings not working

Same here.


– Code is in the eye of the beholder –

Offline

#5 2018-03-26 03:44:07

ooo
Member
Registered: 2013-04-10
Posts: 1,607

Re: Gnome 3.28 - Settings not working

Offline

#6 2018-03-26 07:20:41

-MacNuke-
Member
Registered: 2013-01-29
Posts: 21

Re: Gnome 3.28 - Settings not working

Got it working... maybe it is a workaround? I started my system. I checked for a running gnome-control-center process... could not find anything. I tried to open the control center... it did not start. I checked again, now a "gnome-control-center --overview" process runs:

myuser 2944  0.3  0.5 101734732 85788 tty2  Sl+  09:11   0:00 gnome-control-center --overview

I tried to start the control center again... still the timeout. I executed "kill 2944". I tried to open up the gnome-control-center again -> it worked.

It showed me the User Management Page.

Offline

#7 2018-03-26 17:08:42

berrykerry789
Member
Registered: 2014-08-02
Posts: 11

Re: Gnome 3.28 - Settings not working

So I fixed mine by swiching from xorg to wayland... and the settings opened.  I then swiched back and it's also working in xorg.

Offline

#8 2018-03-26 17:26:32

blispx
Member
Registered: 2017-11-29
Posts: 25

Re: Gnome 3.28 - Settings not working

That's right because the problem lies between Vala/JS and XWayland

Offline

#9 2018-03-26 18:27:12

wzrdtales
Member
Registered: 2017-03-14
Posts: 13

Re: Gnome 3.28 - Settings not working

Executing `killall gnome-control-center` helps fixing this issue at least temporarily.

Offline

#10 2018-03-26 19:42:29

blispx
Member
Registered: 2017-11-29
Posts: 25

Re: Gnome 3.28 - Settings not working

it does not fix anything, after rebooting and running the gnome-user-account again hangs

Offline

#11 2018-03-26 20:22:43

wzrdtales
Member
Registered: 2017-03-14
Posts: 13

Re: Gnome 3.28 - Settings not working

It does, if you would read the whole sentence instead, you would have noticed the last word **temporarily**.

Offline

#12 2018-03-26 20:52:51

lpr1
Member
Registered: 2017-10-08
Posts: 31

Re: Gnome 3.28 - Settings not working

blispx wrote:

it does not fix anything, after rebooting and running the gnome-user-account again hangs

Whole gnome-control-center hangs after visiting users tab for me on X.Org session (did not try wazland), i had same problem when upgraded to 3.26.1, it was fixed in 3.26.2 as far as I can recall. Everything else works fine on X.Org.

Offline

#13 2018-03-26 23:57:58

blispx
Member
Registered: 2017-11-29
Posts: 25

Re: Gnome 3.28 - Settings not working

Gnome really? :-)

Process 19111 (gnome-control-c) of user 1000 dumped core.

Stack trace of thread 19111:
#0  0x000055a189fce6f0 n/a (gnome-control-center)
#1  0x00007f5f7af62c2d g_closure_invoke (libgobject-2.0.so.0)
#2  0x00007f5f7af76bb0 n/a (libgobject-2.0.so.0)
#3  0x00007f5f7af7f746 g_signal_emit_valist (libgobject-2.0.so.0)
#4  0x00007f5f7af80180 g_signal_emit (libgobject-2.0.so.0)
#5  0x00007f5f7494810c n/a (libibus-1.0.so.5)
#6  0x00007f5f7b23918c n/a (libgio-2.0.so.0)
#7  0x00007f5f7b2391c9 n/a (libgio-2.0.so.0)
#8  0x00007f5f7ac872c6 g_main_context_dispatch (libglib-2.0.so.0)
#9  0x00007f5f7ac876a1 n/a (libglib-2.0.so.0)
#10 0x00007f5f7ac8772e g_main_context_iteration (libglib-2.0.so.0)
#11 0x00007f5f7b250b3e g_application_run (libgio-2.0.so.0)
#12 0x000055a189f5c82a main (gnome-control-center)
#13 0x00007f5f738e5f4a __libc_start_main (libc.so.6)
#14 0x000055a189f5c9ea _start (gnome-control-center)

Stack trace of thread 19116:
#0  0x00007f5f7acc471c g_variant_unref (libglib-2.0.so.0)
#1  0x00007f5f7ac74de2 n/a (libglib-2.0.so.0)
#2  0x00007f5f7ac7574f g_hash_table_unref (libglib-2.0.so.0)
#3  0x00007f5f7b275d9d n/a (libgio-2.0.so.0)
#4  0x00007f5f7af67f25 g_object_unref (libgobject-2.0.so.0)
#5  0x00007f5f7b27fcbb n/a (libgio-2.0.so.0)
#6  0x00007f5f7b281920 n/a (libgio-2.0.so.0)
#7  0x00007f5f7b23918c n/a (libgio-2.0.so.0)
#8  0x00007f5f7b2391c9 n/a (libgio-2.0.so.0)
#9  0x00007f5f7ac872c6 g_main_context_dispatch (libglib-2.0.so.0)
#10 0x00007f5f7ac876a1 n/a (libglib-2.0.so.0)
#11 0x00007f5f7ac879d2 g_main_loop_run (libglib-2.0.so.0)
#12 0x00007f5f7b27fb78 n/a (libgio-2.0.so.0)
#13 0x00007f5f7acafcea n/a (libglib-2.0.so.0)
#14 0x00007f5f7500f08c start_thread (libpthread.so.0)
#15 0x00007f5f739bae7f __clone (libc.so.6)

Stack trace of thread 19115:
#0  0x00007f5f739b097b __poll (libc.so.6)
#1  0x00007f5f7ac87613 n/a (libglib-2.0.so.0)
#2  0x00007f5f7ac8772e g_main_context_iteration (libglib-2.0.so.0)
#3  0x00007f5f7ac87782 n/a (libglib-2.0.so.0)
#4  0x00007f5f7acafcea n/a (libglib-2.0.so.0)
#5  0x00007f5f7500f08c start_thread (libpthread.so.0)
#6  0x00007f5f739bae7f __clone (libc.so.6)

Stack trace of thread 19114:
#0  0x00007f5f75015786 pthread_cond_timedwait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f5f698bf0cb _ZN7bmalloc9Scavenger13threadRunLoopEv (libjavascriptcoregtk-4.0.so.18)
#2  0x00007f5f5da21b9f execute_native_thread_routine (libstdc++.so.6)
#3  0x00007f5f7500f08c start_thread (libpthread.so.0)
#4  0x00007f5f739bae7f __clone (libc.so.6)

Stack trace of thread 19122:
#0  0x00007f5f739b5879 syscall (libc.so.6)
#1  0x00007f5f7acce7ed g_cond_wait_until (libglib-2.0.so.0)
#2  0x00007f5f7ac59953 n/a (libglib-2.0.so.0)
#3  0x00007f5f7acb06f6 n/a (libglib-2.0.so.0)
#4  0x00007f5f7acafcea n/a (libglib-2.0.so.0)
#5  0x00007f5f7500f08c start_thread (libpthread.so.0)
#6  0x00007f5f739bae7f __clone (libc.so.6)

Stack trace of thread 19119:
#0  0x00007f5f739b5879 syscall (libc.so.6)
#1  0x00007f5f7acce7ed g_cond_wait_until (libglib-2.0.so.0)
#2  0x00007f5f7ac59953 n/a (libglib-2.0.so.0)
#3  0x00007f5f7acb06f6 n/a (libglib-2.0.so.0)
#4  0x00007f5f7acafcea n/a (libglib-2.0.so.0)
#5  0x00007f5f7500f08c start_thread (libpthread.so.0)
#6  0x00007f5f739bae7f __clone (libc.so.6)

Stack trace of thread 19118:
#0  0x00007f5f739b097b __poll (libc.so.6)
#1  0x00007f5f7ac87613 n/a (libglib-2.0.so.0)
#2  0x00007f5f7ac8772e g_main_context_iteration (libglib-2.0.so.0)
#3  0x00007f5f4c67af4e n/a (libdconfsettings.so)
#4  0x00007f5f7acafcea n/a (libglib-2.0.so.0)
#5  0x00007f5f7500f08c start_thread (libpthread.so.0)
#6  0x00007f5f739bae7f __clone (libc.so.6)

Stack trace of thread 19124:
#0  0x00007f5f739b5879 syscall (libc.so.6)
#1  0x00007f5f7acce7ed g_cond_wait_until (libglib-2.0.so.0)
#2  0x00007f5f7ac59953 n/a (libglib-2.0.so.0)
#3  0x00007f5f7acb06f6 n/a (libglib-2.0.so.0)
#4  0x00007f5f7acafcea n/a (libglib-2.0.so.0)
#5  0x00007f5f7500f08c start_thread (libpthread.so.0)
#6  0x00007f5f739bae7f __clone (libc.so.6)

Offline

#14 2018-03-27 23:24:40

lpr1
Member
Registered: 2017-10-08
Posts: 31

Re: Gnome 3.28 - Settings not working

Now it doesn't work on X.Org at all, as others wrote.

Offline

#15 2018-03-28 01:23:50

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 414

Re: Gnome 3.28 - Settings not working

lpr1 wrote:

Now it doesn't work on X.Org at all, as others wrote.

I had this problem (on Wayland) for the previous 2 days but I don't see it today, on either my PC or laptop. Doesn't happen for me with Xorg either. I updated a few hours before your post so perhaps those updates fixed it.

Offline

#16 2018-03-28 01:45:18

lpr1
Member
Registered: 2017-10-08
Posts: 31

Re: Gnome 3.28 - Settings not working

bulletmark wrote:
lpr1 wrote:

Now it doesn't work on X.Org at all, as others wrote.

I had this problem (on Wayland) for the previous 2 days but I don't see it today, on either my PC or laptop. Doesn't happen for me with Xorg either. I updated a few hours before your post so perhaps those updates fixed it.

Complete oposite for me, It worked fine till today, and I've just checked forum for the new post and started settings for whatever reason (to check it out I guess), and it doesn't work anymore, now did reboot and still the same..., my system is up to date, maybe mirrors I use are not synched yet (they usually lag ~8h), so that's the state of it as of now.

Offline

#17 2018-03-28 07:30:51

jancici
Member
From: Kalinovo,SK
Registered: 2011-12-04
Posts: 149

Re: Gnome 3.28 - Settings not working

lpr1 wrote:

Whole gnome-control-center hangs after visiting users tab for me on X.Org session

this happen on my PC, after restart I was not able to start control-cetner at all.

wzrdtales wrote:

Executing `killall gnome-control-center` helps fixing this issue at least temporarily.

This help me to run control center on PC which is using xorg.


On Laptop, I am using wayland and there is not any problem with control-center.

Offline

#18 2018-03-28 09:02:02

AlynxZhou
Member
Registered: 2017-02-20
Posts: 28
Website

Re: Gnome 3.28 - Settings not working

I found that user tab hangs since 3.26...

Offline

#19 2018-03-28 13:46:41

phantomis
Member
Registered: 2011-10-06
Posts: 2

Re: Gnome 3.28 - Settings not working

Same problem here, killing the gnome-control-center allow me to change a setting i needed, but I dont know if this will happen again

Offline

#20 2018-03-28 21:56:22

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 414

Re: Gnome 3.28 - Settings not working

AlynxZhou wrote:

I found that user tab hangs since 3.26...

For me also, and it is simply ridiculous that problem still exists in 3.28. But note that is a separate problem to what is being discussed here which only started in 3.28.

Offline

#21 2018-03-28 22:48:52

lpr1
Member
Registered: 2017-10-08
Posts: 31

Re: Gnome 3.28 - Settings not working

And now it works for me, this is completely random lol.

Last edited by lpr1 (2018-03-28 22:49:58)

Offline

#22 2018-04-06 00:43:30

Erdem
Member
From: Istabul
Registered: 2012-03-15
Posts: 3
Website

Re: Gnome 3.28 - Settings not working

Here gnome-control-center is issue too.
I don't know why libwebkit2gtk doesn't include required symbol.

[death@Ryzen ~]$ gnome-control-center -v
gnome-control-center: symbol lookup error: /usr/lib/libwebkit2gtk-4.0.so.37: undefined symbol: soup_session_connect_async

PS: It's due libsoup-gnome from AUR.

Last edited by Erdem (2018-04-06 00:54:03)

Offline

#23 2018-04-15 18:37:44

JackSchnippes
Member
Registered: 2010-06-16
Posts: 4

Re: Gnome 3.28 - Settings not working

I also got the error message

gnome-control-center: symbol lookup error: /usr/lib/libwebkit2gtk-4.0.so.37: undefined symbol: soup_session_connect_async

After Erdem's hint towards libsoup-gnome from AUR I resolved the issue permanently like so:

$ sudo pacman -S libsoup
resolving dependencies...
looking for conflicting packages...
:: libsoup and libsoup-gnome are in conflict. Remove libsoup-gnome? [y/N] y

Packages (2) libsoup-gnome-2.59.90.1-1 [removal]  libsoup-2.62.1-1

Total Download Size:   0.54 MiB
Total Installed Size:  4.52 MiB
Net Upgrade Size:      0.05 MiB

:: Proceed with installation? [Y/n]

Offline

#24 2018-06-11 12:37:55

fero
Member
Registered: 2015-05-03
Posts: 2

Re: Gnome 3.28 - Settings not working

Thank you @JackSchnippes . `sudo pacman -S libsoup` SOLVED for me

Offline

#25 2018-06-29 12:33:24

jerikko
Member
Registered: 2018-06-29
Posts: 1

Re: Gnome 3.28 - Settings not working

fero wrote:

Thank you @JackSchnippes . `sudo pacman -S libsoup` SOLVED for me

Offline

Board footer

Powered by FluxBB