You are not logged in.

#1 2018-03-25 18:11:19

ozooha
Member
Registered: 2009-09-29
Posts: 95

Gnome Nautilius shows no fstab mounted drives

With the update I cannot seem to see my mounted drives as per the fstab file.
They are mounted when I check them under /media.
Also conky shows them as well.
OZooHA

Last edited by ozooha (2018-03-25 18:11:43)

Offline

#2 2018-03-25 18:55:11

Kisuke-CZE
Member
Registered: 2017-03-16
Posts: 9
Website

Re: Gnome Nautilius shows no fstab mounted drives

Same fo me. Mounting SMB shares from bash script in /run/media/USER/SHARENAME. Nautilus does not show them since I upgraded to 3.28. Worked well in 3.26.

This might be some new "feature".
But would be nice to have some switch to turn it on again.

Last edited by Kisuke-CZE (2018-03-25 19:06:42)

Offline

#3 2018-03-25 22:17:41

ozooha
Member
Registered: 2009-09-29
Posts: 95

Re: Gnome Nautilius shows no fstab mounted drives

Keep me informed please as i will do the same as and when I get that correct information.
Cheers.
OZooHA

Offline

#4 2018-03-29 00:27:49

ozooha
Member
Registered: 2009-09-29
Posts: 95

Re: Gnome Nautilius shows no fstab mounted drives

Kisuke-CZE wrote:

Same fo me. Mounting SMB shares from bash script in /run/media/USER/SHARENAME. Nautilus does not show them since I upgraded to 3.28. Worked well in 3.26.

This might be some new "feature".
But would be nice to have some switch to turn it on again.

So I had to do this:
from

<hostname>:/media /media nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=10min 0 0

to

<hostname>:/media /media nfs noauto,user ,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=10min, comment=x-gvfs-show  0 0

introduce user and comment=x-gvfs-show

Offline

#5 2018-03-29 16:32:53

Kisuke-CZE
Member
Registered: 2017-03-16
Posts: 9
Website

Re: Gnome Nautilius shows no fstab mounted drives

Thanks for info. Unfortunately this does not work for me.
I was mounting network shares like:

sudo mount -t cifs -o nobrl,user=${MOUNT_USER},password=${SECRET},uid=${USER},gid=${GROUP} //${NAS_IP}/${SHARE} ${MEDIA_DIR}/${USER}/${SHARE}

Changed it to

sudo mount -t cifs -o nobrl,user=${MOUNT_USER},password=${SECRET},uid=${USER},gid=${GROUP},user,comment=x-gvfs-show //${NAS_IP}/${SHARE} ${MEDIA_DIR}/${USER}/${SHARE}

But nothing changed.

I did a workarround by mounting shares in script like this:

gio mount "${URL}" >> /dev/null << EOF
${USERNAME}

${PASSWD}
EOF

This does the trick with showing mounted share in nautilus. But causes another problems. Some apps cannot access files in shares mounted via gvfs... And nautilus does not show thumbnail for multimedia files when mounted this way.
Well, what a nice upgrade. I will keep trying to find optimal solution.

Last edited by Kisuke-CZE (2018-03-29 16:33:36)

Offline

#6 2018-03-29 16:35:00

docattheradarstation
Member
Registered: 2018-03-29
Posts: 2

Re: Gnome Nautilius shows no fstab mounted drives

I have the same problem using autofs instead of fstab, however ozooha's solution does not work for me, or at least I'm unsure where to add user and comment=x-gvfs-show.

Here's an entrance for an entrance for an nfs share:

/etc/autofs/auto.hdd

/media/hdd -rsize=8192,wsize=8192,auto 192.168.1.23:/mnt/hdd

Offline

#7 2018-03-30 00:25:28

ozooha
Member
Registered: 2009-09-29
Posts: 95

Re: Gnome Nautilius shows no fstab mounted drives

Kisuke-CZE wrote:

Thanks for info. Unfortunately this does not work for me.
I was mounting network shares like:

sudo mount -t cifs -o nobrl,user=${MOUNT_USER},password=${SECRET},uid=${USER},gid=${GROUP} //${NAS_IP}/${SHARE} ${MEDIA_DIR}/${USER}/${SHARE}

Changed it to

sudo mount -t cifs -o nobrl,user=${MOUNT_USER},password=${SECRET},uid=${USER},gid=${GROUP},user,comment=x-gvfs-show //${NAS_IP}/${SHARE} ${MEDIA_DIR}/${USER}/${SHARE}

But nothing changed.

I did a workarround by mounting shares in script like this:

gio mount "${URL}" >> /dev/null << EOF
${USERNAME}

${PASSWD}
EOF

This does the trick with showing mounted share in nautilus. But causes another problems. Some apps cannot access files in shares mounted via gvfs... And nautilus does not show thumbnail for multimedia files when mounted this way.
Well, what a nice upgrade. I will keep trying to find optimal solution.

Take off user and see what happens:

sudo mount -t cifs -o nobrl,user=${MOUNT_USER},password=${SECRET},uid=${USER},gid=${GROUP},comment=x-gvfs-show //${NAS_IP}/${SHARE} ${MEDIA_DIR}/${USER}/${SHARE}

Offline

#8 2018-03-30 00:30:50

ozooha
Member
Registered: 2009-09-29
Posts: 95

Re: Gnome Nautilius shows no fstab mounted drives

docattheradarstation wrote:

I have the same problem using autofs instead of fstab, however ozooha's solution does not work for me, or at least I'm unsure where to add user and comment=x-gvfs-show.

Here's an entrance for an entrance for an nfs share:

/etc/autofs/auto.hdd

/media/hdd -rsize=8192,wsize=8192,auto 192.168.1.23:/mnt/hdd

try the 2 combinations and see

/media/hdd -rsize=8192,wsize=8192,auto, user, comment=x-gvfs-show 192.168.1.23:/mnt/hdd

/media/hdd -rsize=8192,wsize=8192,auto, comment=x-gvfs-show 192.168.1.23:/mnt/hdd

You need the comment=x-gvfs-show to show for sure but the user is so that you don't have to use root login.

Offline

#9 2018-03-30 14:39:00

docattheradarstation
Member
Registered: 2018-03-29
Posts: 2

Re: Gnome Nautilius shows no fstab mounted drives

Unfortunately not even mounting via console (with or without the options you provided) manages to make my shares show up in my file manager.
I wonder if it's an nfs thing.

Last edited by docattheradarstation (2018-03-30 14:39:53)

Offline

#10 2018-04-12 14:10:41

alacn1
Member
Registered: 2018-04-12
Posts: 1

Re: Gnome Nautilius shows no fstab mounted drives

Offline

Board footer

Powered by FluxBB