You are not logged in.

#1 2006-07-31 16:05:59

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

beagle dependencies : gnome, evolution, etc. = mandatory ?

hi there,
installig beagle was one of my plans, till i realized how many things would be installed as dependencies : gnome, evolution and so one.
i don't care having some basic gnome stuff, but i don't want my kde system to be polluted by useless gnome stuff. i don't intend to start a troll, so if you're pro-gnome, please forgive me.

nevertheless, when i look at beagle's software requirement i don't see so many dependencies. is there any way not to install gnome, evolution, etc. ?

thanks for any help.!


what goes up must come down

Offline

#2 2006-07-31 18:49:18

Linteg
Member
From: Sweden
Registered: 2006-03-11
Posts: 54

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

I think the different backends (like evolution-sharp/evolution-data-server) could to blame for this, try editing the libbeagle pkgbuild to suit your own needs and recompile. It might be worth to look at Beagle's optional prerequisites..
Btw. as you're a kde-user, you might want to check out Kerry, which is a kde frontend for libbeagle, with it you will only need the libbeagle package (and not beagle, which is the gtk2 ui etc)...

Edit: Kerry also available from aur, I don't know if it's outdated or not though.

Offline

#3 2006-07-31 20:24:57

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

thansk for your ideas Linteg. unfortunately it looks like even kerry requires beagle. so the whole beagle stuff (including gnome) has to be installed.

and i don't feel confident enough to edit a pkgbuild... (i'm no coder...)


what goes up must come down

Offline

#4 2006-07-31 21:14:43

stavrosg
Member
From: Rhodes, Greece
Registered: 2005-05-01
Posts: 330
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

The real offender for beagle is the mono/gtk-sharp dependency, which depends on gnome-panel, and this one pulls the rest of the kitchen sink in smile

I tried long ago to do some gnome-free pkgbuilds but I failed, and gave up. It is a real cpu eater, too anyway.

Offline

#5 2006-07-31 21:39:58

Linteg
Member
From: Sweden
Registered: 2006-03-11
Posts: 54

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

Ok, so I ended up making a pkgbuild (based on the one in aur) for the devel version of kerry, I did a pacman -Rcs beagle before making it so i hope the dependancies are correct, try it out if you wish

pkgname=kerry-devel
pkgver=0.1.90
pkgrel=1
pkgdesc="A desktop search tool integrated with Beagle and KDE."
url="http://en.opensuse.org/Kerry"
license="GPL"
depends=('kdebase' 'libbeagle')
makedepends=()
source=(http://developer.kde.org/~binner/kerry/kerry-0.1.90.tar.bz2)
md5sums=('02b0d26c001d56f187d84379f93303e8')

build() {
  cd $startdir/src/kerry-$pkgver
  ./configure --prefix=/opt/kde
  make || return 1
  make DESTDIR=$startdir/pkg install
}

Offline

#6 2006-07-31 22:07:37

user
Member
Registered: 2006-03-29
Posts: 465

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

stavrosg wrote:

It is a real cpu eater, too anyway.

agreed, so i won't to install beagle, it will be greate if beagle port on java platform..
(i am using gnome-2.14.2.1)


I removed my sig, cause i select the flag, the flag often the target of enemy.

SAR brain-tumor
[img]http://img91.imageshack.us/img91/460/cellphonethumb0ff.jpg[/img]

Offline

#7 2006-08-01 08:31:56

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

Beagle porting to the java platform won't make a difference. Beagle is highly experimental software which keeps memory referenced most of the time, no matter what a garbage collector does.
Mono 1.1.16 is quite much optimized nowadays and does a perfect job. From the mono apps I've seen, switching them over to Java doesn't make them better.

About the huge list of gnome depends: If I would remove evolution-sharp, beagle would crash when it tries to run the evolution indexer. So it's either depend on evolution-sharp, or not support evolution indexing at all.

Since beagle is bloated anyways because of the gtk-sharp dependencies, I added evolution-sharp aswell.

Offline

#8 2006-08-01 13:14:38

codemac
Member
From: Cliche Tech Place
Registered: 2005-05-13
Posts: 776
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

Another item that you may want to note, is that it is Beagle's very purpose to have many dependencies.  Like spotlight in Mac OS X, without interoperability, the power of this application is diminished.

Offline

#9 2006-08-01 19:50:10

JGC
Developer
Registered: 2003-12-03
Posts: 1,659

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

I wonder what future beagle has in its current state. It's rather something that Novell needed quickly for their distribution than something everyone should use on every desktop. Besides beagle, I've seen at least two other indexing engines like beagle: tracker and Kat. Tracker is hosted on freedesktop.org as a multi-desktop interface that people use beagle for now.

Offline

#10 2006-08-01 20:12:28

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

FYI kerry really needs beagle to work. i'll give a try to those alternative apps JGC mentions.


what goes up must come down

Offline

#11 2006-08-01 20:44:27

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

kio-clucene looks nice also. it would be nice to have a PKGBUILD...


what goes up must come down

Offline

#12 2006-08-02 00:39:15

WillySilly
Member
From: Martinez, CA
Registered: 2005-01-14
Posts: 268
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

I started working on a package for tracker, but there is one pitfall, it needs the embedded mysql db to compile and work. So once thats available I'll make put up a package for tracker


<Shadowhand> wizzomafizzo, sorry, i meant "soul mate" ... err, "better self" err "best friend with boobs"

<dadexter> I am not gonna become a fscking signature

Offline

#13 2006-08-02 07:52:25

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: beagle dependencies : gnome, evolution, etc. = mandatory ?

damn ! kat daemon is MAJOR resource hog when indexing ! i've never ever encountered such systems slowdowns ! i hope index is incremental...


what goes up must come down

Offline

Board footer

Powered by FluxBB