You are not logged in.

#1 2018-05-03 19:09:46

Lopiben
Member
Registered: 2018-05-03
Posts: 5

wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Hello everyone,

I am trying to install wyrd (even though I'm not sure it's a good idea as the source site cannot be reached). I had to download the sources from a snapshot of the source website.

It requires ncurses, which is installed on my system and up-to-date. The ./configure fails to find term.h during the makepkg -s command :

[ben@arch-X220 wyrd]$ makepkg -s
...
=== configuring in curses (/home/ben/builds/wyrd/src/wyrd-1.4.6/curses)
configure: running /bin/sh ./configure --disable-option-checking '--prefix=/usr'  '--sysconfdir=/etc' '--enable-utf8' 'CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now' 'CPPFLAGS=-D_FORTIFY_SOURCE=2' '--enable-widec' --cache-file=/dev/null --srcdir=.
...
checking for sys/ioctl.h... yes
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking for working ncurses library... found in -lncurses
checking for term.h... configure: error: not found
configure: error: ./configure failed for curses
==> ERROR: A failure occurred in build().
    Aborting...

The complete output is available here.

This is the PKGBUILD :

# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Jeff Mickey <jeff@archlinux.org>
# Contributor: Daniel J Griffiths <griffithsdj@archlinux.us>

pkgname=wyrd
pkgver=1.4.6
pkgrel=3
pkgdesc='A text-based front-end to Remind.'
arch=('i686' 'x86_64')
url='http://pessimization.com/software/wyrd/'
license=('GPL')
depends=('remind' 'ncurses')
makedepends=('ocaml' 'camlp4')
source=("http://pessimization.com/software/wyrd/${pkgname}-${pkgver}.tar.gz")
md5sums=('2fc561482fdac4daac0cb6735d934ebe')

build() {
  cd "${srcdir}/${pkgname}-${pkgver}"

  ./configure --prefix=/usr --sysconfdir=/etc --enable-utf8
  make
}

package() {
  cd "${srcdir}/${pkgname}-${pkgver}"
  make DESTDIR="${pkgdir}" install
}

I do have a term.h file at /usr/include/term.h but I have no idea why the ./configure can't find it.

Do you have any idea ? Because I am lost.

Thank you,
Ben

Offline

#2 2018-05-03 20:06:28

loqs
Member
Registered: 2014-03-06
Posts: 11,242

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Check config.log for the exact cause of the failure.

Offline

#3 2018-05-03 23:23:35

Lopiben
Member
Registered: 2018-05-03
Posts: 5

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Here is the config.log : https://pastebin.com/E1jMi2Vr

As I understand it, the compiler searches for header files at different locations. I don't really understand why it continues from windows.h that it does not find to curses.h but then again, I don't understand many things.
It apparently fails after another unsuccesful search for term.h .

Thanks for your reply,
Ben

Offline

#4 2018-05-03 23:52:19

loqs
Member
Registered: 2014-03-06
Posts: 11,242

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

The config.log shows configure searching for ncursesw/curses.h ncurses/term.h curses/term.h which is not the same as curses.h or term.h different path.
Edit:

conftest.c:26:10: error: storage size of '__dummy' isn't known
 TERMINAL __dummy
configure:3668: checking for term.h
configure:3681: gcc -c -g -O2   conftest.c >&5
conftest.c: In function 'main':
conftest.c:26:10: error: storage size of '__dummy' isn't known
 TERMINAL __dummy
          ^~~~~~~
configure:3681: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_TERMIOS_H 1
| #define HAVE_SYS_IOCTL_H 1
| #define CURSES_HEADER <ncurses.h>
| /* end confdefs.h.  */
| #include <term.h>
| int
| main ()
| {
| TERMINAL __dummy
|   ;
|   return 0;
| }

edit2:
If I made that check succeed then configure succeeds but the build fails.
Not sure what the correct flagging for the package if the maintainer can not or will not fix it and upstream is missing I would remove it from the AUR.

Last edited by loqs (2018-05-04 00:42:34)

Offline

#5 2018-05-04 12:39:46

Lopiben
Member
Registered: 2018-05-03
Posts: 5

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

So I should give up on wyrd ?

Offline

#6 2018-05-04 13:30:33

loqs
Member
Registered: 2014-03-06
Posts: 11,242

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

I would wait two weeks for a response from the AUR maintainer. If the AUR maintainer does not respond and no one else responds to this thread
I would flag the package for deletion due to the discussed issues and give up on wyrd.
Edit:
Just noticed the package maintainer is a TU and has no responded to comments on the packages page from a year ago about the missing source.
So I would forgo waiting an additional 14 days and submit a deletion request for the package as it serves no useful function as it stands.

Last edited by loqs (2018-05-04 19:37:05)

Offline

#7 2018-05-07 07:22:11

Lopiben
Member
Registered: 2018-05-03
Posts: 5

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Done. Many thanks.

Offline

#8 2018-07-06 06:58:37

davidredick
Member
Registered: 2018-07-04
Posts: 4

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Some one cloned the source from debian package.

https://github.com/haguenau/wyrd

Still has the same term.h issue.

The patch is below but it merely allows you to uncover even more painful compile problems which I don't want to solve.


diff -Naur wyrd-master/curses/configure wyrd-master.new/curses/configure
--- wyrd-master/curses/configure    2017-07-07 20:57:58.000000000 +0000
+++ wyrd-master.new/curses/configure    2018-07-06 02:35:44.757633628 +0000
@@ -3669,6 +3669,7 @@
$as_echo_n "checking for term.h... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h.  */
+#define NCURSES_INTERNALS
#include <term.h>
int
main ()

Offline

#9 2020-07-30 10:50:57

Perdu
Member
Registered: 2020-07-30
Posts: 1

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Hi all,

I fixed the compile issues: https://github.com/Perdu/wyrd
I'm going to try to put this back on AUR!

Offline

#10 2020-07-30 15:30:42

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,875
Website

Re: wyrd 1.4.6-3 ./configure fails for curses : can't find term.h

Mod note: Closing this old thread.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB