You are not logged in.

#1 2018-05-04 16:33:59

julienfalque
Member
Registered: 2016-06-17
Posts: 36

Conflicting file error while updating extra/js52

Hi,

Today I tried updating my system and got the following error:

 $ LANG=en_US yaourt -Suya
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 Foreign packages: | 12 / 12

==> Package upgrade only (new release):
extra/js52             52.7.3-1  1 -> 2

==> Software upgrade (new version) :
core/libaio            0.3.110-1 -> 0.3.111-1
core/linux-lts         4.14.38-1 -> 4.14.39-1
core/linux-lts-headers 4.14.38-1 -> 4.14.39-1
extra/cmake            3.10.3-1  -> 3.11.1-1
extra/python2          2.7.14-3  -> 2.7.15-1

==> Continue upgrade ? [Y/n]
==> [V]iew package detail   [M]anually select packages
==> --------------------------------------------------
==> 
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (6) cmake-3.11.1-1  js52-52.7.3-2  libaio-0.3.111-1  linux-lts-4.14.39-1  linux-lts-headers-4.14.39-1  python2-2.7.15-1

Total Installed Size:  312.04 MiB
Net Upgrade Size:        0.30 MiB

:: Proceed with installation? [Y/n] 
(6/6) checking keys in keyring                                                                                                                                      [#####################################################################################################] 100%
(6/6) checking package integrity                                                                                                                                    [#####################################################################################################] 100%
(6/6) loading package files                                                                                                                                         [#####################################################################################################] 100%
(6/6) checking for file conflicts                                                                                                                                   [#####################################################################################################] 100%
error: failed to commit transaction (conflicting files)
js52: /usr/lib/libmozjs-52.so.0 exists in filesystem
Errors occurred, no packages were upgraded.

Can someone help me please?

Offline

#2 2018-05-04 16:39:06

schmodd
Member
Registered: 2015-02-12
Posts: 27

Re: Conflicting file error while updating extra/js52

Same error for me ;(

I checked via "pacman --query --list | grep /usr/lib/libmozjs" which shows:

js /usr/lib/libmozjs-24.so
js52 /usr/lib/libmozjs-52.so

Whats the problem?

Offline

#3 2018-05-04 16:41:01

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 8,339

Re: Conflicting file error while updating extra/js52

The problem is that the previous package didn't include the soname symlink, so it was created by ldconfig after pacman installed it. The new package does include it, so it conflicts. Not a great situation; you can force that one package or wait and see if the maintainer wants to do something different.

Offline

#4 2018-05-04 16:54:13

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,936

Re: Conflicting file error while updating extra/js52

... or just sudo rm /usr/lib/libmozjs-52.so.0 since it is safe to remove, then proceed as usual.

Last edited by eschwartz (2018-05-04 16:54:42)


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#5 2018-05-04 17:32:49

newbie1962
Member
From: italy
Registered: 2012-07-24
Posts: 137

Re: Conflicting file error while updating extra/js52

Eschwartz wrote:

... or just sudo rm /usr/lib/libmozjs-52.so.0 since it is safe to remove, then proceed as usual.

thank
Esschwartz


hp-envy dv7

Offline

#6 2018-05-04 19:57:51

Arup
Member
From: Earth
Registered: 2014-02-20
Posts: 89

Re: Conflicting file error while updating extra/js52

Eschwartz wrote:

... or just sudo rm /usr/lib/libmozjs-52.so.0 since it is safe to remove, then proceed as usual.

thanks that worked out well.

Offline

#7 2018-05-04 20:10:36

samhh
Member
Registered: 2017-12-25
Posts: 17

Re: Conflicting file error while updating extra/js52

Deleting the file as Eschwartz suggested also worked for me.

Offline

#8 2018-05-04 22:05:16

insomnium
Member
Registered: 2016-05-31
Posts: 4

Re: Conflicting file error while updating extra/js52

Arup wrote:
Eschwartz wrote:

... or just sudo rm /usr/lib/libmozjs-52.so.0 since it is safe to remove, then proceed as usual.

thanks that worked out well.

Yes, plain old file deletion done the magic for me as well, thanks.

Offline

#9 2018-05-04 22:08:23

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,194
Website

Re: Conflicting file error while updating extra/js52

Enough of the "me too" empty posts: https://wiki.archlinux.org/index.php/Co … mpty_posts


There is now an announcement on the ML and this is done. Closing.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB