You are not logged in.

#1 2018-05-12 11:59:10

stromo
Member
Registered: 2018-05-11
Posts: 12

rt2800pci: Network card fails and only recovers after reboot

I'm using a PCIe x1 network card with Ralink RT2790 chipset:

09:00.0 Network controller: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe

After short time (5-15 min) the device enters a failed state:

[  101.346719] rt2800pci 0000:09:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x000f address=0x00000000fdc1d000 flags=0x0000]
[  102.150029] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  102.717083] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  103.560001] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  104.130028] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  105.017087] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  105.584053] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  106.473452] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  107.039990] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  109.520656] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  110.186656] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  110.753465] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  111.850765] wlp9s0: authenticate with bc:05:43:90:07:f8
[  112.420005] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  112.423026] wlp9s0: send auth to bc:05:43:90:07:f8 (try 1/3)
[  113.330445] wlp9s0: send auth to bc:05:43:90:07:f8 (try 2/3)
[  114.343748] wlp9s0: send auth to bc:05:43:90:07:f8 (try 3/3)
[  115.330785] wlp9s0: authentication with bc:05:43:90:07:f8 timed out
[  115.927082] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  116.993739] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  117.560039] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  119.250005] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  124.249989] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  124.820001] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  125.005063] IPv6: ADDRCONF(NETDEV_UP): wlp9s0: link is not ready
[  125.576670] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  126.143378] ieee80211 phy0: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[  127.836762] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x0000006a]
[  129.503327] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x0000006a]
[  129.503332] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)

This makes my PC unconnected and so nearly unusable. How to fix this?

Last edited by stromo (2018-05-13 16:16:25)

Offline

#2 2018-05-13 12:36:11

stromo
Member
Registered: 2018-05-11
Posts: 12

Re: rt2800pci: Network card fails and only recovers after reboot

sorry for the late edit

Offline

#3 2018-05-13 13:39:05

mxfm
Member
Registered: 2015-10-23
Posts: 95

Re: rt2800pci: Network card fails and only recovers after reboot

I also have faulty 'Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe' (from lspci) which enters fail state.

In my case, this occurs when I slighly rotate laptop to move it to new place, journald is trottled with messages like above. Happens on both linux and windows. Softblocking via rfkill/Fn+F12 helps to shutdown the card (to gracefully close everything), but it remains in fail state, setting down interface does not help, removing and inserting module does not help. Only reboot.

Does something triggers these errors or it happens regularly?

P.S.

Last time I searched for help, I got no useful information. Looks like a hardware problem...

Offline

#4 2018-05-13 16:17:43

stromo
Member
Registered: 2018-05-11
Posts: 12

Re: rt2800pci: Network card fails and only recovers after reboot

The error comes inevitably after some time. As I'm using a desktop PC I don't even touch it.

Offline

#5 2018-05-13 16:28:10

jeremy31
Member
Registered: 2015-11-01
Posts: 149

Re: rt2800pci: Network card fails and only recovers after reboot

Does iwconfig show power management enabled?

Offline

#6 2018-05-13 16:41:16

mxfm
Member
Registered: 2015-10-23
Posts: 95

Re: rt2800pci: Network card fails and only recovers after reboot

stromo wrote:

The error comes inevitably after some time. As I'm using a desktop PC I don't even touch it.

Do you disassemble it from time to time? I regularly (once in 4-6 month) clean laptop (remove dust from cooler). I noticed that these failures are related with disassembling, but I cannot say for sure. Perhaps it was not plugged fully or somehow damaged ...

P.S. My laptop is 6 years old.

Offline

#7 2018-05-13 16:43:10

mxfm
Member
Registered: 2015-10-23
Posts: 95

Re: rt2800pci: Network card fails and only recovers after reboot

jeremy31 wrote:

Does iwconfig show power management enabled?

I have the same problem. In my case it is off:

wlo1      IEEE 802.11  ESSID:"*********"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: *********   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1183  Invalid misc:42979   Missed beacon:0

Offline

Board footer

Powered by FluxBB