You are not logged in.

#101 2018-12-19 19:01:01

progandy
Member
Registered: 2012-05-17
Posts: 3,225

Re: The IWD thread

n8henrie wrote:

Has anybody found a way to connect to an access point by BSSID instead of SSID? No luck with using BSSID with `connect` or `connect-hidden`.

There is no way, iwd doesn't expose BSSIDs, and BSS / AP information is squashed into networks. IWD is designed to be the automagic tool which handles all those pesky technical details for you after you select a network name and give your authentication info.

Last edited by progandy (2018-12-19 19:02:42)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#102 2018-12-20 08:31:59

ua4000
Member
Registered: 2015-10-14
Posts: 130

Re: The IWD thread

Have you tried the
https://wiki.archlinux.org/index.php/Iw … figuration
and create the configuration file by hand in /var/lib/iwd  ?

Also see here
https://git.kernel.org/pub/scm/network/ … enNetworks
for the extra option

ignore_broadcast_ssid=1

On the other hand, it's maybe not working yet:
https://wiki.debian.org/NetworkManager/iwd

Known issues
As of right now the only known issue with iwd is the inability to connect to hidden SSIDs. Feedback about your success or failure with iwd is warmly welcome!

Offline

#103 2018-12-20 16:50:24

n8henrie
Member
From: Shiprock, NM
Registered: 2014-03-30
Posts: 19
Website

Re: The IWD thread

progandy wrote:

IWD is designed to be the automagic tool which handles all those pesky technical details for you after you select a network name and give your authentication info.

Seems to be working great in general but my router conveniently(?) broadcasts my 2.4GHz and 5GHz networks under the same SSID (so some devices like my iPhone automatically use the 5 GHz when in range and switch to the 2.4GHz when farther away). But my new Arch box will only connect to the 2.4 with iwd, missing out on the 802.11ac speeds.

If I split it out into a separate network it connects to the 5GHz fine, so it seems to have the ability, but when under the SSID it will only use the 2.4.

With wpa_supplicant I can just specify the BSSID which works great, so I guess I'll go back to that for now.

ua4000 wrote:

Have you tried the
Also see here
https://git.kernel.org/pub/scm/network/ … enNetworks
for the extra option

ignore_broadcast_ssid=1

I don't see this config option anywhere in the actual source code, just in those tests.

$ git --no-pager grep -r -i ignore_broadcast_ssid
autotests/testHiddenNetworks/ssidHiddenOpen.conf:ignore_broadcast_ssid=1
autotests/testHiddenNetworks/ssidHiddenWPA.conf:ignore_broadcast_ssid=1
autotests/testHiddenNetworks/ssidOverlap1.conf:ignore_broadcast_ssid=1
autotests/testHiddenNetworks/ssidOverlap2.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1
autotests/testScan/ssid_hidden.conf:ignore_broadcast_ssid=1

Last edited by n8henrie (2018-12-20 16:50:46)

Offline

#104 2018-12-20 19:51:26

progandy
Member
Registered: 2012-05-17
Posts: 3,225

Re: The IWD thread

n8henrie wrote:

If I split it out into a separate network it connects to the 5GHz fine, so it seems to have the ability, but when under the SSID it will only use the 2.4.

network_bss_select might have to be updated with more intelligent logic that prefers 5GHz networks when the signal strength is good enough and only a bit less than the 2.4GHz signal.
https://git.kernel.org/pub/scm/network/ … ork.c#n652


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Online

#105 2018-12-20 23:14:59

n8henrie
Member
From: Shiprock, NM
Registered: 2014-03-30
Posts: 19
Website

Re: The IWD thread

Looks like it might already take it into account a bit with this ranking algorithm: https://git.kernel.org/pub/scm/network/ … can.c#n997

Last edited by n8henrie (2018-12-20 23:15:15)

Offline

#106 2018-12-21 17:29:04

ua4000
Member
Registered: 2015-10-14
Posts: 130

Re: The IWD thread

gothmog123 wrote:
ua4000 wrote:

I tested a while: for me dhcpcd + iwd only works on every 2nd boot.
To get wireless working I figured out, that I have to restart iwd manually.


As far as I can see the difference is: to get wireless working the log has to show "hardware_rekey not supported".

Any ideas on this ?

Don't know how much this will help, but I have systemd device renaming disabled, so my wireless is always wlan0, maybe you can try that.

Thanks for the help. I was thinking about it, also about adding a delay for starting iwd.service, e.g. 30s.

But for now, I had another idea, I enabled haveged to increase system entropy since I think you need some random numbers to use PSK...
6 of 6 reboots were successful afterwards.

Offline

#107 2019-01-07 20:59:33

Kampfpudding
Member
Registered: 2018-04-29
Posts: 9

Re: The IWD thread

Apparently, some user in this thread have no problems using connman with iwd. When iwd is running and I start connman, I get

Aborting (signal 11) [connmand]

and connman fails. The same happens when connman is started without iwd running (which works fine), but then after I start iwd (because I need a backend of course) connman crashes again. The same goes for starting connman with the

--wifi=iwd_agent

option.

I looked around a bit and found one entry here but the repo version of connman already is the latest (1.36-1). I tried iwd-git from the AUR, hoping there might be some fix that is not yet available for the repo version.

Any ideas? I would love to get rid of dhcpcd and just use connman instead. I know there are other DHCP clients out there, but this bugs me very much and would really like to have it fixed.

Offline

#108 2019-01-07 23:16:10

rsmarples
Member
Registered: 2009-05-12
Posts: 203

Re: The IWD thread

Kampfpudding wrote:

I would love to get rid of dhcpcd and just use connman instead. I know there are other DHCP clients out there, but this bugs me very much and would really like to have it fixed.

Why do you want to get rid of dhcpcd?
As the author I'd like to know how I can improve it.

Offline

#109 2019-01-08 23:16:11

Kampfpudding
Member
Registered: 2018-04-29
Posts: 9

Re: The IWD thread

Oh nothing serious. It's just one more thing I need to keep track of on top of iwd. So connman would kind of combine two packages into one. Additionally I feel like when I drop my connection, dhcpcd causes trouble of some kind (I usually have to restart it in order to get an connection/local IP. Might be on iwd's side, though). This sounds really vague and that's because it is. I haven't really looked into it smile

Last edited by Kampfpudding (2019-01-08 23:18:57)

Offline

#110 2019-01-09 09:10:46

Binabik
Member
Registered: 2017-04-20
Posts: 8

Re: The IWD thread

Like for others, it is crucial for me to control which BSS my device connects to.

n8henrie wrote:

Looks like it might already take it into account a bit with this ranking algorithm: https://git.kernel.org/pub/scm/network/ … can.c#n997

This ranking algorithm looks quite hard-coded. Does anyone know if there are plans to
a) either let the user control the BSS that will be chosen
b) or make the ranking algorithm configurable?

Until then, I would rather stick with wpa_supplicant although I like the concept of iwd because wpa_supplicant gives me more control about how I will connect.

Offline

#111 2019-01-12 21:26:54

Troels
Member
From: Denmark
Registered: 2009-03-01
Posts: 12

Re: The IWD thread

Hello, I just want to say, if you've had any trouble connecting to eduroam though EAP+PEAP+MSCHAPv2 it should be solved now. The fix is in the git master. I went to IRC and provided debug logs, and the devs were super helpful.

Offline

#112 2019-01-13 13:30:13

andrewj
Member
Registered: 2016-02-19
Posts: 1

Re: The IWD thread

scruffidog wrote:

Anyone else who  upgraded to 0.8 and also running connman is getting a connman_iwd.service crash ?

Sep 25 18:15:29 hydra kernel: audit: type=1300 audit(1537913729.597:169): arch=c000003e syscall=54 success=yes exit=0 a0=9 a1=0 a2=40 a3=564048a86d10 items=0 ppid=1 pid=9458 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4
294967295 comm="connmand" exe="/usr/bin/connmand" key=(null)
Sep 25 18:15:29 hydra connmand[9458]: Checking loopback interface settings
Sep 25 18:15:29 hydra connmand[9458]: System hostname is hydra
Sep 25 18:15:29 hydra connmand[9458]: __connman_inet_get_pnp_nameservers: Cannot read /proc/net/pnp Failed to open file “/proc/net/pnp”: No such file or directory
Sep 25 18:15:29 hydra connmand[9458]: Cannot create /var/run/connman/resolv.conf falling back to /etc/resolv.conf
Sep 25 18:15:29 hydra connmand[9458]: lo {newlink} index 1 address 00:00:00:00:00:00 mtu 65536
Sep 25 18:15:29 hydra connmand[9458]: lo {newlink} index 1 operstate 0 <UNKNOWN>
Sep 25 18:15:29 hydra dbus-daemon[383]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.2626' (uid=0 pid=9458 comm="/usr/bin/connmand --wifi=iwd_agent -n ")
Sep 25 18:15:29 hydra connmand[9458]: enp3s0 {create} index 2 type 1 <ETHER>
Sep 25 18:15:29 hydra connmand[9458]: enp3s0 {update} flags 36867 <UP>
Sep 25 18:15:29 hydra connmand[9458]: enp3s0 {newlink} index 2 address F0:76:1C:63:AB:D3 mtu 1500
Sep 25 18:15:29 hydra connmand[9458]: enp3s0 {newlink} index 2 operstate 2 <DOWN>
Sep 25 18:15:29 hydra connmand[9458]: Adding interface enp3s0 [ ethernet ]
Sep 25 18:15:29 hydra connmand[9458]: wlp4s0 {create} index 3 type 1 <ETHER>
Sep 25 18:15:29 hydra connmand[9458]: wlp4s0 {RX} 741074 packets 983205233 bytes
Sep 25 18:15:29 hydra connmand[9458]: wlp4s0 {TX} 404940 packets 51663314 bytes
Sep 25 18:15:29 hydra connmand[9458]: wlp4s0 {update} flags 69699 <UP,RUNNING,LOWER_UP>
Sep 25 18:15:29 hydra connmand[9458]: wlp4s0 {newlink} index 3 address D0:7E:35:9B:90:56 mtu 1500
Sep 25 18:15:29 hydra connmand[9458]: wlp4s0 {newlink} index 3 operstate 6 <UP>
Sep 25 18:15:29 hydra connmand[9458]: Adding interface wlp4s0 [ wifi ]
Sep 25 18:15:29 hydra connmand[9458]: Aborting (signal 11) [/usr/bin/connmand]
Sep 25 18:15:29 hydra connmand[9458]: ++++++++ backtrace ++++++++
Sep 25 18:15:29 hydra connmand[9458]: #0  0x7f7f6130ce00 in /usr/lib/libc.so.6
Sep 25 18:15:29 hydra connmand[9458]: #1  0x564047565ea7 in /usr/bin/connmand
Sep 25 18:15:29 hydra connmand[9458]: #2  0x56404756646b in /usr/bin/connmand
Sep 25 18:15:29 hydra connmand[9458]: #3  0x5640475d00d4 in /usr/bin/connmand
Sep 25 18:15:29 hydra connmand[9458]: #4  0x5640475d1547 in /usr/bin/connmand
Sep 25 18:15:29 hydra connmand[9458]: #5  0x7f7f6165301e in /usr/lib/libdbus-1.so.3
Sep 25 18:15:29 hydra connmand[9458]: #6  0x7f7f61656b5c in /usr/lib/libdbus-1.so.3
Sep 25 18:15:29 hydra connmand[9458]: #7  0x5640475caed1 in /usr/bin/connmand
Sep 25 18:15:29 hydra connmand[9458]: #8  0x7f7f616fe271 in /usr/lib/libglib-2.0.so.0
Sep 25 18:15:29 hydra connmand[9458]: #9  0x7f7f616fff89 in /usr/lib/libglib-2.0.so.0
Sep 25 18:15:29 hydra connmand[9458]: #10 0x7f7f61700f62 in /usr/lib/libglib-2.0.so.0
Sep 25 18:15:29 hydra connmand[9458]: #11 0x564047545c8b in /usr/bin/connmand
Sep 25 18:15:29 hydra connmand[9458]: #12 0x7f7f612f9223 in /usr/lib/libc.so.6
Sep 25 18:15:29 hydra connmand[9458]: +++++++++++++++++++++++++++

After downgrading back to 0.7, everything is working fine again. Clues to troubleshoot ?

I had the same issue, which is caused by a null pointer issue in connman's iwd plugin.  It has already beeen reported upstream: https://01.org/jira/browse/CM-693

I confirmed this through debugging, and got it working by recompiling through ABS with the following amended prepare() function in the PKGBUILD:

prepare(){
  cd "${pkgname}-${pkgver}"
  patch -Np1 -i "${srcdir}/allow_group_network.diff"

  echo "Patching strcmp() to g_strcmp0() in iwd.c to avoid NULL issues..."
  sed -i -e 's/strcmp(/g_strcmp0(/g' plugins/iwd.c
}

Offline

Board footer

Powered by FluxBB