You are not logged in.

#151 2019-08-23 17:24:42

digitalone
Member
Registered: 2011-08-19
Posts: 212

Re: The IWD thread

jpegxguy wrote:

It should work though, no dhcpcd needed. Iwd has an internal dhcp client. Don't give up immediately. Make sure you're using the latest version (0.19 right now) and send the contents of /etc/iwd/main.conf and systemctl status iwd when you've started it with the config file (and without dhcpcd)

It's not working.

0.19 here, boot log:

iwd[430]: Skipping optional configuration file /etc/iwd/main.conf
iwd[430]: netconfig: Network configuration with the IP addresses is disabled

main.conf

[General]
enable_network_config=true

It's ignored.

Last edited by digitalone (2019-08-23 17:30:07)

Offline

#152 2019-08-23 17:40:14

jpegxguy
Member
From: Earth
Registered: 2018-06-18
Posts: 15

Re: The IWD thread

That's the behavior of iwd when it can't see such a file. How do the permissions look on /etc/iwd and /etc/iwd/main.conf?

Last edited by jpegxguy (2019-08-23 18:11:00)


hi

Offline

#153 2019-08-23 17:50:03

digitalone
Member
Registered: 2011-08-19
Posts: 212

Re: The IWD thread

jpegxguy wrote:

That's the behavior of iwd when it can see such a file. How do the permissions look on /etc/iwd and /etc/iwd/main.conf?

When it sees the file, does it "skip"?

drwxr-xr-x 2 root root 4096 Aug 23 19:35 /etc/iwd
-rw-r--r-- 1 root root 68 Aug 23 19:35 /etc/iwd/main.conf

It's not even renaming interface as "wlan0". I noticed this behavior in the last days.

Last edited by digitalone (2019-08-23 17:56:13)

Offline

#154 2019-08-23 18:14:00

jpegxguy
Member
From: Earth
Registered: 2018-06-18
Posts: 15

Re: The IWD thread

digitalone wrote:

It's not even renaming interface as "wlan0". I noticed this behavior in the last days.

If you move main.conf to another location and reboot (assuming iwd is enabled in systemctl) does iwd take control of the interface? AFAIK you can check this because if iwd has taken control of the interface and you kill is process (systemctl stop will do), the interface goes with it as well.


hi

Offline

#155 2019-08-23 22:29:50

digitalone
Member
Registered: 2011-08-19
Posts: 212

Re: The IWD thread

jpegxguy wrote:
digitalone wrote:

It's not even renaming interface as "wlan0". I noticed this behavior in the last days.

If you move main.conf to another location and reboot (assuming iwd is enabled in systemctl) does iwd take control of the interface? AFAIK you can check this because if iwd has taken control of the interface and you kill is process (systemctl stop will do), the interface goes with it as well.

No, because I created main.conf today and I already had interface name assigned by udev from the last few days. By default iwd should rename it to wlan0, but it's not happening.

Anyway, I returned to use wpa_supplicant to see if I get same issues with networkmanager. Using iwd, sometimes networkmanager loses connection without remembering the password, even if I already set it. That's why I wanted to try iwd alone and wanted to configure it, but I can't.

Offline

#156 2019-08-24 01:49:17

amish
Member
Registered: 2014-05-10
Posts: 404

Re: The IWD thread

I have been using main.conf with enable_network_config=true from few weeks now and it seems to be working fine. i.e. it is parsing it.

However, IWD does not connect immediately to Wifi AP.

I need to restart iwd 4-5 times and then it will connect.

Very rarely it connects on its own at system boot. (i.e. on first attempt)


Forum signature: I discuss. I put my thoughts strongly. But I definitely respect all developers and time they put in.

Offline

#157 2019-08-24 06:50:13

digitalone
Member
Registered: 2011-08-19
Posts: 212

Re: The IWD thread

Well, don't know what to say. I tried everything.

Maybe the only difference is that I'm using an USB wifi adapter I bought to replace an Intel wifi card of my laptop which its driver is bugged and causes connection to drop. That's why I tried to use iwd, I though to resolve with it but the issue happened the same. It's a driver issue.

Then I bought an Asus usb adapter that's working better but networkmanager with iwd sometimes loses connection telling me the put the password I already inserted before. Using iwd alone I can't configure it.

I see if the issue will occur with wpa_supplicant, I'd like to keep using networkmanager having plasma-nm applet in the system tray.

Last edited by digitalone (2019-08-24 06:53:33)

Offline

#158 2019-08-25 01:28:36

jpegxguy
Member
From: Earth
Registered: 2018-06-18
Posts: 15

Re: The IWD thread

jpegxguy wrote:

Using

iwd 0.18-1
networkmanager 1.18.0-1

Networkmanager actually starts iwd normally without having to enable it in systemctl. Nice.
I wonder if it works with eduroam though. The combination of these 2 didn't work before

This was actually random BTW. To this day I have iwd enabled in order for NetworkManager to play nicely with it. Otherwise I have to restart one of the 2.

https://gitlab.freedesktop.org/NetworkM … issues/101

Last edited by jpegxguy (2019-08-25 01:28:51)


hi

Offline

#159 2019-08-26 03:31:00

SRSR333
Member
Registered: 2019-05-09
Posts: 5

Re: The IWD thread

So, for some reason, iwd refuses to connect to my university's wireless network. In iwctl, I can scan for, and attempt to connect to the network, but after exiting iwctl and sending a ping to google.com, I receive an error.

The output of journalctl -b | grep iwd after attempting to connect:

Aug 26 10:34:04 archlinux iwd[753]: EAP server tried method 13 while client was configured for method 25
Aug 26 10:34:04 archlinux iwd[753]: PEAP: Tunnel has disconnected with alert: close_notify
Aug 26 10:34:09 archlinux iwd[753]: 4-Way handshake failed for ifindex: 4, reason: 15
Aug 26 10:34:09 archlinux iwd[753]: EAP server tried method 13 while client was configured for method 25
Aug 26 10:34:09 archlinux iwd[753]: PEAP: Tunnel has disconnected with alert: close_notify
Aug 26 10:34:14 archlinux iwd[753]: 4-Way handshake failed for ifindex: 4, reason: 15
Aug 26 10:34:14 archlinux iwd[753]: EAP server tried method 13 while client was configured for method 25
Aug 26 10:34:14 archlinux iwd[753]: PEAP: Tunnel has disconnected with alert: close_notify
Aug 26 10:34:19 archlinux iwd[753]: 4-Way handshake failed for ifindex: 4, reason: 15
Aug 26 10:34:20 archlinux iwd[753]: authentication timed out
Aug 26 10:34:20 archlinux iwd[753]: authentication timed out
Aug 26 10:34:20 archlinux iwd[753]: authentication timed out

My network's configuration file located in /var/lib/iwd/SSID.8021x (personal information obfuscated):

[Security]
EAP-Method=PEAP
EAP-Identity=anonymous
#EAP-PEAP-CACert=/path/to/cert.pem
EAP-PEAP-Phase2-Method=MSCHAPV2
EAP-PEAP-Phase2-Identity=domain\\user

[Settings]
Autoconnect=true

Otherwise, my entire network stack has only got three services running: systemd-networkd, systemd-resolved, and this, iwd. I was hoping to simply the bloat of NetworkManager + wpa_supplicant + dhcpcd + netctl and so on.

Does anyone know how I might contact the developers for further information? Thanks smile

Offline

#160 2019-08-26 07:21:39

progandy
Member
Registered: 2012-05-17
Posts: 3,491

Re: The IWD thread

iwd is located here:
https://git.kernel.org/pub/scm/network/ … git/about/
Mailing list:     https://lists.01.org/mailman/listinfo/iwd
IRC:    irc://irc.freenode.net/#iwd

Last edited by progandy (2019-08-26 07:42:34)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#161 2019-08-26 14:21:25

Stellarator
Member
Registered: 2019-01-12
Posts: 8

Re: The IWD thread

SRSR333 wrote:

So, for some reason, iwd refuses to connect to my university's wireless network. In iwctl, I can scan for, and attempt to connect to the network, but after exiting iwctl and sending a ping to google.com, I receive an error.

Check this and try to play with EAP-Method. I would recommend starting with:

[Security]
EAP-Method=TTLS
EAP-TTLS-CACert=/path/to/cert.pem
EAP-TTLS-Phase2-Method=MSCHAPV2
EAP-TTLS-Phase2-Identity=...
EAP-TTLS-Phase2-Password=...

Offline

#162 2019-08-26 16:15:27

SRSR333
Member
Registered: 2019-05-09
Posts: 5

Re: The IWD thread

Stellarator wrote:

Check this and try to play with EAP-Method. I would recommend starting with:

[Security]
EAP-Method=TTLS
EAP-TTLS-CACert=/path/to/cert.pem
EAP-TTLS-Phase2-Method=MSCHAPV2
EAP-TTLS-Phase2-Identity=...
EAP-TTLS-Phase2-Password=...

Works like a charm! Thank you very much.

Would you mind explaining why setting EAP-TTLS works, while EAP-PEAP doesn’t, even though the network configuration guide for my university’s network state that it’s supposed to be PEAP?

Last edited by SRSR333 (2019-08-26 16:18:30)

Offline

#163 2019-08-27 08:19:25

digitalone
Member
Registered: 2011-08-19
Posts: 212

Re: The IWD thread

Running wpa_supplicant from 3 days and no disconnection issues with networkmanager. I have to stay to wpa_supplicant since iwd were causing connection to drop asking me the password that I already inserted. Tried also to run iwd alone (disabling networkmanager), but I couldn't configure it because /etc/iwd/main.conf file was not parsed by the daemon which I enabled at boot. Maybe it's an incompatibility issue between iwd and usb wifi adapters since iwd was not even renaming interface name to wlan0 as it should do by default.

I'm sorry to say that, but iwd on my system is not a better replacement of wpa_supplicant. I orphaned networkmanager-iwd on AUR, feel free to adopt it if you want.

Offline

#164 2019-08-27 08:40:00

Stellarator
Member
Registered: 2019-01-12
Posts: 8

Re: The IWD thread

SRSR333 wrote:

Would you mind explaining why setting EAP-TTLS works, while EAP-PEAP doesn’t, even though the network configuration guide for my university’s network state that it’s supposed to be PEAP?

I can assume the obvious thing - outdated KB guide/article or something. Both types of encapsulation are quite (most?) popular (with the caveat that EAP-TTLS is not supported on Windows 7 or less). Therefore, I mean that some kind of transition occurred in your network, which was not reflected in the documentation in a timely manner.

Interestingly, the daemon gives a hint:

iwd[753]: EAP server tried method 13 while client was configured for method 25

This info is a bit cryptic but with some effort you can understand what is going on.

It would be nice if the daemon could adapt to the server’s responses, especially since your case is quite typical (or am I wrong?) and the daemon already has all the necessary information in the config (CACert, Phase2-Method, Phase2-Identity, Phase2-Password) to proceed with different encapsulation protocol (or at least try to do so). But it seems like no one has thought about it yet (here I can also be wrong, because I am not involved in the project at the proper level).

Offline

#165 2019-08-28 21:41:23

maxplayer
Member
Registered: 2019-08-28
Posts: 1

Re: The IWD thread

had issue with the latest version of iwd 0.19-1 on my x201 laptop

02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)
[ 5074.706361] iwlwifi 0000:02:00.0: Radio type=0x1-0x3-0x1
[ 5074.947940] iwlwifi 0000:02:00.0: Radio type=0x1-0x3-0x1
[ 5089.390751] wlan0: authenticate with 3c:28:6d:75:c0:bd
[ 5089.393587] wlan0: send auth to 3c:28:6d:75:c0:bd (try 1/3)
[ 5089.409481] wlan0: authenticated
[ 5089.412699] wlan0: associate with 3c:28:6d:75:c0:bd (try 1/3)
[ 5089.415170] wlan0: RX AssocResp from 3c:28:6d:75:c0:bd (capab=0x1011 status=0 aid=3)
[ 5089.418158] wlan0: associated
[ 5089.430669] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 5089.510298] wlan0: Limiting TX power to 20 (20 - 0) dBm as advertised by 3c:28:6d:75:c0:bd
[ 5090.081133] iwd[2865]: segfault at 73824f01018b ip 0000563935acbcd9 sp 00007ffd49729e38 error 4 in iwd[563935a53000+7f000]
[ 5090.081219] audit: type=1701 audit(1567026126.692:101): auid=4294967295 uid=0 gid=0 ses=4294967295 pid=2865 comm="iwd" exe="/usr/lib/iwd/iwd" sig=11 res=1
[ 5090.408177] audit: type=1131 audit(1567026127.019:103): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=iwd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
[ 5090.420367] wlan0: deauthenticating from 3c:28:6d:75:c0:bd by local choice (Reason: 3=DEAUTH_LEAVING)
[ 5090.672378] audit: type=1130 audit(1567026127.282:105): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=iwd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 5090.672595] audit: type=1131 audit(1567026127.282:106): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=iwd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[ 5090.693941] audit: type=1130 audit(1567026127.305:107): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=iwd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

I got connected, and right after disconnected, falling back to iwd 0.18-2 got it back stabled

a new Upstream commit has just been done for 0.20 i will give it a try once released for arch

Offline

#166 2019-08-29 23:24:12

patrickmcnamara
Member
From: Dublin, Ireland
Registered: 2019-08-29
Posts: 1
Website

Re: The IWD thread

Since 0.20, iwd is renaming my network interfaces despite the "use_default_interface=true" option in my config. If anyone knows a fix, it would be appreciated.

Offline

#167 2019-08-31 09:17:41

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,456

Re: The IWD thread

Can someone help me with this result of systemctl status iwd:

Aug 31 11:14:33 hostname iwd[5865]:         Bands: 2.4 GHz 5 GHz
Aug 31 11:14:33 hostname iwd[5865]:         Ciphers: CCMP TKIP BIP
Aug 31 11:14:33 hostname iwd[5865]:         Supported iftypes: ad-hoc station
Aug 31 11:14:33 hostname iwd[5865]: No control_port_over_nl80211 setting, defaulting to True
Aug 31 11:14:33 hostname iwd[5865]: Could not register frame watch type 00d0: -95
Aug 31 11:14:33 hostname iwd[5865]: Could not register frame watch type 00d0: -95
Aug 31 11:14:33 hostname iwd[5865]: Could not register frame watch type 00d0: -95
Aug 31 11:14:33 hostname iwd[5865]: Received error during CMD_TRIGGER_SCAN: Invalid argument (22)
Aug 31 11:14:33 hostname iwd[5865]: Could not register frame watch type 00d0: -95
Aug 31 11:14:33 hostname iwd[5865]: Received error during CMD_TRIGGER_SCAN: Invalid argument (22)

Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

#168 2019-08-31 09:26:41

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,456

Re: The IWD thread

... and what about this? Weird.

                                
[iwd]# station wlan0 show
                                 Station: wlan0                                
--------------------------------------------------------------------------------
  Settable  Property            Value                                          
--------------------------------------------------------------------------------
            Scanning            no
            State               disconnected

[iwd]# station wlan0 scan 
Argument type is wrong             

Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB