You are not logged in.

#1 2018-05-23 07:53:17

dx4
Member
Registered: 2018-05-23
Posts: 10

Viber no connection

I installed viber from AUR but I get no connection when I run it.

Here is the terminal output when I run it from console:

Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...            
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...             
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...            
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks                                     
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback                               
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback                          
qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings                                     
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup                               
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init                                  
qt.network.ssl: QSslSocket: cannot resolve sk_new_null                                          
qt.network.ssl: QSslSocket: cannot resolve sk_push                                              
qt.network.ssl: QSslSocket: cannot resolve sk_free                                              
qt.network.ssl: QSslSocket: cannot resolve sk_num                                               
qt.network.ssl: QSslSocket: cannot resolve sk_pop_free                                          
qt.network.ssl: QSslSocket: cannot resolve sk_value                                             
qt.network.ssl: QSslSocket: cannot resolve SSL_library_init                                     
qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings                               
qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index                                 
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method                                  
qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method                                 
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method                                  
qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method                                 
qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain                             
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf                    
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf                      
qt.network.ssl: QSslSocket: cannot resolve SSLeay                                               
qt.network.ssl: QSslSocket: cannot resolve SSLeay_version                                       
qt.network.ssl: Incompatible version of OpenSSL                                                 
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method                
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init                    
QQuickItem: Cannot set activeFocusOnTab to false once item is the active focus item.            

Offline

#2 2018-05-23 12:40:34

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,285

Re: Viber no connection

Have you tried the LD_LIBRARY_PATH workaround in myrik93 comment ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2018-05-29 07:45:32

dx4
Member
Registered: 2018-05-23
Posts: 10

Re: Viber no connection

Doesn't seem to work. Or maybe I'm still doing something wrong when excecuting the command.

This is the error shown in console when it says "no connection":

QQuickItem: Cannot set activeFocusOnTab to false once item is the active focus item.
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init

Offline

#4 2018-05-29 11:58:39

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,285

Re: Viber no connection

post the command you run as well as its full output in the console/xterminal .

This is proprietary software compiled for debian, trying to get that working ion arch linux s often hard and we need as  much info as possible.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2018-05-31 07:30:16

dx4
Member
Registered: 2018-05-23
Posts: 10

Re: Viber no connection

[dx4@dxserver ~]$ LD_LIBRARY_PATH=/opt/viber/lib/ viber
mv: replace '/home/dx4/.config/mimeapps.list', overriding mode 0644 (rw-r--r--)?
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
qt.network.ssl: QSslSocket: cannot resolve sk_new_null
qt.network.ssl: QSslSocket: cannot resolve sk_push
qt.network.ssl: QSslSocket: cannot resolve sk_free
qt.network.ssl: QSslSocket: cannot resolve sk_num
qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
qt.network.ssl: QSslSocket: cannot resolve sk_value
qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
qt.network.ssl: QSslSocket: cannot resolve SSLeay
qt.network.ssl: QSslSocket: cannot resolve SSLeay_version
qt.network.ssl: Incompatible version of OpenSSL
qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
QQuickItem: Cannot set activeFocusOnTab to false once item is the active focus item.

When I click "yes" when it asks me if I have viber installed in a mobile phone:

QQuickItem: Cannot set activeFocusOnTab to false once item is the active focus item.

When I enter my phone:

qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init

Offline

#6 2018-05-31 20:40:07

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,285

Re: Viber no connection

Goto the folder where you build viber, cd into src .
extract control.tar.gz to somewherre and open the file control .
It lists all the dependencies debian uses for viber .

One thing stands out like a sore thumb : openssl1.0.0 .
Viber needs an polder version of openssl.

install openssl-1.0 with pacman, try running viber again.
Post  a comment on the aur page about the wrong dependency the package has.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2018-06-04 07:36:58

dx4
Member
Registered: 2018-05-23
Posts: 10

Re: Viber no connection

Edit: Nice, that seems to have fixed most of the problems. The remaining errors are:

Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
QQuickItem: Cannot set activeFocusOnTab to false once item is the active focus item.

Last edited by dx4 (2018-06-04 08:48:45)

Offline

Board footer

Powered by FluxBB