You are not logged in.

#1 2018-05-23 15:22:48

Registered: 2008-03-11
Posts: 219

Dell XPS 13 (2015) random freezing

I've had this problem for a few weeks now.

The laptop will lock up completely at random. When it happens, the screen, mouse, everything is frozen (REISUB having no effect). If there's audio playing, the last second or so of audio is being repeated indefinitely.

When does it happen?
I think i never happened when there's really nothing going on on the laptop
Sometimes it happens when I'm not using it except playing some music (through mplayer)
Most often it happens when I'm actively using it, whether playing music or not.

There are no log messages in dmesg, journald, Xorg.log or anywhere to be found.

I have no way of debugging what happens when the freeze happends.

How do I fix this? I have no idea. I will be running a memtest in a few days. Other than that, I have no ideas.

More info:
Dell XPS 13 9343
glxinfo: direct rendering: Yes
Using the modesetting driver
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=off"
All packages up to date


#2 2018-05-23 22:15:05

From: Brisbane, Australia
Registered: 2013-10-22
Posts: 433

Re: Dell XPS 13 (2015) random freezing

The Arch wiki for our 9343 model is excellent. Have you followed everything there, e.g. have you updated to the current BIOS? Note there are two different 2015 XPS 13 models so you should fix your post title. You should also clarify whether you have the touchscreen model. My 9343 is up to date, using modesetting also, and never locks up running GNOME+Wayland. My machine is as per the wiki except I have i915.enable_psr=1 set as it does not cause flicker on my non-touchscreen model.


#3 2018-06-10 12:05:02

Registered: 2018-06-10
Posts: 1

Re: Dell XPS 13 (2015) random freezing

I think I had the same issue as you. I've also got a Dell xps 2015, and the last few weeks my computer started freezing randomly, a few times a day (maybe once every two hours, sometimes more frequently), with no apparent pattern. Happened when I was watching a movie with mplayer, coding, or just surfing the web. If I was listening to music, the song would just repeat the last few seconds over and over.

Couldn't find any relevant log messages, so I I ended up just trying various things, for instance,
- All the things here: … tel_driver
- Downgrading all my packages (except kernel) by a date in April (as I'm pretty sure it wasn't happening then) ( … cific_date)

None of that worked, so I thought it might be something with the kernel, so I installed the Long Term Support version of the kernel, (linux-lts and linux-lts-headers) and it hasn't happened since (2 days), so might be worth trying if you don't need the latest kernel. I'm pretty sure that fixed it for me. ( … linux-lts/)


#4 2018-06-10 13:09:34

Registered: 2012-06-16
Posts: 125

Re: Dell XPS 13 (2015) random freezing

A little light on details (i.e. what graphics cards are being used, what cpu, what drivers are being used etc.). But I will say I was having similar issues with a Dell Precision 5510 with a Skylake cpu (i5-6440HQ) and intel HD530 graphics using either the xf86-video-intel or modesetting.

I was able to finally solve by turning off intel_pstate by passing the following kernel parameter in my bootloader


Ended months of frustration for me and laptop is now usable again.

Last edited by CarbonChauvinist (2018-06-10 13:09:52)

"the wind-blown way, wanna win? don't play"


#5 2019-01-06 13:45:42

Registered: 2018-11-11
Posts: 2

Re: Dell XPS 13 (2015) random freezing

Hello there,

I have the same issue. The laptop decides to hang at some point and it's exactly as OP describes it.
Some memtestx86 shows that RAM is fine. Doing heavy loads (gpu/cpu stress) shows no effect - the System reached ~84°C but continues to work. Those hangs seem very random.

I tried a BIOS update for now (going from A13 -> A18) and I'll have a look what it does.
Setting cstate to 0 didn't help either.

When I encountered this issue, I switched to the lts kernel and that did it untill the lts kernel was updated. So I downgraded the thing and everything was fine.
But that isn't really an option. For now,I'll try to use the new BIOS and see how long I can continue with the 4.20.0-zen1 (linux-zen) kernel.

P.S. The kernel that seemed to be working was 4.14.X. Everything after that caused issues. I'm not sure if it's appropriate to report this to the kernel people yet. I'm really surrprised not more people are affected.


Board footer

Powered by FluxBB