You are not logged in.

#1 2018-05-27 10:58:24

Askannz
Member
Registered: 2016-10-22
Posts: 33

[Solved] Headphones volume linked to the wrong control, and automute

Hi there.

Here is what the "alsamixer" playback console looks like on my machine :

https://i.imgur.com/vfDjKZj.png

Normally, the "Headphone" slider should control my headphones when they are plugged in the output jack port, and the "Speaker" slider should control the built-in speakers of my laptop. But for some reason, what really happens on my machine is that the "Speaker" slider actually controls both, and the "Headphone" slider does nothing at all.

If would not be so much of a problem if it was not for the fact that ALSA (or PulseAudio, not sure which one is the culprit here) automatically brings the "Speaker" slider to zero whenever I plug in my headphones, and so I have to manually bring it back to its normal level every time. I tried to disable the "Auto-mute" option on the right, but it does nothing at all and turns itself back on every time I reboot anyway.

So my qeustions are :

- Is there something wrong with my setup, and how do I fix it to get the proper channels associated with the proper output ?
- If I cannot get ALSA or PulseAudio to recognize the correct controls, how can I at least disable the auto-mute feature ?

Relevant bits of info about my config : the laptop is an MSI GE63VR 7RE, the audio card is an Intel CM238, I have both ALSAand PulseAudio installed, but they came with KDE Plasma 5 and I did not change anything in their configuration. I am running on kernel 4.16.10, and all packages are up-to-date as far as I know. Please let me know if I forgot something.

Thanks for your help.

Mod note: Please don't post oversized images -- V1del

Last edited by Askannz (2018-06-15 13:54:26)

Offline

#2 2018-06-05 20:30:35

Tuomola
Member
Registered: 2016-06-21
Posts: 9

Re: [Solved] Headphones volume linked to the wrong control, and automute

Hello,

My alsamixer volume controls are also messed up, issue seems to be similar to what Askannz posted, and with the same sound card/chip setup.

So I got myself a new laptop, and installed Arch on it. Mostly everything has been working so far, only internal 4G modem gave some pain, which installing wvdial fixed. Sounds were not configured yet, so I threw all alsa stuff at it and pulseaudio on top. I had a signal from pulseaudio, but couldn't get it routed to speakers, even after all alsa unmuting.

Soundcard as to alsamixer is HDA Intel PCH with Realtek AC1220 chip.

I removed pulseaudio, but even with alsa I couldn't get any sound out. This was fixed with what I found from Gentoo forums:
https://forums.gentoo.org/viewtopic-p-8 … d46f749db8

So now in my /etc/modprobe.d sits an alsa.conf file which reads:
options snd-hda-intel model=dual-codecs

And sound started to come out!

However alsamixer is messed now:
- Both PCM and Headphone volumes act as masters, so if either is set to zero, no sound is heard
- Speaker volume control has no effect
- Muting works correctly on channels: if all volumes are set to max, muting headphones mutes them, same with speakers
- There is no option for auto-mute mode, as it would be nice to mute speakers when plugging in headphones
- No Master volume control

Last edited by Tuomola (2018-06-05 20:33:35)

Offline

#3 2018-06-07 12:45:39

Tuomola
Member
Registered: 2016-06-21
Posts: 9

Re: [Solved] Headphones volume linked to the wrong control, and automute

Ok, I got my stuff working now, let me know if it makes any difference to you Askanzz...

I got a Clevo P950EP6 board with HDA Intel PCH, Realtek ALC1220

changed this:

/etc/modprobe.d/alsa.conf
options snd-hda-intel model=no-primary-hp

Stuff works as it should by first glance with Pulseaudio too. Although alsamixer still treats 'Headphones' as general master too, it seems that plugging headphones in mutes speakers.

Edit: headset mic is not recognized yet, could be a minor settings tweak somewhere, I'll look into it later.

Another edit:
Concerning 'Headphone' as master, it gets muted every time headphones are unlocked, which results no audio on speakers. Now I have to up volume on
headphones again on alsamixer... annoyances...

Last edited by Tuomola (2018-06-07 13:49:25)

Offline

#4 2018-06-15 13:53:31

Askannz
Member
Registered: 2016-10-22
Posts: 33

Re: [Solved] Headphones volume linked to the wrong control, and automute

Fixed it.
The solution was to edit the file

/usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

and to change the section

[Element Speaker]
switch = off
volume = off

to

[Element Speaker]
switch = off
volume = merge

 
If I understand correctly, those "path" files define which ALSA channel goes to which PulseAudio output. By default, the "headphones" output is set to ignore (and in fact mute) the "Speaker" channel. That seems to be incompatible with my sound card for some reason. Tuomola, you should try to fiddle around with those files as well.

EDIT : Just to be clear, even after this fix, my headphones are still linked to the wrong control, but at least the automute is gone.

EDIT 2 : Seems like this file gets overwritten when PulseAudio gets an update, so I have to apply the fix again.

Last edited by Askannz (2018-06-26 02:15:06)

Offline

#5 2018-06-15 18:38:56

Tuomola
Member
Registered: 2016-06-21
Posts: 9

Re: [Solved] Headphones volume linked to the wrong control, and automute

Thanks Ask, it seems my issue is indeed solvable with editing these files. Just need to figure out the logic behind it... Experimented a bit, but it seems a reboot is needed to see if they worked or not.

Offline

Board footer

Powered by FluxBB