You are not logged in.

#1 2018-05-29 09:44:13

InFerYes
Member
Registered: 2012-11-13
Posts: 27

ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Hi, I was updating Arch today and encountered the following error:

error: failed to prepare transaction (could not satisfy dependencies)
:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64'

It's similar to the problem reported here.

I have solved the problem by updating vlc, removing ffmpeg2.8 and doing a full upgrade.

sudo pacman -Sy vlc
sudo pacman -R ffmpeg2.8
sudo pacman -Syu

Full excerpt of the problem:

:: Synchronizing package databases...
 core                                                                                                                                                                 129,4 KiB  3,83M/s 00:00 [#######################################################################################################################] 100%
 extra                                                                                                                                                               1610,1 KiB  11,2M/s 00:00 [#######################################################################################################################] 100%
 community                                                                                                                                                              4,4 MiB  11,2M/s 00:00 [#######################################################################################################################] 100%
 multilib                                                                                                                                                             172,0 KiB  12,0M/s 00:00 [#######################################################################################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: nodejs-lts-carbon and nodejs are in conflict. Remove nodejs? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64'

Offline

#2 2018-05-29 11:46:34

j3nnn1
Member
Registered: 2011-10-27
Posts: 2

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

thanks this :

sudo pacman -Sy vlc
sudo pacman -R ffmpeg2.8
sudo pacman -Syu

works for me!

so if I need install again ffmpeg2.8, may be I could do it with asp? or  I never could install again?

Offline

#3 2018-05-29 13:34:38

cmdrkotori
Member
Registered: 2017-07-30
Posts: 1

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

I fixed it with
pacman -Rs ffmpeg2.8
because the packages that used it (dcadec, schroedinger) are for codecs that are rarely used in the wild.

Offline

#4 2018-05-29 14:17:22

faceyneck
Member
Registered: 2017-12-16
Posts: 30

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Hmm... This seems like something that should be on the Arch homepage perhaps?

I had exact same error, took same steps to update Arch, namely the:

sudo pacman -Sy vlc
sudo pacman -R ffmpeg2.8
sudo pacman -Syu

 

I'll report back if I notice any NEW weirdness with VLC.
(I'm in a VM, and VLC is weird already, but that's for another post... if I get 'round to it.)

Thanks for posting, InFerYes,

-Facey

Offline

#5 2018-05-29 14:23:33

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,331

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

If you had to update vlc specifically, the issue is simply that you need to update more often.

Offline

#6 2018-05-29 14:47:15

Vrakfall
Member
Registered: 2018-03-18
Posts: 3

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

I've just had the same problem and the last time I updated was yesterday!
I wonder why I installed vlc tho, I always use mpv.

Offline

#7 2018-05-29 14:49:19

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,331

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

You can have the issue if you update regularly, but ffmpeg2.8 would not be required by vlc, so that's different than what faceyneck posted.

Offline

#8 2018-05-29 15:38:40

Vrakfall
Member
Registered: 2018-03-18
Posts: 3

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Alright, I see. Well then, it's still problematic.

Edit: Also, I meant I did install vlc, it wasn't a really wise decision from me since I don't use it.

Last edited by Vrakfall (2018-05-29 15:44:01)

Offline

#9 2018-05-29 15:39:47

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,331

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

It's only problematic if you don't keep your system cleaned up, don't read the error, and don't bother to check out the package in question.

Last edited by Scimmia (2018-05-29 15:41:46)

Offline

#10 2018-05-29 15:45:44

Vrakfall
Member
Registered: 2018-03-18
Posts: 3

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Ahah yeah, that's why I checked it out, probably a bit late.

Offline

#11 2018-05-29 17:45:27

bandithijo
Member
From: Indonesia
Registered: 2016-07-30
Posts: 4
Website

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

InFerYes wrote:

...

sudo pacman -Sy vlc
sudo pacman -R ffmpeg2.8
sudo pacman -Syu

that was solved my problem.


Technical Blog:Journal | BanditHijo.Com

Offline

#12 2018-05-29 17:55:41

Forum_Liker
Member
Registered: 2015-07-23
Posts: 27

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

sudo pacman -R ffmpeg2.8
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: bomi: removing ffmpeg2.8 breaks dependency 'ffmpeg2.8'

Offline

#13 2018-05-29 20:11:23

loqs
Member
Registered: 2014-03-06
Posts: 9,273

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

You will need to remove all AUR packages that depend on ffmpeg2.8 as well as ffmpeg2.8.  Then rebuild all those packages.

Offline

#14 2018-05-29 23:07:16

Konpai
Member
Registered: 2018-05-29
Posts: 1

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

sudo pacman -R ffmpeg2.8
sudo pacman -Syu

This worked for me! I didn't have to remove vlc.

Offline

#15 2018-05-29 23:42:02

donatom
Member
From: West Coast (California)
Registered: 2012-12-23
Posts: 30

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Thanks, InFerYes. Your solution works fine.

Offline

#16 2018-05-29 23:52:50

loqs
Member
Registered: 2014-03-06
Posts: 9,273

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

@donatom did you try without `pacman -Sy vlc` first?

Offline

#17 2018-05-30 07:07:33

grisu48
Member
Registered: 2017-06-07
Posts: 4

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Thanks InFerYes, this solution also works for me.

Offline

#18 2018-05-30 11:12:38

ratcheer
Member
Registered: 2011-10-09
Posts: 680

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

Doing the same as konpai fixed it for me.

Tim

Offline

#19 2018-05-30 13:53:39

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,865

Re: ffmpeg2.8: installing x265 (2.8-1) breaks dependency 'libx265.so=151-6

With all of the "Me too"s, I assume this thread is solved.
Closing


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB