You are not logged in.

#1 2018-06-10 00:05:44

ri0t
Member
Registered: 2018-06-10
Posts: 8

[SOLVED]ACPI infinite loop on poweroff or reboot

Hey,

I literally just got Arch working and I get this ACPI infinite loop whenever I reboot or poweroff the system, forcing me to physically shut it down

Here is what I get : ACPI Error: Method parse/execution failed \_SB.PCI0.PGOM, AE_AML_LOOP_TIMEOUT (20180105/psparse-550)
A similar error is right below except after "PGOM" there is a ._ON
Then comes in
blocking rcu_node structures :
INFO:rcu_preemp detected stalls on CPUs/task
And so on and so forth....

The thing is, on many other linux distros, ACPI would give me error messages on Boot, but never has it prevented me to shutdown the system. Of course, I would like to keep the features ACPI provides.

Any solutions to this ?

Thanks!

Last edited by ri0t (2018-06-10 17:06:10)

Offline

#2 2018-06-10 00:24:17

loqs
Member
Registered: 2014-03-06
Posts: 15,481

Re: [SOLVED]ACPI infinite loop on poweroff or reboot

Welcome to the arch linux forums ri0t.  Are the message recorded in the journal if you check the journal for previous boots?
If so please post the output from when you initiate a shutdown / reboot to the the end of the journal for that boot.
Edit:
spelling post not past.

Last edited by loqs (2018-06-10 00:24:46)

Offline

#3 2018-06-10 15:19:45

ri0t
Member
Registered: 2018-06-10
Posts: 8

Re: [SOLVED]ACPI infinite loop on poweroff or reboot

Before (not right before, but in the logs at some point) I see this warning that might be useful (?) ACPI Warning : \_SB.PCI0.GFX0._DSM : ARGUMENT #4 TYPE MISMATCH = FOUND (BUFFER), ACPI REQUIRES (PACKAGE) (20180105/nsarguments-100)
A similar error is right below it but instead of GFX0 it's PEG0.PEGP.

­https://ibb.co/jx0CHo
https://ibb.co/dPRV3T
https://ibb.co/kOVUxo

These are the three images I took. Sorry I have no access to a GUI on my Arch machine yet.

Offline

#4 2018-06-10 15:53:01

ri0t
Member
Registered: 2018-06-10
Posts: 8

Re: [SOLVED]ACPI infinite loop on poweroff or reboot

Okay. the command lspci -v recreates the problem.

https://ibb.co/k8NpV8

Offline

#5 2018-06-10 16:06:28

ri0t
Member
Registered: 2018-06-10
Posts: 8

Re: [SOLVED]ACPI infinite loop on poweroff or reboot

Nomodeset seems to solve the problem. It was probably an error due to nouveau. That being said, I have no clue on how to blacklist nouveau as doing the blacklist.conf file and running mkinitcpio -p linux does not seem to affect it.

Offline

#6 2018-06-10 16:20:04

ri0t
Member
Registered: 2018-06-10
Posts: 8

Re: [SOLVED]ACPI infinite loop on poweroff or reboot

Nevermind, configuring the blacklist.conf as follows as well as installing the nvidia driver and bumblebee seem to have fixed everything.

Here is my blacklist.conf :

blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
blacklist nv
blacklist uvcvideo

as proposed by i_love_r34 on this thread : https://bbs.archlinux.org/viewtopic.php?id=213042

Offline

#7 2018-06-10 16:27:25

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 17,620

Re: [SOLVED]ACPI infinite loop on poweroff or reboot

That's quite a random list and none of these are necessary. The only driver you should have to blacklist should be nouveau, but that happens automatically when you install a nvidia package. uvcvideo definitely has no relation to this, nv hasn't existed for years and the others also don't make much sense.

However if this works for you, please mark the topic as [SOLVED] by editing your initial post.

Last edited by V1del (2018-06-10 16:58:54)

Offline

Board footer

Powered by FluxBB