You are not logged in.

#1 2018-06-12 22:52:56

mkb613
Member
Registered: 2018-06-12
Posts: 2

[ERROR ON BOOT] Firmware Bug

Hey all I have recently installed arch Linux for the first time on my ASUS laptop model UX305U. Everything has been going well except for a couple of peculiar errors when booting up. I have read online about this error and tried many fixes and none of them have worked. My BIOS is up to date and i installed intel microcode. I am wondering if anyone has some unique solutions. If no solutions can be found what should I do short of going out and buying a new laptop? Would it be wrong to just ignore these errors?

journalctl -p 3 -xb output:

archlinux kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
archlinux kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80

Offline

#2 2018-06-12 23:00:43

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,133

Re: [ERROR ON BOOT] Firmware Bug

That is just a warning about a crappy DSDT (Differentiated System Description Table) for your machine's ACPI implementation.  It is common on consumer grade equipment which are designed to operate only toy operating systems from the American Pacific Northwest to have buggy DSDTs.  Ignore it unless you have any bad symptoms.  Otherwise, see the article I linked, but it is not for the feint of heart.

Last edited by ewaller (2018-06-12 23:01:12)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2018-06-12 23:05:17

mkb613
Member
Registered: 2018-06-12
Posts: 2

Re: [ERROR ON BOOT] Firmware Bug

Thank you for the quick reply and helpful answer!

Offline

#4 2018-06-13 18:57:46

outfit
Member
Registered: 2015-09-02
Posts: 18

Re: [ERROR ON BOOT] Firmware Bug

This does not help much and I guess you already know not to worry about it. But I have the same laptop and do not get the errors. If there are any commands or whatever you want me to output I would be happy to do so, to understand what makes your install different than mine.

Offline

Board footer

Powered by FluxBB