You are not logged in.

#1 2018-06-12 23:30:54

gcb
Member
Registered: 2014-02-12
Posts: 21

permanently fixing associated application

Every time i click a downloaded PDF on firefox, it opens GIMP.

I have already done what the random strangers on the internet suggests: edit some file with mimetypes (/usr/share/applications/mimeinfo.cache) and it solves the problem for a few days. Then i don't know what updates that file, and a random amount of time later, i open another PDF, and bam, gimp shows up again.

Is there a *correct* way to fix this problem?

I have never ever opened a PDF in gimp for years. When opening them via double click on the shell (kde, default file manager) it opens okular just fine. So obviously KDE and that mimeinfo file are not playing nice with each other and a third thing that i don't know what is overriding both my KDE and mimeinfo preferences with their preference for gimp. What is that third thing?!

thanks!

Offline

#2 2018-06-12 23:32:35

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,151
Website

Re: permanently fixing associated application


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2018-06-13 00:19:33

gcb
Member
Registered: 2014-02-12
Posts: 21

Re: permanently fixing associated application

That makes it sound even worse smile

`xdg-open somefile.pdf` correctly opens okular, in line with my file manager.

So it seems firefox is the culprit... but according to https://support.mozilla.org/en-US/kb/ch … -open-file there is a UI to set this. let's see what is set for PDF....  it is set to "save file", and the options under it are Gimp and okular (okular looks like was added by me some time in the past because it has the custom icon while gimp has the correct icon)

Maybe save file is the default, and when i click the file in the download dialog it picks the next one... i can't change the order... so let's change the default to be okular. ...and click a PDF file in the download window and... you guessed it! GIMP!

i think i give up. will try to install IE6 under wine and not deal with this anymore... sigh

What even is Firefox using to screw up file association this bad? it is not using the OS default (xdg-open), it is not using the selection on its own settings screen. Where is it picking this decision from?

Offline

#4 2018-06-13 00:30:11

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 27,151
Website

Re: permanently fixing associated application

I don't use Firefox, but I installed it, went to about:preferences and under General/Applications configured it to open .pdf files with zathura ("Use other" in the drop-down) and now it does...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2019-02-14 20:18:55

gcb
Member
Registered: 2014-02-12
Posts: 21

Re: permanently fixing associated application

thanks for checking it, anarchist!

This is oddly Interesting. The file association will work, and remember which was set at the time of download. E.g. if it is set to gimp and you save a.pdf, later you set to okular and save b.pdf, clicking the file in Firefox's download window will open gimp for a.pdf, and okular for b.pdf.

But my main problem, i set pdf (and everything else) to just save. Then it will save the file but when clicking the file in the download window it will open gimp, no matter what. It might be the first option in firefox's internal list or something. There is no way to make firefox save, and then obey the OS association.

I guess i will 'solve' this by setting it to open with okular and live with that. If I have to time i will take a look at their code and open a ticket with moz.

Offline

Board footer

Powered by FluxBB