You are not logged in.

#1 2018-06-23 09:41:44

huyizheng
Member
Registered: 2018-05-15
Posts: 8

[SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

I tried to load some ladspa plugins with pulseaudio by edit ~/.config/pulse/default.pa:

.nofail
.include /etc/pulse/default.pa
load-module module-ladspa-sink  sink_name=ladspa_sink  plugin=dyson_compress_1403  label=dysonCompress  control=0,1,0.5,0.99
load-module module-ladspa-sink  sink_name=ladspa_normalized  master=ladspa_sink  plugin=fast_lookahead_limiter_1913  label=fastLookaheadLimiter  control=10,0,0.8
set-default-sink ladspa_normalized

When I use pulseaudio 11.1, it works correctly, however when I upgrade pulseaudio to 12.0, these plugins cannot be loaded, when run "pulseaudio" in terminal it returns the following error:

$ pulseaudio
E: [pulseaudio] ltdl-bind-now.c: Failed to open module dyson_compress_1403.so: dyson_compress_1403.so: cannot open shared object file: No such file or directory
E: [pulseaudio] module-ladspa-sink.c: Failed to load LADSPA plugin: file not found
E: [pulseaudio] module.c: Failed to load module "module-ladspa-sink" (argument: "sink_name=ladspa_sink  plugin=dyson_compress_1403  label=dysonCompress  control=0,1,0.5,0.99"): initialization failed.
W: [pulseaudio] module-ladspa-sink.c: The 'master' module argument is deprecated and may be removed in the future, please use the 'sink_master' argument instead.
E: [pulseaudio] module-ladspa-sink.c: Master sink not found.
E: [pulseaudio] module.c: Failed to load module "module-ladspa-sink" (argument: "sink_name=ladspa_normalized  master=ladspa_sink  plugin=fast_lookahead_limiter_1913  label=fastLookaheadLimiter  control=10,0,0.8"): initialization failed.
E: [pulseaudio] main.c: Sink ladspa_normalized does not exist.

However I have the file dyson_compress_1403.so in /usr/lib/:

$ locate dyson_compress_1403.so
/usr/lib/ladspa/dyson_compress_1403.so

If I downgrade pulseaudio back to 11.1 it works again.

So anyone knows how can I fix this? Thanks.
Sorry for poor English.

Last edited by huyizheng (2018-06-23 13:02:20)

Offline

#2 2018-06-23 11:54:35

loqs
Member
Registered: 2014-03-06
Posts: 5,845

Re: [SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

Offline

#3 2018-06-23 11:56:36

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,261

Re: [SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

Does it work if you manually set LADSPA_PATH?

Since you are the second person posting this, I did some digging, and suspect https://cgit.freedesktop.org/pulseaudio … 6e2ff7833c to be the culprit of this.

Offline

#4 2018-06-23 12:04:42

loqs
Member
Registered: 2014-03-06
Posts: 5,845

Re: [SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

That commit seems really bizarre asserting define QUOTE_MACRO(x) #x will escape anything and that LADSPA_PATH is a macro.

Offline

#5 2018-06-23 12:21:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,261

Re: [SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

Seeing as the commit  seems to be from someone that had "some" undefined issue on Windows I'm not entirely sure what to make of it either, I'm wondering why it was even merged that way

Offline

#6 2018-06-23 12:40:48

loqs
Member
Registered: 2014-03-06
Posts: 5,845

Re: [SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

I think the intended result was supposed to follow https://gcc.gnu.org/onlinedocs/cpp/Stringizing.html

Offline

#7 2018-06-23 13:00:21

huyizheng
Member
Registered: 2018-05-15
Posts: 8

Re: [SOLVED] Pulseaudio cannot load ladspa plugin when upgrade to 12.0

V1del wrote:

Does it work if you manually set LADSPA_PATH?

Since you are the second person posting this, I did some digging, and suspect https://cgit.freedesktop.org/pulseaudio … 6e2ff7833c to be the culprit of this.

Yes, by adding "export LADSPA_PATH=/usr/lib/ladspa" to my ~/.xprofile and it works.
Thanks.

Offline

Board footer

Powered by FluxBB