You are not logged in.

#1 2018-06-24 16:51:08

sakf
Member
Registered: 2017-05-11
Posts: 6

Touchpad settings on plasma 5 not persistent

Since updating to plasma 5.13 the touchpad settings set in kcm are no longer persistent. Whenever I reboot the scroll direction is inverted again and kcm complains about the saved settings not matching the active settings. Does anyone know how to fix this? I'm using libinput on xorg. (synaptics is not an option as it often recognizes too many touches.)

Offline

#2 2018-06-24 22:48:10

imrel
Member
Registered: 2018-06-24
Posts: 3

Re: Touchpad settings on plasma 5 not persistent

I had exact same issues - and also resetting when coming back from extended sleep.

I have libinput and touchpad configured in /etc/X11/xorg.conf.d/30-touchpad.conf
Option "NaturalScrolling" "true"

kcm conf: ~/.config/touchpadrc
InvertVertScroll=true

Maybe it wasn't saving before? can't confirm as i can not reproduce the problem after
I disabled and enabled Background Services > Startup Services > Touchpad


There appears to be had some changes to Touchpad KCM https://cgit.kde.org/plasma-desktop.git … f3d5cdf0ab

Offline

#3 2018-06-25 03:35:44

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,099

Re: Touchpad settings on plasma 5 not persistent

Possibly this is the issue I reported having in this thread: https://bbs.archlinux.org/viewtopic.php?id=238242. I'm suspicious that KDE is interfering somehow, but I'm not sure.

Most of my settings are remembered, but those whose names were changed in the recent libinput update are not.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#4 2018-06-25 17:59:07

sakf
Member
Registered: 2017-05-11
Posts: 6

Re: Touchpad settings on plasma 5 not persistent

I think it might be be an issue with kde's touchpad service. It's not only the non-persisting setttings, but also it doesn't enable/disable the touchpad when i connect a mouse. Any ideas on how to check this?

Offline

#5 2018-06-26 01:31:10

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,099

Re: Touchpad settings on plasma 5 not persistent

imrel wrote:

kcm conf: ~/.config/touchpadrc
InvertVertScroll=true

Are you sure that's the right file? Mine was last changed on 4th October 2017 and sets acceleration speed to 1. Yet the acceleration speed is one of the settings which doesn't persist and I've since tried saving this setting through the GUI (to match what's set in xorg.conf.d/50-libinput-cfr.conf.

Maybe it wasn't saving before? can't confirm as i can not reproduce the problem after
I disabled and enabled Background Services > Startup Services > Touchpad

Hmm ... somebody suggested disabling it in my earlier thread, but maybe I should try re-enabling it.

But there is some muddling issue of settings: settings which should only be applied to non-touchpad and non-trackpoint mice are also applied to touchpads and trackpoints. And unsetting them doesn't persist either.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#6 2018-06-28 18:42:02

imrel
Member
Registered: 2018-06-24
Posts: 3

Re: Touchpad settings on plasma 5 not persistent

it was KDE applying its default settings over my user and xorg settings

most probably this is fixed with 5.13.2 update now
https://bbs.archlinux.org/viewtopic.php?pid=1792722

Offline

#7 2018-06-30 20:28:54

imrel
Member
Registered: 2018-06-24
Posts: 3

Re: Touchpad settings on plasma 5 not persistent

still happening

seems like mouse and touchpad settings are in conflict:

when i run `kcminit mouse` it turns natural scrolling off
`kcminit kcm_touchpad` turns it on

since kcm_touchpad settings are applied before, the settings will be overwritten - i have no solution for this currently.
I want to have different settings for mouse and touchpad

Offline

#8 2018-07-12 22:06:41

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,099

Re: Touchpad settings on plasma 5 not persistent

imrel wrote:

still happening

seems like mouse and touchpad settings are in conflict:

when i run `kcminit mouse` it turns natural scrolling off
`kcminit kcm_touchpad` turns it on

since kcm_touchpad settings are applied before, the settings will be overwritten - i have no solution for this currently.
I want to have different settings for mouse and touchpad

Me, too. I also want separate trackpoint settings, which the mouse settings also override.

Is it possible to block kcminit from running either the mouse or touchpad modules? I know that these depend on desktop files, though I'm not entirely certain which. That is, I found a Fedora bug complaining that the settings weren't applied because one of the mouse.desktop files was missing.

How can I emulate that bug on Arch Linux?!

I want Fedora bugs in Arch.

kcminit mouse

reproduces the problem with both touchpad and trackpoint settings: KDE is failing to apply the settings selectively just to mice.

In truth, I'd rather KDE didn't touch my mice, touchpad or trackpoint at all and just let the config I have in /etc alone. But I can't find a way to prevent it interfering.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

Board footer

Powered by FluxBB